Community discussions

MikroTik App
 
LFHarada
just joined
Topic Author
Posts: 6
Joined: Mon Oct 17, 2022 8:59 pm

PiHole Docker container simply refuses to run on a MikroTik RB3011UiAS (RouterOS 7.13.3)

Thu Feb 22, 2024 9:33 am

Hi everyone, hope you are all doing fine.

So, i'm a newbie into containers in MikroTik, but i know some stuff about Docker, i have this problem where i'm trying to setup PiHole as my DNS Server but the container simply refuses to run.

I was following this tutorial from The Network Berg but i've encountered some issues with it, some needed info was not present in the video, like the need of activating containers in the device mode, also as this is an old video, the Docker Registry URL wasn't updated, anyway, i've managed to create the container and everything but when i start it, it runs for about 1 or 2 seconds and then it stops without generating a single line of log...

Also, i've tried to run it from these registry URLs:
- https://registry-1.docker.io
- https://registry.hub.docker.com
- https://registry.hub.docker.com/v2/
- https://index.docker.io/v2/
- https://index.docker.io/v1/
All of them leads to the same result, so i don't think it's the problem.

Here is some config and troubleshooting that i've done until now i'm only showing configs related to the problem though, of course, I'll save you from having to see the entire thing, just comment if you need some extra info, i hope it may help you understand what is happening, maybe you guys can see something that i can't. By the way, i haven't done any DNS config neither changes on the routing table because i'm stuck at this point where i can't even run the container.
[MyUsername@MikroTik-RB3011UiAS] > export
# 2024-02-22 03:16:18 by RouterOS 7.13.3
# software id = 73G8-DCW6
#
# model = RB3011UiAS
# serial number = XXXXXXXXXXXX

/disk
set usb1 type=hardware

/ip address
add address=10.0.0.1/24 comment="Gateway IP Address | Docker Network" interface=Docker network=10.0.0.0

/ip firewall nat
add action=masquerade chain=srcnat comment="NAT for Internet | Docker to PPPoE Algar Telecom" out-interface=PPPoE-AlgarTelecom src-address=10.0.0.0/24

/interface bridge
add name=Docker

/interface veth
add address=10.0.0.100/24 comment="Docker Virtual Interface" gateway=10.0.0.1 gateway6="" name=veth1-DockerPiHole

/interface bridge port
add bridge=Docker interface=veth1-DockerPiHole

/container mounts
add dst=/etc/pihole name=etc_pihole src=/usb1/etc
add dst=/etc/dnsmasq.d name=dnsmasq_pihole src=/usb1/etc-dnsmasq.d

/container envs
add key=TZ name=envs_pihole value=America/Sao_Paulo
add key=WEBPASSWORD name=envs_pihole value=XXXXXXXXXXXXXXX
add key=DNSMASQ_USER name=envs_pihole value=root

/container config
set registry-url=https://registry.hub.docker.com tmpdir=usb1/tmpdir

/container
add dns=1.1.1.1,8.8.8.8 envlist=envs_pihole hostname=PiHole-DNS-Server interface=veth1-DockerPiHole logging=yes mounts=etc_pihole,dnsmasq_pihole root-dir=usb1/pihole start-on-boot=yes

[MyUsername@MikroTik-RB3011UiAS] > system/device-mode/print                                                                                                                                                                                                        
       mode: enterprise
  container: yes

[MyUsername@MikroTik-RB3011UiAS] > ping 8.8.8.8
  SEQ HOST                                     SIZE TTL TIME       STATUS                                                                                                                                                                                                                                                                             
    0 8.8.8.8                                    56 120 10ms953us 
    1 8.8.8.8                                    56 120 11ms42us  
    2 8.8.8.8                                    56 120 10ms636us 
    3 8.8.8.8                                    56 120 11ms45us  
    4 8.8.8.8                                    56 120 10ms868us 
    sent=5 received=5 packet-loss=0% min-rtt=10ms636us avg-rtt=10ms908us max-rtt=11ms45us 

[MyUsername@MikroTik-RB3011UiAS] > ping google.com
  SEQ HOST                                     SIZE TTL TIME       STATUS                                                                                                                                                                                                                                                                             
    0 142.250.218.14                             56 119 8ms635us  
    1 142.250.218.14                             56 119 8ms521us  
    2 142.250.218.14                             56 119 8ms540us  
    3 142.250.218.14                             56 119 8ms568us  
    4 142.250.218.14                             56 119 8ms649us  
    sent=5 received=5 packet-loss=0% min-rtt=8ms521us avg-rtt=8ms582us max-rtt=8ms649us 

[MyUsername@MikroTik-RB3011UiAS] > ping 10.0.0.1
  SEQ HOST                                     SIZE TTL TIME       STATUS                                                                                                                                                                                                                                                                             
    0 10.0.0.1                                   56  64 447us     
    1 10.0.0.1                                   56  64 337us     
    2 10.0.0.1                                   56  64 658us     
    3 10.0.0.1                                   56  64 250us     
    4 10.0.0.1                                   56  64 425us     
    sent=5 received=5 packet-loss=0% min-rtt=250us avg-rtt=423us max-rtt=658us 

[MyUsername@MikroTik-RB3011UiAS] > ping 10.0.0.100
  SEQ HOST                                     SIZE TTL TIME       STATUS                                                                                                                                                                                                                                                                             
    0 10.0.0.100                                 56  64 386us     
    1 10.0.0.100                                 56  64 271us     
    2 10.0.0.100                                 56  64 474us     
    3 10.0.0.100                                 56  64 428us     
    4 10.0.0.100                                 56  64 284us     
    sent=5 received=5 packet-loss=0% min-rtt=271us avg-rtt=368us max-rtt=474us

[MyUsername@MikroTik-RB3011UiAS] > /tool fetch url="https://registry-1.docker.io" mode=https  
  status: failed

failure: Fetch failed with status 503

[MyUsername@MikroTik-RB3011UiAS] > /tool fetch url="https://registry.hub.docker.com" mode=https  
      status: finished
  downloaded: 2KiBC-z pause]
    duration: 0s

[MyUsername@MikroTik-RB3011UiAS] > /container/print
 0 name="5b016124-cf3e-4d2b-95ad-a2f6ee4a7b75" tag="pihole/pihole:latest" os="linux" arch="arm" interface=veth1-DockerPiHole envlist="envs_pihole" root-dir=usb1/pihole mounts=etc_pihole,dnsmasq_pihole dns=1.1.1.1,8.8.8.8 hostname="PiHole-DNS-Server" logging=yes start-on-boot=yes status=stopped 

[MyUsername@MikroTik-RB3011UiAS] > /log/print
 03:25:00 container,info,debug importing remote image: pihole/pihole, tag: latest
 03:25:00 system,info item added by winbox-3.40/tcp-msg(winbox):MyUsername@10.0.99.253 (*7 = /container add dns=1.1.1.1,8.8.8.8 envlist=envs_pihole file="" hostname=PiHole-DNS-Server interface=veth1-DockerPiHole logging=yes mounts=etc_pihole,dnsmasq_pihole remote-image=pihole/pihole:latest root-dir=usb1/pihole start-on-boot=yes)
 03:25:05 container,info,debug getting layer sha256:4de6a546d77461a35cb9514c6432142adfb72460cf04bac21bd261d66c288476
 03:25:17 container,info,debug layer sha256:4de6a546d77461a35cb9514c6432142adfb72460cf04bac21bd261d66c288476 downloaded
 03:25:36 container,info,debug getting layer sha256:4a5db933f96b99df6887f7ee962a20b94bbd7ca59136d8d4ea3a9caa551995d7
 03:25:55 container,info,debug layer sha256:4a5db933f96b99df6887f7ee962a20b94bbd7ca59136d8d4ea3a9caa551995d7 downloaded
 03:27:52 container,info,debug getting layer sha256:4f4fb700ef54461cfa02571ae0db9a0dc1e0cdb5577484a6d75e68dc38e8acc1
 03:27:53 container,info,debug layer sha256:4f4fb700ef54461cfa02571ae0db9a0dc1e0cdb5577484a6d75e68dc38e8acc1 downloaded
 03:27:53 container,info,debug getting layer sha256:ae48e9d33be8c558a4709cafd6df02138eab49d77a15b596fa68b79aed5e71f2
 03:27:53 container,info,debug layer sha256:ae48e9d33be8c558a4709cafd6df02138eab49d77a15b596fa68b79aed5e71f2 downloaded
 03:27:53 container,info,debug getting layer sha256:4b3d745d8800719c74913421a2803649890c3d4c9e24ee0751cfb52fb1ed01e6
 03:27:56 container,info,debug layer sha256:4b3d745d8800719c74913421a2803649890c3d4c9e24ee0751cfb52fb1ed01e6 downloaded
 03:27:56 container,info,debug getting layer sha256:94c69318b5adac2f0882c2aecd3db5b83ebfcd0130f28b291313e5dc77e8d816
 03:27:58 container,info,debug layer sha256:94c69318b5adac2f0882c2aecd3db5b83ebfcd0130f28b291313e5dc77e8d816 downloaded
 03:27:58 container,info,debug getting layer sha256:a374290c7967563847cef48b76addaffd3488ee18069a5073cb40b2922184324
 03:28:06 container,info,debug layer sha256:a374290c7967563847cef48b76addaffd3488ee18069a5073cb40b2922184324 downloaded
 03:28:55 container,info,debug getting layer sha256:351c2d4202359795c6ee7dd523aa2981afc632fd72565a38f98013095eff1868
 03:29:00 container,info,debug layer sha256:351c2d4202359795c6ee7dd523aa2981afc632fd72565a38f98013095eff1868 downloaded
 03:29:00 container,info,debug getting layer sha256:7ce34a9eaa2582ff097a9f8f83c2ed234d637c5254ec9c9d692802c1da77342f
 03:29:03 container,info,debug layer sha256:7ce34a9eaa2582ff097a9f8f83c2ed234d637c5254ec9c9d692802c1da77342f downloaded
 03:29:03 container,info,debug import successful, container 5b016124-cf3e-4d2b-95ad-a2f6ee4a7b75

[MyUsername@MikroTik-RB3011UiAS] > /disk/print
Flags: B - BLOCK-DEVICE; M - MOUNTED
Columns: SLOT, MODEL, SERIAL, INTERFACE, SIZE, FREE, FS
#    SLOT  MODEL                      SERIAL                    INTERFACE                    SIZE            FREE  FS  
0 BM usb1  Kingston DataTraveler 3.0  E0D55EA57424E4B1894E0C29  USB 3.20 5000Mbps  62 058 921 984  60 695 384 064  ext4

[MyUsername@MikroTik-RB3011UiAS] > /file/print
Columns: NAME, TYPE, SIZE, CREATION-TIME
 #  NAME                                                         TYPE              SIZE       CREATION-TIME      
33  usb1                                                         disk                         2024-02-20 05:42:16
34  usb1/pihole                                                  container store              2024-02-20 05:41:43
35  usb1/etc-dnsmasq.d                                           container store              2024-02-20 05:42:16
36  usb1/tmpdir                                                  directory                    2024-02-22 03:29:03
37  usb1/etc                                                     directory                    2024-02-20 05:42:13
38  usb1/etc/custom.list                                         .list file        0          2024-02-20 05:42:03
39  usb1/etc/dns-servers.conf                                    .conf file        651        2024-02-20 05:42:03
40  usb1/etc/gravity.db                                          .db file          8.8MiB     2024-02-20 05:42:03
41  usb1/etc/gravity_old.db                                      .db file          92.0KiB    2024-02-20 05:42:08
42  usb1/etc/install.log                                         .log file         849        2024-02-20 05:42:08
43  usb1/etc/list.1.raw.githubusercontent.com.domains            .domains file     3200.9KiB  2024-02-20 05:42:08
44  usb1/etc/list.1.raw.githubusercontent.com.domains.sha1       .sha1 file        95         2024-02-20 05:42:13
45  usb1/etc/local.list                                          .list file        65         2024-02-20 05:42:13
46  usb1/etc/logrotate                                           file              241        2024-02-20 05:42:13

Who is online

Users browsing this forum: No registered users and 1 guest