Community discussions

MikroTik App
 
User avatar
stmx38
Long time Member
Long time Member
Topic Author
Posts: 581
Joined: Thu Feb 14, 2008 4:03 pm
Location: Moldova, Chisinau

Dude v6 - SMS notification through smspilot.ru - using fetch tool

Thu May 18, 2017 11:52 pm

Related solutions
Dude v6 - SMS notification

Requirements
1. Mikrotik ROS with installed Dude server.
2. Account on smspilot.ru

Setup instruction
1. Create new Notification in Dude
Name: SMS-Notification-smspilot.ru
Type: execute on server
Command:
# Variables
:local notificationtext "Service [Probe.Name] on [Device.Name] is now [Service.Status]"
:local url "http://smspilot.ru/api.php"
:local apikey "154YCR22XL9IS4UR8YRO7GFQ81PGN6Z3OD1BXY726N854S52I3046CZ0R8JXR2SH"
#
#
# First Name Last Name
:local to "+xxxxxxxxxxx"
#
/tool fetch output=none url="$url\?apikey=$apikey&to=$to&send=$notificationtext"
And test it via pressing Test button.

2. Now you can use it:
Dude-v6-SMS-notification-through-smspilot.ru-using-fetch-tool-01.png
Related Wiki topics
Manual:Tools/Fetch

Hope this will help someone.
You do not have the required permissions to view the files attached to this post.
Last edited by stmx38 on Tue Mar 22, 2022 8:02 am, edited 5 times in total.
 
netx34
just joined
Posts: 4
Joined: Sat Jan 13, 2018 1:43 pm

Re: Dude v6 - SMS notification through smspilot.ru - using fetch tool

Tue Sep 07, 2021 2:08 am

i got error of "url" invalid how can i test it,
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 9479
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: Dude v6 - SMS notification through smspilot.ru - using fetch tool

Tue Sep 07, 2021 2:14 am

(the \ on \? must be set only if tested on terminal, on script the \ must be removed)

probably because after 6 years the service do not work anymore or has changed syntax...
 
netx34
just joined
Posts: 4
Joined: Sat Jan 13, 2018 1:43 pm

Re: Dude v6 - SMS notification through smspilot.ru - using fetch tool

Tue Sep 07, 2021 2:27 am

its working hehehhee, i forgot to install the Dude Client side

Who is online

Users browsing this forum: No registered users and 2 guests