Community discussions

MikroTik App
 
Alisina23
just joined
Topic Author
Posts: 7
Joined: Thu Aug 10, 2017 3:13 pm
Location: Tehran
Contact:

Safari cant go to the Hotspot Login page

Thu Aug 10, 2017 3:31 pm

Hi,

My Device is Hap ac lite(RB952) and I configured HotSpot on WLAN1 .
The hotspot login page worked fine and open on Android Devices and windows devices. The problem is Safari on Iphone !
Safari can't open the hotspot login page with no ERRORs (my connection is HTTP and I don't have any certificate to login HTTPS) ! I can't understand what is the problem ! :? :(
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 25389
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Safari cant go to the Hotspot Login page

Thu Aug 10, 2017 3:37 pm

Do you have any settings in the walled garden?
 
Alisina23
just joined
Topic Author
Posts: 7
Joined: Thu Aug 10, 2017 3:13 pm
Location: Tehran
Contact:

Re: Safari cant go to the Hotspot Login page

Thu Aug 10, 2017 3:50 pm

Do you have any settings in the walled garden?
No Settings in the walled garden...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 25389
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Safari cant go to the Hotspot Login page

Thu Aug 10, 2017 3:54 pm

Please post your configuration export file here, or email your supout.rif file to support.
iPhone normally does show the login popup.
 
Alisina23
just joined
Topic Author
Posts: 7
Joined: Thu Aug 10, 2017 3:13 pm
Location: Tehran
Contact:

Re: Safari cant go to the Hotspot Login page

Fri Aug 11, 2017 11:41 am

Please post your configuration export file here, or email your supout.rif file to support.
iPhone normally does show the login popup.
Do you mean that I must to post the backup of my device?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 25389
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Safari cant go to the Hotspot Login page

Fri Aug 11, 2017 11:43 am

type "/export" in the command line. copy and paste here.
 
Alisina23
just joined
Topic Author
Posts: 7
Joined: Thu Aug 10, 2017 3:13 pm
Location: Tehran
Contact:

Re: Safari cant go to the Hotspot Login page

Fri Aug 11, 2017 3:13 pm

type "/export" in the command line. copy and paste here.
Here is my device configuration!

[a.salehi@RB952-Resthouse] > /export
# aug/11/2017 21:12:49 by RouterOS 6.37.1
# software id = ZJ3M-ESHW
#
/interface bridge
add name=Local
add name=Net
/interface ethernet
set [ find default-name=ether1 ] name=ether6
/ip hotspot profile
add dns-name=rojinet.local hotspot-address=100.1.1.11 html-directory=flash/hotspot login-by=\
http-chap,https,http-pap,mac-cookie name=hsprof1
/ip hotspot user profile
add idle-timeout=2h name=Guest rate-limit=819200 transparent-proxy=yes
/ip pool
add name=hs-pool-17 ranges=100.1.1.20-100.1.1.80
/ip dhcp-server
add address-pool=hs-pool-17 disabled=no interface=Net name=dhcp1
/ip hotspot
add address-pool=hs-pool-17 disabled=no interface=Net name=hotspot1 profile=hsprof1
/ip hotspot user profile
add address-pool=hs-pool-17 idle-timeout=30m name=Stable rate-limit=819200 transparent-proxy=yes
add address-pool=hs-pool-17 idle-timeout=15m name=Weekly rate-limit=409600 transparent-proxy=yes
add address-pool=hs-pool-17 name=MGMT rate-limit=1638400 shared-users=unlimited transparent-proxy=yes
add address-pool=hs-pool-17 name=CEO shared-users=3 transparent-proxy=yes
add add-mac-cookie=no address-pool=hs-pool-17 idle-timeout=1s keepalive-timeout=10s name=STH session-timeout=10s \
shared-users=10 transparent-proxy=yes
/system logging action
set 1 disk-file-name=flash/log
#error exporting /tool user-manager customer
#error exporting /tool user-manager profile
#error exporting /tool user-manager profile limitation
/interface bridge port
add bridge=Net
add bridge=Net
add bridge=Local
add bridge=Local
/ip address
add address=192.192.168.222/24 network=192.192.168.0
add address=100.1.1.11/24 interface=Net network=100.1.1.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=Local
/ip dhcp-relay
add dhcp-server=10.139.1.10 disabled=no interface=Local name=relay1
/ip dhcp-server network
add address=100.1.1.0/24 dns-server=8.8.8.8 gateway=100.1.1.11
add address=200.1.1.0/24 dns-server=8.8.8.8 gateway=200.1.1.10
/ip dns
set servers=8.8.8.8
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes
add action=masquerade chain=srcnat src-address=100.1.1.0/24
/ip hotspot user
add limit-bytes-total=4294967296 name=r.sadeghi password=8526 profile=Stable server=hotspot1
add name=a.salehi password=1374 profile=MGMT server=hotspot1
add limit-bytes-total=4294967296 name=gh.bordbar password=7418 profile=Stable server=hotspot1
add name=1 password=1 profile=STH server=hotspot1
add name=somaie password=3194 server=hotspot1
/ip route
add distance=1 gateway=192.192.168.91
/system clock
set time-zone-name=Asia/Tehran
/system identity
set name=RB952-Resthouse
/system lcd
set contrast=0 enabled=no port=parallel type=24x4
/system lcd page
set time disabled=yes display-time=5s
set resources disabled=yes display-time=5s
set uptime disabled=yes display-time=5s
set packets disabled=yes display-time=5s
set bits disabled=yes display-time=5s
set version disabled=yes display-time=5s
set identity disabled=yes display-time=5s
set Net disabled=yes display-time=5s
set Local disabled=yes display-time=5s
set ether6 disabled=yes display-time=5s
/system leds
add leds="" type=interface-activity
add leds="" type=interface-activity
add leds="" type=interface-activity
add leds="" type=interface-activity
add leds="" type=interface-activity
/system scheduler
add interval=4w2d name="Reset HS Counters Schedule" on-event="Reset HS User Counters" policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=aug/07/2017 start-time=18:24:33
/system script
add name="Reset HS User Counters" owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
source="/ip hotspot user reset-counters\r\
\n\r\
\n"
#error exporting /tool user-manager database
#error exporting /tool user-manager profile profile-limitation
#error exporting /tool user-manager router
#error exporting /tool user-manager user
[a.salehi@RB952-Resthouse] >
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1522
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: Safari cant go to the Hotspot Login page

Fri Aug 11, 2017 3:38 pm

Due to this "dns-name=rojinet.local" your clients are redirected to "rojinet.local " Hotspot page, but does your DNS server which is used by clients has such static DNS entry?

If this router would be your LAN DHCP server, then:
"/ip dns static add name=rojinet.local address=100.1.1.11"

I think that easier test would be to unset dns-name parameter on Hotspot settings and test it then.
 
Alisina23
just joined
Topic Author
Posts: 7
Joined: Thu Aug 10, 2017 3:13 pm
Location: Tehran
Contact:

Re: Safari cant go to the Hotspot Login page

Fri Aug 11, 2017 3:54 pm

Due to this "dns-name=rojinet.local" your clients are redirected to "rojinet.local " Hotspot page, but does your DNS server which is used by clients has such static DNS entry?

If this router would be your LAN DHCP server, then:
"/ip dns static add name=rojinet.local address=100.1.1.11"

I think that easier test would be to unset dns-name parameter on Hotspot settings and test it then.
Thanks for your guidance,
I'll set the 100.1.1.11 as DNS and test it, but why are all of the Devices (except Iphone) work fine?
 
Alisina23
just joined
Topic Author
Posts: 7
Joined: Thu Aug 10, 2017 3:13 pm
Location: Tehran
Contact:

Re: Safari cant go to the Hotspot Login page

Tue Aug 15, 2017 6:53 am

Due to this "dns-name=rojinet.local" your clients are redirected to "rojinet.local " Hotspot page, but does your DNS server which is used by clients has such static DNS entry?

If this router would be your LAN DHCP server, then:
"/ip dns static add name=rojinet.local address=100.1.1.11"

I think that easier test would be to unset dns-name parameter on Hotspot settings and test it then.
Nothing happen !!!
Safari cant open the hotspot login page !!!
Safari redirected to the hotspot login page, but Login page didn't load!
 
parabellium
just joined
Posts: 9
Joined: Wed Nov 11, 2015 10:30 am

Re: Safari cant go to the Hotspot Login page

Thu Nov 30, 2017 9:27 am

Hi, problem is .local domain name. Change rojinet.local to rojinet.info or com,net......
 
folkert
just joined
Posts: 20
Joined: Thu Oct 04, 2012 6:57 pm

Re: Safari cant go to the Hotspot Login page

Wed Oct 23, 2019 2:17 pm

Hi, problem is .local domain name. Change rojinet.local to rojinet.info or com,net......
Solved it for me!
 
kimze
just joined
Posts: 1
Joined: Fri Dec 31, 2021 10:15 am

Re: Safari cant go to the Hotspot Login page

Sun Jan 02, 2022 2:44 pm

IP > hotspot >server profiles> uncheck DNS name,
works fine

Who is online

Users browsing this forum: No registered users and 3 guests