Community discussions

MikroTik App
 
hcstokka
just joined
Topic Author
Posts: 1
Joined: Fri Jul 12, 2013 11:01 pm

BGP issues after 6.47.9 -> 7.2 upgrade  [SOLVED]

Tue Apr 05, 2022 9:46 pm

Have a CHR with a pretty basic BGP setup announcing a /24 public subnet. Config is working fine in 6.47.9. After upgrading to ROS7 I ran into some issues.

Config below works fine in 7.2. I can see BGP session is up and when running a torch on ether1 I can see traffic with destination 1.1.1.0/24 reacing the interface.

However, if I add 1.1.1.1/24 to a interface, BGP session drops. What am I missing?

Edit:
Adding WAN IP to BGP Connection "Local Address" solved the issue.
/ip firewall address-list
add address=1.1.1.0/24 list=bgp-networks

/routing filter rule
add chain=bgp-out disabled=no rule="if (dst == 1.1.1.0/24) { accept; }"
add chain=bgp-out disabled=no rule="reject;"

/routing bgp template
set default as=12345 disabled=no output.filter-chain=bgp-out .network=bgp-networks .no-client-to-client-reflection=yes .redistribute=connected router-id=[WAN IP] routing-table=main vrf=main

/routing bgp connection
add as=12345 cisco-vpls-nlri-len-fmt=auto-bits connect=yes disabled=no listen=yes local.role=ebgp multihop=yes name=bgp output.filter-chain=bgp-out .network=bgp-networks .no-client-to-client-reflection=yes .redistribute=connected remote.address=1.2.3.4/32 .as=12345 .port=179 router-id=[WAN IP] routing-table=main templates=default vrf=main

/ip route
add blackhole disabled=no dst-address=1.1.1.0/24 gateway=0.0.0.0 routing-table=main suppress-hw-offload=no

Who is online

Users browsing this forum: mada3k, Semrush [Bot] and 8 guests