Community discussions

MikroTik App
 
fabioanz
just joined
Topic Author
Posts: 4
Joined: Tue Apr 19, 2022 3:09 pm

ROSv7.2.1 RIP Configuration

Tue Apr 19, 2022 3:23 pm

Hi there!
I'm currently getting started with Mikrotik but I'm have some troubles with RIP that I am unfortunately not able to resolve via some tutorials, as most still use the "old" ROS version.

My Situation:
As seen in the attchments my topology is mostly Cisco-based, with the exception for B4 which is a Mikrotik CHR. The Mikrotik Router should propagete the IPs of his tunnel-interfaces and its' lo1 interface.
Here my configuration:
[admin@MikroTik] > routing/rip/export
# apr/19/2022 12:22:18 by RouterOS 7.2.1
# software id =
#
/routing rip instance
add disabled=no name=default
/routing rip interface-template
add disabled=no instance=default interfaces=tun1,tun2,tun3,lo1

The Router receives RIP routes from the neighbors but does not send any.

Now my question: How can I specify the neworks it shoudl distribute?

Best Regards,
Fabio
You do not have the required permissions to view the files attached to this post.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6827
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: ROSv7.2.1 RIP Configuration

Tue Apr 19, 2022 5:04 pm

You are redistributing routes by enabling "redistribute" options in RIP instance configuration.
 
fabioanz
just joined
Topic Author
Posts: 4
Joined: Tue Apr 19, 2022 3:09 pm

Re: ROSv7.2.1 RIP Configuration

Tue Apr 19, 2022 6:18 pm

Thanks for your quick answer!
From my understanding that way I would only be able to redistribute all connected/static/... routes. In my case I want to distribute just some of my connected routes. How would I go about this?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6827
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: ROSv7.2.1 RIP Configuration  [SOLVED]

Tue Apr 19, 2022 6:33 pm

Enable connected redistribution and set up output routing filter to accept only specific prefixes
 
fabioanz
just joined
Topic Author
Posts: 4
Joined: Tue Apr 19, 2022 3:09 pm

Re: ROSv7.2.1 RIP Configuration

Tue Apr 19, 2022 8:47 pm

Thanks that would work for me. I only found one resource to do that in ROSv7 but unfortunately it didn't work.
What would be a correct rule if for example I want to allow the distribution of the route for the network 192.168.2.0/24

From the example I found online I would do it like that:
/routing/filter/rule add chain=rip_out rule="if (dst in 192.168.2.0/24 && dst-len==24 && protocol rip) { accept }"
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6827
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: ROSv7.2.1 RIP Configuration

Tue Apr 19, 2022 8:50 pm

remove "protocol rip" otherwise the rule will try to match only redistributed routes from other RIP instances.
 
fabioanz
just joined
Topic Author
Posts: 4
Joined: Tue Apr 19, 2022 3:09 pm

Re: ROSv7.2.1 RIP Configuration

Wed Apr 20, 2022 12:38 am

Thank you! You saved the day :D
 
eifLZ9D8zSwW
just joined
Posts: 7
Joined: Sat May 30, 2015 10:26 am

Re: ROSv7.2.1 RIP Configuration

Wed Feb 08, 2023 9:37 pm

Hi,
I would like to ask if normal (not redistribution) route advertisement is on road map in near future.
thank you

Who is online

Users browsing this forum: No registered users and 1 guest