Community discussions

MikroTik App
 
User avatar
loloski
Member Candidate
Member Candidate
Topic Author
Posts: 168
Joined: Mon Mar 15, 2021 9:10 pm

ROS v6.49.6 BGP Aggregate

Fri Apr 29, 2022 3:11 pm

Trying to setup a BGP Aggregate in the lab with summary only but it won't work
[admin@USGW] > ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADS  0.0.0.0/0                          192.168.122.1             1
 1 ADC  10.10.10.0/30      10.10.10.1      ether2                    0
 2 ADbU 103.xxx.80.0/23                                             20
 3 ADb  103.xxx.80.0/24                    10.10.10.2               20
 4 ADb  103.xxx.81.0/24                    10.10.10.2               20
exported configuration
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing bgp instance
set default client-to-client-reflection=no disabled=yes
add as=65530 client-to-client-reflection=no name=USG-SS router-id=10.10.10.1
/ip address
add address=10.10.10.1/30 interface=ether2 network=10.10.10.0
/ip dhcp-client
add disabled=no interface=ether1
/ip dns
set servers=8.8.8.8
/routing bgp aggregate
add inherit-attributes=no instance=USG-SS prefix=103.xx.80.0/23
/routing bgp network
add network=1.1.1.0/24 synchronize=no
/routing bgp peer
add default-originate=always instance=USG-SS name=PEER-SS remote-address=\
    10.10.10.2 remote-as=65531 remove-private-as=yes use-bfd=yes
/system identity
set name=USGW
/system logging
add topics=bgp
/tool romon
set enabled=yes
Care to share anyone i tried both 6.48.6 LTS and 6.49.6 exhibit same behavior
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6818
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: ROS v6.49.6 BGP Aggregate  [SOLVED]

Fri Apr 29, 2022 3:17 pm

Why do you think that it is not working?
By looking at the routing table I would say that it is working, aggregated 2 ADbU 103.xxx.80.0/23 is created.
 
User avatar
loloski
Member Candidate
Member Candidate
Topic Author
Posts: 168
Joined: Mon Mar 15, 2021 9:10 pm

Re: ROS v6.49.6 BGP Aggregate

Fri Apr 29, 2022 3:33 pm

I'm expecting it will create only a single routing entry with /23 prefix just like in cisco
 
User avatar
loloski
Member Candidate
Member Candidate
Topic Author
Posts: 168
Joined: Mon Mar 15, 2021 9:10 pm

Re: ROS v6.49.6 BGP Aggregate

Fri Apr 29, 2022 3:43 pm

I think i know now the issue, the topology and my assumption is wrong :)
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6818
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: ROS v6.49.6 BGP Aggregate

Fri Apr 29, 2022 4:06 pm

Aggregate works on output, you need some other peer where aggregated routes should be sent to actually see the result.
 
User avatar
loloski
Member Candidate
Member Candidate
Topic Author
Posts: 168
Joined: Mon Mar 15, 2021 9:10 pm

Re: ROS v6.49.6 BGP Aggregate

Fri Apr 29, 2022 4:13 pm

thanks mrz for faster response, case closed :)

Who is online

Users browsing this forum: No registered users and 32 guests