Community discussions

MikroTik App
 
jardielroque
just joined
Topic Author
Posts: 4
Joined: Sun Mar 01, 2020 10:28 pm

announce ipv6 routes in bgp

Fri Jun 10, 2022 4:23 pm

I would like someone to help me, I really need to do a filter to announce my ipv6 block to the operator, and block the millions of routes received by her.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 9534
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: announce ipv6 routes in bgp

Fri Jun 10, 2022 4:58 pm

Simply ask the operator to provide you only default route, and nothing more.
 
jardielroque
just joined
Topic Author
Posts: 4
Joined: Sun Mar 01, 2020 10:28 pm

Re: announce ipv6 routes in bgp

Fri Jun 10, 2022 5:12 pm

Simply ask the operator to provide you only default route, and nothing more.
AND HOW DO I MAKE HIM SEE MY ROUTES, WHY HE CLAIMS I'M NOT ADVERTISEMENT ANY ROUTE
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1676
Joined: Fri Aug 10, 2012 6:46 am
Location: iparchitechs.com
Contact:

Re: announce ipv6 routes in bgp

Fri Jun 10, 2022 5:24 pm

I would like someone to help me, I really need to do a filter to announce my ipv6 block to the operator, and block the millions of routes received by her.

Here is an IPv6 filtering example for advertised prefixes from a blog post I wrote:

https://stubarea51.net/2021/08/24/mikro ... g-filters/
/routing filter rule
add chain=dead.beef.101 rule="if (dst==200:dead:beef:101::/64) {accept}"
add chain=dead.beef.102 rule="if (dst==200:dead:beef:102::/64) {accept}"
add chain=dead.beef.agg rule="if (dst in 200:dead:beef::/48) {accept}"
add chain=bgp-out-v6 rule="if (chain dead.beef.101) {set bgp-local-pref 300; accept}"
add chain=bgp-out-v6 rule="if (chain dead.beef.102) {accept}"
add chain=bgp-out-v6 rule="if (chain dead.beef.agg && dst-len<128) {set bgp-local-pref 150; accept}"
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 9534
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: announce ipv6 routes in bgp

Fri Jun 10, 2022 5:34 pm

Hardware and RouterOS used is not specified.
 
jardielroque
just joined
Topic Author
Posts: 4
Joined: Sun Mar 01, 2020 10:28 pm

Re: announce ipv6 routes in bgp

Fri Jun 10, 2022 5:36 pm

I would like someone to help me, I really need to do a filter to announce my ipv6 block to the operator, and block the millions of routes received by her.

Here is an IPv6 filtering example for advertised prefixes from a blog post I wrote:

https://stubarea51.net/2021/08/24/mikro ... g-filters/
/routing filter rule
add chain=dead.beef.101 rule="if (dst==200:dead:beef:101::/64) {accept}"
add chain=dead.beef.102 rule="if (dst==200:dead:beef:102::/64) {accept}"
add chain=dead.beef.agg rule="if (dst in 200:dead:beef::/48) {accept}"
add chain=bgp-out-v6 rule="if (chain dead.beef.101) {set bgp-local-pref 300; accept}"
add chain=bgp-out-v6 rule="if (chain dead.beef.102) {accept}"
add chain=bgp-out-v6 rule="if (chain dead.beef.agg && dst-len<128) {set bgp-local-pref 150; accept}"
SORRY BUT IN THIS VERSION I'M BAD STILL, COULD MODIFY JA RULE FOR MY BLOCK ALREADY. FOLLOW THE BLOCK BELOW,

2804:284c::/32

HOW WOULD THE RULE BE?
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 9534
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: announce ipv6 routes in bgp

Fri Jun 10, 2022 6:06 pm

You still haven't specified which RouterOS you are using.
 
jardielroque
just joined
Topic Author
Posts: 4
Joined: Sun Mar 01, 2020 10:28 pm

Re: announce ipv6 routes in bgp

Fri Jun 10, 2022 8:14 pm

You still haven't specified which RouterOS you are using.
I'm currently using RouterOS 7.2.1 and I'm thinking of upgrading to the latest one, 7.3.1
 
User avatar
loloski
Member Candidate
Member Candidate
Posts: 168
Joined: Mon Mar 15, 2021 9:10 pm

Re: announce ipv6 routes in bgp

Mon Jun 13, 2022 5:21 am

make sure you have an active route with type = blackhole for the subnet or prefix you want to announce otherwise it won't work because no synchronize is no longer available on ROS v7
and also connection->filter section output.network = bgp-networks should match and have entry on your ipv6 address list
/ipv6 firewall address-list
add address=2804:284c::/32  list=bgp-networks

/routing filter rule
add chain=bgp-out-v6 rule="if (dst in 2804:284c::/32 && dst-len >= 32 && protocol bgp) { accept }"
just my 0.2$

Who is online

Users browsing this forum: No registered users and 2 guests