Community discussions

MikroTik App
 
Leonardorortizm
just joined
Topic Author
Posts: 14
Joined: Thu Mar 17, 2022 12:34 am

Router is Killing all peers Ospf

Fri May 20, 2022 5:07 pm

Hi, i have a CCR1072-1G-8S+ running BGP and Ospf as internal, the router drop down all Ospf peers at the same time, this has happened to someone else?

The interface is not disconecting and not lose L2 comunication when occurs....

may/19 19:52:26 route,ospf,info OSPFv2 neighbor 10.11.0.80: state change from Full to Down
may/19 19:52:26 route,ospf,info OSPFv2 neighbor 10.11.0.113: state change from Full to Down
may/19 19:52:26 route,ospf,info OSPFv2 neighbor 10.11.0.116: state change from Full to Down
may/19 19:52:34 route,ospf,info OSPFv2 neighbor 10.11.0.110: state change from Full to Down
may/19 19:52:36 route,ospf,info Ignoring Link State Acknowledgment packet: wrong peer state
may/19 19:52:36 route,ospf,info state=Attempt
may/19 19:52:36 route,ospf,info Ignoring Link State Acknowledgment packet: wrong peer state
may/19 19:52:36 route,ospf,info state=ExStart
may/19 19:52:37 route,ospf,info Ignoring Link State Acknowledgment packet: wrong peer state
may/19 19:52:37 route,ospf,info state=ExStart
may/19 19:52:43 route,ospf,info Ignoring Link State Acknowledgment packet: wrong peer state
may/19 19:52:43 route,ospf,info state=Attempt
may/19 19:56:11 route,ospf,info OSPFv2 neighbor 10.11.0.117: state change from Full to Down
may/19 19:59:51 route,ospf,info OSPFv2 neighbor 10.11.0.110: state change from Full to Down
may/19 20:00:05 route,ospf,info OSPFv2 neighbor 10.11.0.80: state change from Full to Down
may/19 20:00:05 route,ospf,info OSPFv2 neighbor 10.11.0.70: state change from Full to Down
may/19 20:00:05 route,ospf,info Ignoring Link State Acknowledgment packet: wrong peer state
may/19 20:00:05 route,ospf,info state=Down
may/19 20:00:12 route,ospf,info Ignoring Link State Acknowledgment packet: wrong peer state
may/19 20:00:12 route,ospf,info state=Attempt
may/19 20:00:12 route,ospf,info Ignoring Link State Acknowledgment packet: wrong peer state
may/19 20:00:12 route,ospf,info state=Attempt
may/19 20:00:12 route,ospf,info Ignoring Link State Acknowledgment packet: wrong peer state
may/19 20:00:12 route,ospf,info state=Down
may/19 20:02:10 route,ospf,info OSPFv2 neighbor 10.11.0.117: state change from Full to Down
may/19 20:02:20 route,ospf,info OSPFv2 neighbor 10.11.0.70: state change from Full to Down
may/19 20:04:14 route,ospf,info OSPFv2 neighbor 10.11.0.80: state change from Full to Down
may/19 20:04:28 route,ospf,info OSPFv2 neighbor 10.11.0.113: state change from Full to Down
may/19 20:04:28 route,ospf,info OSPFv2 neighbor 10.11.0.110: state change from Full to Down
 
User avatar
UplinkLLC
just joined
Posts: 12
Joined: Sun May 15, 2022 7:29 am
Location: USA

Re: Router is Killing all peers Ospf

Sat May 21, 2022 3:28 am

Hello Leonardorortizm,

What version of RouterOS are you using on the CCR1072-1G-8S+ ?
 
Leonardorortizm
just joined
Topic Author
Posts: 14
Joined: Thu Mar 17, 2022 12:34 am

Re: Router is Killing all peers Ospf

Sat May 21, 2022 4:03 pm

Hi, im using v6.49.5 RouterOs
 
User avatar
nichky
Forum Guru
Forum Guru
Posts: 1119
Joined: Tue Jun 23, 2015 2:35 pm

Re: Router is Killing all peers Ospf

Sun May 22, 2022 11:16 am

how your NAT looks like?
 
Leonardorortizm
just joined
Topic Author
Posts: 14
Joined: Thu Mar 17, 2022 12:34 am

Re: Router is Killing all peers Ospf

Mon May 23, 2022 3:23 pm

Hi mate , thanks for write, i have solve it.

The problem was CPU usage over 75%. I was thinking that for an router too big as CCR1072 75% was'nt much.-
 
Leonardorortizm
just joined
Topic Author
Posts: 14
Joined: Thu Mar 17, 2022 12:34 am

Re: Router is Killing all peers Ospf

Sat Jun 04, 2022 10:40 pm

Hi, the problem has occurred again with cpu usage in 33%, i don't now what i can do for solve it!.

Jun/04/2022 13:25:45 route,ospf,info OSPFv2 neighbor 10.11.0.70: state change from Full to Down
Jun/04/2022 13:25:45 route,ospf,info OSPFv2 neighbor 10.11.0.77: state change from Full to Down
Jun/04/2022 13:25:45 route,ospf,info OSPFv2 neighbor 10.11.0.84: state change from Full to Down
Jun/04/2022 13:25:45 route,ospf,info OSPFv2 neighbor 10.11.0.116: state change from Full to Down
Jun/04/2022 13:25:45 route,ospf,info OSPFv2 neighbor 10.11.0.113: state change from Full to Down
Jun/04/2022 13:25:45 route,ospf,info OSPFv2 neighbor 10.11.0.110: state change from Full to Down
Jun/04/2022 13:25:45 route,ospf,info OSPFv2 neighbor 10.11.0.80: state change from Full to Down
Jun/04/2022 13:25:45 route,ospf,info OSPFv2 neighbor 10.11.0.117: state change from Full to Down
Jun/04/2022 13:25:45 route,bgp,error HoldTimer expired
Jun/04/2022 13:25:45 route,bgp,error RemoteAddress=179.1.77.57
Jun/04/2022 13:25:45 route,bgp,error Unexpected UPDATE message
Jun/04/2022 13:25:45 route,bgp,error RemoteAddress=179.1.77.57
Jun/04/2022 13:25:45 route,ospf,info Ignoring Link State Acknowledgment packet: wrong peer state
Jun/04/2022 13:25:45 route,ospf,info state=Attempt
Jun/04/2022 13:25:46 route,ospf,info Ignoring Link State Acknowledgment packet: wrong peer state
Jun/04/2022 13:25:46 route,ospf,info state=ExStart
Jun/04/2022 13:25:46 route,ospf,info Ignoring Link State Acknowledgment packet: wrong peer state
Jun/04/2022 13:25:46 route,ospf,info state=Attempt


I have other two CCR1072 with the same configuration without problems

This is my NAT

9 ;;; NAT
chain=srcnat action=same to-addresses=(BGP Public range) same-not-by-dst=yes
protocol=!ospf src-address-list=Zarzal dst-address-list=!LAN log=no log-prefix=""

10 ;;; NAT
chain=srcnat action=same to-addresses=(other BGP Public range) same-not-by-dst=yes
protocol=!ospf src-address-list=ITX-RUTA-CRUZ dst-address-list=!LAN log=no log-prefix=""
 
User avatar
nichky
Forum Guru
Forum Guru
Posts: 1119
Joined: Tue Jun 23, 2015 2:35 pm

Re: Router is Killing all peers Ospf

Mon Jun 06, 2022 7:47 am

let see what the log saying:



/system logging action
add name=ospf target=memory

/system logging
add action=ospf topics=ospf
 
Leonardorortizm
just joined
Topic Author
Posts: 14
Joined: Thu Mar 17, 2022 12:34 am

Re: Router is Killing all peers Ospf

Mon Jun 06, 2022 4:54 pm

 
User avatar
nichky
Forum Guru
Forum Guru
Posts: 1119
Joined: Tue Jun 23, 2015 2:35 pm

Re: Router is Killing all peers Ospf

Tue Jun 07, 2022 5:45 am

ospf doing what supposed to be doing

Things to check:

Duplicated router ids
Areas and types
Network Type


you mentioned above that you are experiencing high CPU, is that because of ospf? how about if u disable it.
can we get export file?

have u checked maybe / tool profile
 
User avatar
UplinkLLC
just joined
Posts: 12
Joined: Sun May 15, 2022 7:29 am
Location: USA

Re: Router is Killing all peers Ospf

Tue Jun 07, 2022 7:40 am

Not sure if this is your issue, but see this thread: viewtopic.php?t=116968
 
Leonardorortizm
just joined
Topic Author
Posts: 14
Joined: Thu Mar 17, 2022 12:34 am

Re: Router is Killing all peers Ospf

Tue Jun 07, 2022 4:40 pm

@nichky
thanks, i will be reviewing your suggestions.
About cpu usage was solved reducing the amount of traffic that was being sent by mangle routing mark (3GB).

When the cpu usage was high /tool profile shows: routing and firewall are the most that consuming cpu.

Ok i understand that i can have a problem with Ospf, but this not explain why the router is killing BGP too.
 
Leonardorortizm
just joined
Topic Author
Posts: 14
Joined: Thu Mar 17, 2022 12:34 am

Re: Router is Killing all peers Ospf

Thu Jun 09, 2022 3:28 pm

@UplinkLLC

It has not worked for me.
 
User avatar
nichky
Forum Guru
Forum Guru
Posts: 1119
Joined: Tue Jun 23, 2015 2:35 pm

Re: Router is Killing all peers Ospf

Fri Jun 10, 2022 2:17 am

once u get high CPU
check / tool profile and show us here
 
Leonardorortizm
just joined
Topic Author
Posts: 14
Joined: Thu Mar 17, 2022 12:34 am

Re: Router is Killing all peers Ospf

Fri Jun 10, 2022 5:34 pm

The cpu was not high anymore

this is when router is down

AME CPU USAGE
flash 0%
firewall 0.9%
networking 0.7%
winbox 0.1%
logging 0.2%
management 0.3%
encrypting 0%
routing 1.2%
profiling 0.7%
queuing 0.1%
l7-matcher 0%
unclassified 1.1%
total 5.3%


console 0%
flash 0%
firewall 0.8%
networking 0.7%
winbox 0%
logging 0%
management 0.2%
encrypting 0%
routing 1.3%
profiling 0.1%
queuing 0.1%
l7-matcher 0%
unclassified 0.1%
total 3.3%



snmp 0%
console 0%
flash 0%
firewall 0.9%
networking 0.8%
winbox 0.2%
logging 0.3%
management 0.7%
encrypting 0%
routing 1.3%
profiling 0.2%
queuing 0.2%
l7-matcher 0%
unclassified 0.2%
total 4.8%
 
Leonardorortizm
just joined
Topic Author
Posts: 14
Joined: Thu Mar 17, 2022 12:34 am

Re: Router is Killing all peers Ospf

Wed Jun 15, 2022 8:57 pm

Same problem unsolved here

viewtopic.php?t=122671
 
Leonardorortizm
just joined
Topic Author
Posts: 14
Joined: Thu Mar 17, 2022 12:34 am

Re: Router is Killing all peers Ospf  [SOLVED]

Tue Jun 21, 2022 3:18 pm

I has solved the issue, the problem was that the router has receiving an high amount of updates by BGP protocol (about 2 Millions) , the router can't manage this and them kill the BGP process, BGP and OSPF runs under the same process, for this reason all is down when occurs.

the solve was to talk with internet provider and request that only sends to me the default gateway.

I'm not convenced that Mikrotik 1072 could manage Full Routing BGP. Support has said that update to RouterOs V7 could solve the initial issue.
 
User avatar
UplinkLLC
just joined
Posts: 12
Joined: Sun May 15, 2022 7:29 am
Location: USA

Re: Router is Killing all peers Ospf

Wed Jun 22, 2022 7:00 pm

Hello,

Mark the problem as solved please.

Thank you,

Who is online

Users browsing this forum: No registered users and 5 guests