Community discussions

MikroTik App
 
jc179
just joined
Topic Author
Posts: 6
Joined: Fri Nov 15, 2019 7:08 am

Mikrotik switch SFP+ port issue on COLD restart

Mon Feb 10, 2020 12:23 am

Hi All,

I have a crs226-24g-s2+rm running v6.42.11 (long-term), which has an odd issue with SFP+ port not coming back up after AC/DC loss.

This issue only happens if the switch loses AC/DC power and has an unexpected shutdown, a software reboot this does not happen.

Issue is the SFP+ will not come back up, shows under interfaces " no link, not running, slave"

To get the SFP+ to come back up, I need to
- goto interfaces, uncheck "Enabled", press Apply, wait 5 seconds
- check off Enabled, and press Apply again

All resumes working, and life is good again until power is lost.

Is there anyway to script something to do this automatically upon boot everytime (shutdown sfpplus1, wait , restart it) ?

I am so desperate I would even settle for something as crude as
curl something http://switchipaddress/settings.cgi?sfp ... ntevencare
curl something http://switchipaddress/settings.cgi?sfp ... ntevencare
(can I toggle this via a script on a remote box, or even switch crontab /startup rc.local ? )

Also, this issue does not happen in my crs125-24g-1s-rm, the single SFP resumes automatically when power is cut and comes back.

SFP is a HUAWEI MA5671A which works perfect otherwise...

Edit: It only behaves like this using this SFP - other SFP are OK , and yes I understand this might be due to an incompatibility... but if I can work around this I am very happy!

Any ideas?

thanks
Jonathan
 
Zacharias
Forum Guru
Forum Guru
Posts: 3468
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: Mikrotik switch SFP+ port issue on COLD restart

Mon Feb 10, 2020 6:38 pm

Why don't you start with updating the ROS and see if the problem continues ?
 
mkx
Forum Guru
Forum Guru
Posts: 8954
Joined: Thu Mar 03, 2016 10:23 pm

Re: Mikrotik switch SFP+ port issue on COLD restart

Mon Feb 10, 2020 7:24 pm

Why don't you start with updating the ROS ...

... including routerboot.
 
jc179
just joined
Topic Author
Posts: 6
Joined: Fri Nov 15, 2019 7:08 am

Re: Mikrotik switch SFP+ port issue on COLD restart

Tue Feb 11, 2020 5:57 am

Hey,

Good idea! - Upgraded firmware to v6.46.3 (stable), and routerboard to Current Firmware 6.46.3 …. and No change :(

Is there anyway to just get to a shell, and ifconfig this sucker up and down and see if that works upon boot?

Any other ideas?

Jonathan
 
jc179
just joined
Topic Author
Posts: 6
Joined: Fri Nov 15, 2019 7:08 am

Re: Mikrotik switch SFP+ port issue on COLD restart

Tue Feb 11, 2020 8:04 am

Trying to add a work around while getting this worked out...

added a start up script that seems to kinda work (3/5 tries) - I wonder if interface set sfp-sfpplus1 disabled= yes/no is equivalent to the GUI's "Enabled" checkbox. No idea how to get to a shell prompt yet.
interface set sfp-sfpplus1 disabled=yes
delay 5
interface set sfp-sfpplus1 disabled=no
[admin@MikroTik] /system> script print
Flags: I - invalid
 0   ;;; reset sfp1 port to fix glitch with sfp
     name="startup-script" owner="admin" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon
     dont-require-permissions=no run-count=0 source=
       interface set sfp-sfpplus1 disabled=yes
       delay 5
       interface set sfp-sfpplus1 disabled=no
[admin@MikroTik] /system> schedule
[admin@MikroTik] /system scheduler>

.. -- go up to system
add -- Create a new item
comment -- Set comment for items
disable -- Disable items
edit --
enable -- Enable items
export -- Print or save an export script that can be used to restore configuration
find -- Find items by value
get -- Gets value of item's property
print -- Print values of item properties
remove -- Remove item
set -- Change item properties


[admin@MikroTik] /system scheduler> print
Flags: X - disabled
 #   NAME                  START-DATE  START-TIME                INTERVAL             ON-EVENT                 RUN-COUNT
 0   startup-script                    startup                   0s                   startup startup-script           0
[admin@MikroTik] /system scheduler> ..
[admin@MikroTik] /system> ..
I am not 100% certain if "ON-EVENT" should be the name of the script, or the keyword "startup" so I put both.

Jonathan
 
fil
just joined
Posts: 12
Joined: Wed Nov 19, 2014 1:00 am

Re: Mikrotik switch SFP+ port issue on COLD restart

Sun Nov 21, 2021 11:07 am

Any further update on this workaround, or ideally, identifying the problem on SFP port and resolving.

I find that the SFP port does not work - the remote device (modem) indicates it has negotiated at sub-100FX speed (something obviously wrong) and manual intervention is required to bring it back.
 
Zacharias
Forum Guru
Forum Guru
Posts: 3468
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: Mikrotik switch SFP+ port issue on COLD restart

Sun Nov 21, 2021 5:50 pm

Any further update on this workaround, or ideally, identifying the problem on SFP port and resolving.

I find that the SFP port does not work - the remote device (modem) indicates it has negotiated at sub-100FX speed (something obviously wrong) and manual intervention is required to bring it back.
What is the MikroTik model ?
Ros version ?
SFP/SFP+ model ?
 
OpenFiber
newbie
Posts: 34
Joined: Thu Mar 10, 2016 1:33 am

Re: Mikrotik switch SFP+ port issue on COLD restart

Mon Nov 22, 2021 7:47 am

Having exactly the same issue on CRS326-24S+2Q+ (running different versions, currently 6.49) physically unplugging SFP module and reinserting also makes the link working again.
 
djdrastic
Member
Member
Posts: 367
Joined: Wed Aug 01, 2012 2:14 pm

Re: Mikrotik switch SFP+ port issue on COLD restart

Mon Nov 22, 2021 1:05 pm

I've had an issue like this way back in the day on CCR's back in the day and had to create a netwatch script that checks it peers ip address and disables and enables interfaces again.
Best course of action is to log a call with Mikrotik with the switches and affected SFP's . Eventually my issue got fixed in a further downstream fw update.
 
Zacharias
Forum Guru
Forum Guru
Posts: 3468
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: Mikrotik switch SFP+ port issue on COLD restart

Mon Nov 22, 2021 2:54 pm

Just saying that the SFP won't work doesn't really help...
Was it in the compatibility list of MikroTIK SFPs at the first place ?
Was it an SFP, SFP+ or QSFP module ?
 
ConnyMercier
Forum Veteran
Forum Veteran
Posts: 723
Joined: Tue Dec 17, 2019 1:08 pm

Re: Mikrotik switch SFP+ port issue on COLD restart

Mon Nov 22, 2021 4:00 pm

I had the same issues with some SFP/SFP+ modules in the past....
SFP-Interfaces worked perfectly, but on some Reboot and/or Cold-Starts the Interface wouldn't properly initiate.

We use a Scheduler on "startup" to,
1. Wait 90 Sec.
2. Check SFP/SFP+ Interface (If !running Step 3-6)
3. Disable SFP/SFP+ Interface
4. Wait 10 Sec.
5. Enable SFP/SFP+ Interface
6. Check SFP/SFP+ Interface (If !running Step 7)
7. Notification (email, Telegram, etc..)
 
fqx
newbie
Posts: 27
Joined: Tue Dec 20, 2016 2:24 pm

Re: Mikrotik switch SFP+ port issue on COLD restart

Tue Mar 22, 2022 3:11 pm

To be precise, my problem is a little different from this.

When I reboot rb5009, such as software upgrade, the sfp will be unresponsive. Even disable then enable interface won’t fix it.
I have to remove the stick from sfp port physically, then insert it to get it working again.
Is there a way to activate it by software?
 
fqx
newbie
Posts: 27
Joined: Tue Dec 20, 2016 2:24 pm

Re: Mikrotik switch SFP+ port issue on COLD restart

Sun Apr 10, 2022 5:47 am

I have written a script to reset sfp if issue happens, you can use it accordingly.
:local HOST "192.168.1.1"
:local PINGCOUNT "10"
:local INTF "sfp-sfpplus1"
:local DELAY "3s"
:log info "Delay 10s."
:delay 10s
:log info "Start pinging $INTF."
:if ([/ping $HOST interval=1 count=$PINGCOUNT] = 0) do={
:log error "Interface $INTF is down, restarting..."
/interface ethernet set $INTF auto-negotiation=no
:delay $DELAY
/interface ethernet set $INTF auto-negotiation=yes
:log warning "$INTF restart complete."
} else={
:log info "$INTF is working."
}
 
mahfuzazam
newbie
Posts: 26
Joined: Sat Aug 08, 2020 7:59 pm

Re: Mikrotik switch SFP+ port issue on COLD restart

Thu Jun 23, 2022 11:49 am

I'm suffering from a similar issue.
My router is CCR-1036-12G-4S-EM
I need to manually disable and enable SFP interfaces after router reboot to make the SFP work.

Is there any workaround for this? Please help.

I'm using UF-RJ45-1G SFP modules. Auto-negotiation is disabled and set to 1G.

The same SFP module works fine with the RB3011 router, and the issue is only with CCR.
 
djdrastic
Member
Member
Posts: 367
Joined: Wed Aug 01, 2012 2:14 pm

Re: Mikrotik switch SFP+ port issue on COLD restart

Fri Jun 24, 2022 10:45 am

For all that land here.Please log a ticket with Mikrotik.
They should be able if you provide them with enough diagnostic information be able to patch this in a downstream update unless there is some sort of hardware compatibility issue of the sorts.
They did it for me, they should be able to do it for you.

Who is online

Users browsing this forum: alber, w32pamela and 8 guests