Community discussions

MikroTik App
 
Dante91
just joined
Topic Author
Posts: 8
Joined: Mon Jul 24, 2017 1:14 pm

BGP-Routing-Filter "set bgp-med" on ROSv7.2.1

Fri Apr 29, 2022 1:59 pm

Hey @ all,
I just made an upgrade to ROS7.2.1 with my bgp-configuration. So far everything looks good, all settings are correctly migrated.
Only thing thats a bit tricky:
When Router1 wants to announce a route to his neighbor, there is a routing filter set, which changes the bgp-med.

Konfig on ROSv6.49:
/routing filter
add action=accept chain=secondary-out set-bgp-med=110
Konfig on upgraded ROSv7.2.1:
/routing filter rule
add chain=secondary-out disabled=no rule="set bgp-med 110; accept "

On Router2, when I check the received routes from Router1, there is noc MED set in status-field.
What could here be the issue?
Thanks and best regards.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6818
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: BGP-Routing-Filter "set bgp-med" on ROSv7.2.1

Fri Apr 29, 2022 2:02 pm

change to bgp-out-med
 
Dante91
just joined
Topic Author
Posts: 8
Joined: Mon Jul 24, 2017 1:14 pm

Re: BGP-Routing-Filter "set bgp-med" on ROSv7.2.1

Fri Apr 29, 2022 2:24 pm

Hey, thanks for the quick response.
I tried to set bgp-out-med. No change on the remote side. Also tried to change the distance on the routes. Still no change on remote side.
Another thing is that my default template is red and marked as "invalid".

/routing bgp template
set default as=12345 disabled=no nexthop-choice=force-self output.filter-chain=secondary-out .network=\
bgp-networks .redistribute=static router-id=172.200.36.12 routing-table=main
The routes are announced completely and with the right gateway. Just the output-routing filter does not work
Regards

Update: When I set the med-change on the target router as an input-filter, it works.
 
User avatar
TFyre
just joined
Posts: 16
Joined: Wed Jan 13, 2010 3:37 pm
Contact:

Re: BGP-Routing-Filter "set bgp-med" on ROSv7.2.1

Thu Jun 30, 2022 11:54 pm

set bgp-out-med
works for ebgp but not ibgp

According to https://help.mikrotik.com/docs/display/ ... nd+Filters we should use
set bgp-med
for ibgp, but it does not work either

Tested on ROSv7.3.1

Workaround is to use something like bgp communities
 
User avatar
nichky
Forum Guru
Forum Guru
Posts: 1121
Joined: Tue Jun 23, 2015 2:35 pm

Re: BGP-Routing-Filter "set bgp-med" on ROSv7.2.1

Fri Jul 01, 2022 6:49 am

@mrz

can u give us an example of bgp community on v7,, no wiki pls

Who is online

Users browsing this forum: No registered users and 2 guests