Community discussions

MikroTik App
 
tiernano
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 79
Joined: Fri Jul 20, 2012 1:51 pm

OSPFv2 between Mikrotik (7.1) and Bird (1.6.6)

Thu Dec 02, 2021 11:11 pm

Morning all.

This has been wrecking my head for the last few days, and my head hurts from banging it against the wall... Hopefully someone can help.

I have a RB5007 connected to the internet. I have Zerotier Interface and 2 Wireguard interfaces to 2 boxes (Zerotier is multiple endpoints on one interface, Wireguard is point to point...).

on the other end are Linux boxes running Bird. These already use OSPF to talk over both Zerotier and Wireguard for internal stuff (/32 ips for iBGP) and eBGP for external connections.

I have OSPF setup on Mikrotik with a single v2 instance redistributing static routes. on interface templates, i have one for zerotier (broadcast, matching the details in bird) and 1 each for the Wireguard connections (ptp, also matching).

I have a single Area, id 0.0.0.0, type default... and i have a single area range, announcing a /32 to the rest (10.244.253.x/32 for each box, which will be used to connect to BGP).

Long story boring, i am just getting the following constantly in the logs when using ptp,
OspfInterface { { 2 *12 0.0.0.0 0 10.244.250.1 } Point-to-Point PtP } wrong checksum from 10.244.250.2
When the broadcast one is on, I start to see Neighbors in the list, but LSA never changes and they are all listed in an "init" state...

I have tried rebooting boxes, upgrading Bird, and a load of other things, but no luck... What am i doing wrong?

Thanks.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6818
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: OSPFv2 between Mikrotik (7.1) and Bird (1.6.6)

Thu Dec 02, 2021 11:15 pm

Do you have authentication enabled?
 
tiernano
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 79
Joined: Fri Jul 20, 2012 1:51 pm

Re: OSPFv2 between Mikrotik (7.1) and Bird (1.6.6)

Thu Dec 02, 2021 11:16 pm

yea, simple auth is enabled on both...
 
tiernano
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 79
Joined: Fri Jul 20, 2012 1:51 pm

Re: OSPFv2 between Mikrotik (7.1) and Bird (1.6.6)

Thu Dec 02, 2021 11:19 pm

I think you answered by question! turning off auth worked! happy days!
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6818
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: OSPFv2 between Mikrotik (7.1) and Bird (1.6.6)

Fri Dec 03, 2021 10:32 am

We will fix authentication in one of the upcoming versions.
 
User avatar
lemosh
just joined
Posts: 6
Joined: Tue Dec 09, 2014 8:23 am
Contact:

Re: OSPFv2 between Mikrotik (7.1) and Bird (1.6.6)

Wed Dec 08, 2021 11:23 pm

The same problem between mikrotik x86 and brocade. OSPF simple authentification -wrong checksum after upgrade from 6.49.2 to 7.1
when to wait for a fix?
 
JoshDi
newbie
Posts: 31
Joined: Fri May 21, 2021 4:49 pm

Re: OSPFv2 between Mikrotik (7.1) and Bird (1.6.6)

Mon Jul 25, 2022 7:33 pm

I've been working on getting this working for a while (OSPF PTMP with Bird).

Im happy to report that v7.4 works with Bird if you set the OSPF type in Mikrotik to be PTMP. If you want PTMP to work like it did in v6 (and only with mikrotik devices) you need to use PTMP Broadcast in v7

This is allowing me to run wireguard on mikrotik and use OSPF PTMP with BIRD

Who is online

Users browsing this forum: clambert and 7 guests