Community discussions

MikroTik App
 
KirillG
just joined
Topic Author
Posts: 3
Joined: Thu Feb 12, 2015 12:07 pm

RouterOS v6 to v7 update broke my BGP peering

Wed Dec 15, 2021 10:01 am

Hi there.
I've setup BGP in RouterOS v6 like this:
/routing bgp instance set default as=64999 ignore-as-path-len=yes router-id=10.9.0.10/32
/routing bgp peer add hold-time=4m in-filter=bgp_in keepalive-time=1m multihop=yes name=antifilter remote-address=10.9.0.1/32 remote-as=64998 ttl=default 
/routing filter add action=accept chain=bgp_in comment="Set nexthop to VPN" set-in-nexthop-direct=*12
When I updated to RouterOS v7 it broke and I can't really see any status messages nor new routes on my MikroTik.

Current config is:
/routing bgp template
set default as=64999 disabled=yes input.ignore-as-path-len=yes name=default output.filter-chain=dynamic-in .network=bgp-networks .no-client-to-client-reflection=yes router-id=\
    172.30.1.2
add as=64999 disabled=no input.ignore-as-path-len=yes name=my output.network=bgp-networks router-id=10.9.0.10 routing-table=main
/routing ospf instance
add name=default-v2
/routing ospf area
add disabled=yes instance=default-v2 name=backbone-v2
/routing table
add fib name=HTTP
add fib name=DNS
add fib name=DNS-Router
/routing bgp connection
add cisco-vpls-nlri-len-fmt=auto-bits connect=yes disabled=yes hold-time=4m input.filter=bgp_in keepalive-time=600ms listen=yes local.role=ebgp multihop=yes name=antifilter \
    remote.address=163.172.210.8 .as=65432 .port=179 routing-table=main templates=default
add as=64999 cisco-vpls-nlri-len-fmt=auto-bits connect=yes disabled=no hold-time=4m input.filter=bgp_in .ignore-as-path-len=yes listen=yes local.role=ebgp multihop=yes name=VPS \
    output.network=bgp-networks remote.address=10.9.0.1/32 .as=64998 .port=179 router-id=10.9.0.10 routing-table=main templates=my
/routing filter rule
add chain=bgp_in comment="Set nexthop" disabled=no rule="if (protocol bgp) { set gw-interface *12; accept; }"
Can someone please help me to restore BGP?
 
KirillG
just joined
Topic Author
Posts: 3
Joined: Thu Feb 12, 2015 12:07 pm

Re: RouterOS v6 to v7 update broke my BGP peering

Thu Jan 27, 2022 4:51 pm

I'm constantly getting this error as well:
Connection closedBgpInput{ sk=Socket{ 3[
Not sure where to dig for better logs. Can someone please point me towards manual?
 
c1vhosting
just joined
Posts: 2
Joined: Thu Mar 31, 2022 10:03 pm

Re: RouterOS v6 to v7 update broke my BGP peering

Tue Aug 16, 2022 4:45 pm

I'm getting that too
Connection closedBgpInput{ sk=Socket{ 4[
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6827
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: RouterOS v6 to v7 update broke my BGP peering

Tue Aug 16, 2022 10:29 pm

Make sure you have correct local.address set.
 
User avatar
gilljr
newbie
Posts: 49
Joined: Thu Nov 15, 2012 10:47 pm
Location: Phoenix, AZ USA
Contact:

Re: RouterOS v6 to v7 update broke my BGP peering

Thu Aug 18, 2022 2:25 am

On the Connection Tab, make sure to assign the local address. I had this same issue and that was the solution.
 
c1vhosting
just joined
Posts: 2
Joined: Thu Mar 31, 2022 10:03 pm

Re: RouterOS v6 to v7 update broke my BGP peering

Sat Aug 20, 2022 6:55 pm

On the Connection Tab, make sure to assign the local address. I had this same issue and that was the solution.
It is set right. BGP Sessions are unstable. Every 3/4 hours getting Hold time expired or EBGP peer is not on a shared network and multihop is not configuredBPS ...
What could be the cause?
 
newnet
just joined
Posts: 9
Joined: Fri Aug 19, 2022 10:23 am

Re: RouterOS v6 to v7 update broke my BGP peering

Wed Aug 24, 2022 10:11 am

Mikrotik said when I emailed

"Thank you for the report, it is a known problem and will be fixed in the future."

Who is online

Users browsing this forum: Bing [Bot] and 2 guests