Community discussions

MikroTik App
 
User avatar
bitak
just joined
Topic Author
Posts: 8
Joined: Wed Feb 20, 2013 5:43 am

OSPF over ptp interface - routes not added to routing table (RouterOS v7.4.1)

Tue Aug 30, 2022 2:26 pm

I configured OSPF between Mikrotik and Cisco router. Routers are connected through an L2TP IPsec tunnel and the interfaces are configured correctly as ospf point-to-point links (on Cisco by the command "ip ospf network point-to-point"). On both devices, I can see the neighbor in FULL state, however, advertised routes appear only in the Cisco routing table. In Mikrotik, I can not see any OSPF routes.
This is my Mikrotik config:
/interface l2tp-client
add allow=mschap2 connect-to=X.X.X.X disabled=no max-mru=1400 max-mtu=1400 name=l2tp-out-Praha use-ipsec=yes user=YYYYY
/routing id
add disabled=no id=192.168.11.1 name=id-1 select-dynamic-id=""
/routing ospf instance
add disabled=no name=ospf-instance-1 router-id=id-1 routing-table=main version=2 vrf=main
/routing ospf area
add area-id=0.0.0.0 disabled=no instance=ospf-instance-1 name=ospf-area0 type=default
/routing ospf interface-template
add area=ospf-area0 disabled=no interfaces=l2tp-out-Praha type=ptp
add area=ospf-area0 disabled=no interfaces=vlan5 passive
When I print routing table, I don't have any OSPF routes installed:
ip/route/print
# DST-ADDRESS GATEWAY DISTANCE
DAv 0.0.0.0/0 pppoe-out1 1
DAc 10.1.0.1/32 pppoe-out1 0
DAc 10.11.9.0/24 vlan9 0
DAc 172.26.11.0/24 vlan7 0
0 As 172.31.254.0/24 192.168.200.1 1
DAc 192.168.11.0/24 vlan5 0
DAc 192.168.57.1/32 l2tp-out-Praha 0
DAc 192.168.200.1/32 l2tp-out-Bitak 0
DAc 192.168.211.0/24 vlan2 0
When I do on Mikrotik:
routing/ospf/lsa/print
I see it's receiving many OSPF routes:
...
6 D instance=ospf-instance-1 area=ospf-area0 type="router" originator=172.16.100.107 id=172.16.100.107 sequence=0x800034FA
age=937 checksum=0x4DEA body=
bits=
type=stub id=192.168.57.1 data=255.255.255.255 metric=1
type=p2p id=192.168.11.1 data=0.0.0.56 metric=1
type=p2p id=192.168.10.1 data=0.0.0.60 metric=1
type=stub id=192.168.107.0 data=255.255.255.0 metric=1
type=stub id=192.168.7.0 data=255.255.255.0 metric=1
type=stub id=192.168.7.0 data=255.255.255.0 metric=1
type=network id=172.16.100.1 data=172.16.100.107 metric=1000
...

On Cisco router everything ok:
show ip route ospf
...
O 192.168.11.0/24 [110/2] via 192.168.57.208, 00:40:42, Virtual-Access6
...
Cisco config:
router ospf 1
router-id 172.16.100.107
passive-interface default
no passive-interface Tunnel100
no passive-interface Tunnel101
no passive-interface Virtual-Template6
network 172.16.100.0 0.0.0.255 area 0
network 192.168.7.0 0.0.0.255 area 0
network 192.168.57.0 0.0.0.255 area 0
network 192.168.107.0 0.0.0.255 area 0

interface Virtual-Template6
ip unnumbered Loopback6
ip mtu 1400
ip nat inside
ip virtual-reassembly in
zone-member security PRIVATE
no ip route-cache
ip tcp adjust-mss 1360
ip ospf network point-to-point
peer default ip address pool MS_VPN_POOL_PRIVATE
ppp mtu adaptive
ppp encrypt mppe 128
ppp authentication ms-chap-v2
ppp ipcp dns 192.168.57.1

Am I missing something in the Mikrotik configuration?
 
JoshDi
newbie
Posts: 31
Joined: Fri May 21, 2021 4:49 pm

Re: OSPF over ptp interface - routes not added to routing table (RouterOS v7.4.1)

Tue Aug 30, 2022 4:03 pm

Try lowering your MTU on both sides of the PTP interface - 1400 MTU might not be low enough
 
User avatar
bitak
just joined
Topic Author
Posts: 8
Joined: Wed Feb 20, 2013 5:43 am

Re: OSPF over ptp interface - routes not added to routing table (RouterOS v7.4.1)

Tue Aug 30, 2022 4:47 pm

Try lowering your MTU on both sides of the PTP interface - 1400 MTU might not be low enough
I tried that, but MTU isn't the issue.
 
eduplant
Member Candidate
Member Candidate
Posts: 122
Joined: Tue Dec 19, 2017 9:45 am

Re: OSPF over ptp interface - routes not added to routing table (RouterOS v7.4.1)

Wed Aug 31, 2022 9:49 am

Does /routing/route print where ospf show routes but just without the A active flag? If there are received LSAs, it would seem to be an issue installing the routes rather than receiving them. Maybe there is some sort of next-hop resolution problem that is preventing them being installed in the table?
 
User avatar
bitak
just joined
Topic Author
Posts: 8
Joined: Wed Feb 20, 2013 5:43 am

Re: OSPF over ptp interface - routes not added to routing table (RouterOS v7.4.1)

Wed Aug 31, 2022 12:42 pm

Does /routing/route print where ospf show routes but just without the A active flag? If there are received LSAs, it would seem to be an issue installing the routes rather than receiving them. Maybe there is some sort of next-hop resolution problem that is preventing them being installed in the table?
/routing/route/print where ospf
doesn't show anything :(

Who is online

Users browsing this forum: No registered users and 3 guests