Community discussions

MikroTik App
 
desparateguy
just joined
Topic Author
Posts: 3
Joined: Sat Sep 10, 2022 9:12 pm

after using netinstall-cli under linux RB750r2 bricked

Sat Sep 10, 2022 9:30 pm

Hi,
after having misconfigured IP addresses I couldn't reach my RB750r2 (hEX lite) anymore.
After using netinstall under windows11 it was accessible again.
During the research to revive it, i found netinstall-cli under linux.
Because i'm mainly linux-user, i tried the netinstall-cli.
The board was detected and netinstall process completed without errors.
Unfortunately after that the board was again not accessible (ping workes, ssh fails, WebFig fails).
Next try was again under windows11.
Now the board was not recognized by netinstall (waited 40sec, before 15 were enough).
Tried again under linux. Board was detected, netinstall process completed without errors but board is still not accessible (no ssh, webfig)
Using winbox on windows couldn't connect to board, neither IP nor MAC based.

Versions i've used:
windows: netinstall64 for routerOS 7.5
linux: https://download.mikrotik.com/routeros/ ... 7.5.tar.gz
for both: https://download.mikrotik.com/routeros/ ... mipsbe.npk

Next trial was with RouterOS v6.48.6 under linux (because only there board is detected).
I've used matching version for netinstall & routerOS (both v6.48.6).
Result was same (install process:ok, ping:ok, ssh: fail, webfig:fail).
It seems to me the the router internal servers are not running after reboot.
Before i bricked it using the linux-netinstall-cli, the router was shown in the fritzbox as containing a server (clickable link to webfig login).
Now it's shown as dumb device.

What can i do more?

Any help appreciated.

Best regards,
desparateguy

Log from netinstall-cli under Linux:
$>sudo ./netinstall-cli -a 192.168.178.90 routeros-7.5-mipsbe.npk
Version: 7.5(2022-08-30 09:34:59)
Using server IP: 192.168.178.19
Use Netmask: 255.255.255.0
Starting PXE server
Waiting for RouterBOARD...
client: DC:2C:6E:81:44:A3
Sending image: mips
sendFile 4877676
Discovered RouterBOARD...
Formatting...
Sending package routeros-7.5-mipsbe.npk ...
Ready for reboot...
Sent reboot command
$>
 
desparateguy
just joined
Topic Author
Posts: 3
Joined: Sat Sep 10, 2022 9:12 pm

Re: after using netinstall-cli under linux RB750r2 bricked

Sat Sep 10, 2022 11:59 pm

Another experiment after reading about reset button behavior and backup boot loader.
Board detection under linux work only with backup-boot-loader (reset pressed before power).
Same with main-boot-laoder (reset pressed after power) does not detect the board.

Using windows both boot-loaders do not detect the board.
 
desparateguy
just joined
Topic Author
Posts: 3
Joined: Sat Sep 10, 2022 9:12 pm

Re: after using netinstall-cli under linux RB750r2 bricked

Sun Sep 11, 2022 6:59 pm

Many trial later is had success with using windows and coupling pc and brick with a switch instead of directly, as requested by manual.
With this setup windows netinstall recognized the board and re-installed routerOS. After that, board was operational again.

It remains the issue that linux netinstall-cli bricks boards.

Who is online

Users browsing this forum: No registered users and 4 guests