Community discussions

MikroTik App
 
hufhendr
just joined
Topic Author
Posts: 11
Joined: Wed Sep 07, 2022 10:27 pm

OSPF is setting up the wrong interfaces

Sat Sep 10, 2022 9:26 pm

I have 3 routers in three different locations, connected in a triangle. There are two connections via OpenVPN and the last one is via Wireguard. I deployed OSPF there to throw up routes if the OpenVPN connection drops. And looking at it, it doesn't seem to work quite right. The shortest connection to 192.168.2.0/24 is via ovpn-ps. What could I have wrong there or is it a bug?
Image
 
User avatar
nichky
Forum Guru
Forum Guru
Posts: 1119
Joined: Tue Jun 23, 2015 2:35 pm

Re: OSPF is setting up the wrong interfaces

Sat Sep 10, 2022 11:54 pm

without seeing your config, no one can help you
 
hufhendr
just joined
Topic Author
Posts: 11
Joined: Wed Sep 07, 2022 10:27 pm

Re: OSPF is setting up the wrong interfaces

Sun Sep 11, 2022 1:19 am

It is as simple as it can be, a model example
/routing/ospf/interface> print
Flags: D - dynamic 
 0 D address=192.168.7.1%bridge area=backbone state=dr network-type=broadcast cost=1 priority=128 retransmit-interval=5s transmit-delay=1s hello-interval=10s 
     dead-interval=40s 

 1 D address=192.168.77.1%<ovpn-pha> area=backbone state=dr network-type=broadcast bdr=192.168.77.254 cost=1 priority=128 retransmit-interval=5s transmit-delay=1s 
     hello-interval=10s dead-interval=40s 

 2 D address=192.168.77.1%<ovpn-ps> area=backbone state=dr network-type=broadcast bdr=192.168.77.253 cost=1 priority=128 retransmit-interval=5s transmit-delay=1s 
     hello-interval=10s dead-interval=40s 
<br>
/routing/ospf/area> print
Flags: X - disabled, I - inactive, D - dynamic; T - transit-capable 
 0    name="backbone" instance=default-v2 area-id=0.0.0.0 type=default
 
<br>
/routing/ospf/interface-template> print
Flags: X - disabled, I - inactive 
 0   area=backbone instance-id=0 networks=192.168.7.0/24 type=broadcast retransmit-interval=5s transmit-delay=1s hello-interval=10s dead-interval=40s priority=128 
     cost=1 

 1   area=backbone instance-id=0 networks=192.168.77.0/24 type=broadcast retransmit-interval=5s transmit-delay=1s hello-interval=10s dead-interval=40s priority=128 
     cost=1 
<br>
The others are practically the same only in their address ranges
 
User avatar
nichky
Forum Guru
Forum Guru
Posts: 1119
Joined: Tue Jun 23, 2015 2:35 pm

Re: OSPF is setting up the wrong interfaces

Sun Sep 11, 2022 4:42 am

still there is not clear picture,from what u have sent us, try to play with interfaces rather than network

may i get export of the below:
/ppp active pr

/ip/add pr
 
User avatar
nichky
Forum Guru
Forum Guru
Posts: 1119
Joined: Tue Jun 23, 2015 2:35 pm

Re: OSPF is setting up the wrong interfaces

Sun Sep 11, 2022 4:51 am

or i have seen this:

192.168.77.1 excision on two interfaces ovpn-pha and ovpn-ps.
OSPF is doing what it's supposed to be doing
 
hufhendr
just joined
Topic Author
Posts: 11
Joined: Wed Sep 07, 2022 10:27 pm

Re: OSPF is setting up the wrong interfaces

Sun Sep 11, 2022 12:30 pm

So shouldn't both neighboring routers connect to this OpenVPN server, but should I make one of those connections, for example, in reverse and in different network ranges?

active ppp
/ppp/active> print 
Columns: NAME, SERVICE, CALLER-ID, ADDRESS, UPTIME, ENCODING
# NAME  SERVICE  CALLER-ID      ADDRESS         UPTIME       ENCODING          
;;; Praha
0 pha   ovpn     89.103.48.134  192.168.77.254  1d14h44m39s  AES-256-CBC/SHA512
;;; Pisecne
1 ps    ovpn     213.29.63.159  192.168.77.253  1d14h44m29s  AES-256-CBC/SHA512

ip address
/ip/address> print
Flags: I, D - DYNAMIC
Columns: ADDRESS, NETWORK, INTERFACE
#   ADDRESS           NETWORK         INTERFACE  
;;; defconf
0   192.168.7.1/24    192.168.7.0     bridge     
;;; guest wifi
1   192.168.10.1/24   192.168.10.0    vlan2      
;;; Michal
2   192.168.11.1/24   192.168.11.0    vlan3      
;;; VPN
3 I 10.200.0.7/32     10.200.0.0      *13        
4 D 89.24.138.211/32  89.24.145.107   Cetin PPPoE
5 D 192.168.77.1/32   192.168.77.254  <ovpn-pha> 
6 D 192.168.77.1/32   192.168.77.253  <ovpn-ps> 
 
User avatar
nichky
Forum Guru
Forum Guru
Posts: 1119
Joined: Tue Jun 23, 2015 2:35 pm

Re: OSPF is setting up the wrong interfaces

Sun Sep 11, 2022 12:48 pm

oki, and lastly ,
interface/bridge/export
 
hufhendr
just joined
Topic Author
Posts: 11
Joined: Wed Sep 07, 2022 10:27 pm

Re: OSPF is setting up the wrong interfaces

Sun Sep 11, 2022 1:20 pm

# sep/11/2022 12:04:44 by RouterOS 7.5
# software id = WLZZ-1KWZ
#
# model = RB760iGS
# serial number = D4500F1062F9
/interface bridge
add admin-mac=08:55:31:75:31:2D auto-mac=no comment=defconf name=bridge
/interface bridge port
add bridge=bridge comment=defconf ingress-filtering=no interface=eth2
add bridge=bridge comment=defconf ingress-filtering=no interface=eth3
add bridge=bridge comment=defconf ingress-filtering=no interface=eth4
add bridge=bridge comment=defconf ingress-filtering=no interface=eth5
add bridge=bridge comment=defconf ingress-filtering=no interface=sfp1

/routing/ospf/export
# sep/11/2022 12:18:53 by RouterOS 7.5
# software id = WLZZ-1KWZ
#
# model = RB760iGS
# serial number = D4500F1062F9
/routing ospf instance
add disabled=no name=default-v2 redistribute=static router-id=192.168.7.1
/routing ospf area
add disabled=no instance=default-v2 name=backbone
/routing ospf interface-template
add area=backbone disabled=no networks=192.168.7.0/24
add area=backbone disabled=no networks=192.168.77.0/24
 
User avatar
nichky
Forum Guru
Forum Guru
Posts: 1119
Joined: Tue Jun 23, 2015 2:35 pm

Re: OSPF is setting up the wrong interfaces

Sun Sep 11, 2022 2:16 pm

Can't see anything wrong at the ospf, but comming back to your first post you are sayying that:

The shortest connection to 192.168.2.0/24 is via ovpn-ps, on which interface are you expecting to be?

from the wiki: The OSPF protocol is the link-state protocol that takes care of the routes in the dynamic network structure that can employ different paths to its subnetworks.

So im assuming that 192.168.2.0/24 is in the ospf on other site or Redistribute has been ticked.
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1676
Joined: Fri Aug 10, 2012 6:46 am
Location: iparchitechs.com
Contact:

Re: OSPF is setting up the wrong interfaces

Sun Sep 11, 2022 4:02 pm

What is the output of:

routing/ospf/lsa/print detail

On all 3 routers?
 
hufhendr
just joined
Topic Author
Posts: 11
Joined: Wed Sep 07, 2022 10:27 pm

Re: OSPF is setting up the wrong interfaces

Sun Sep 11, 2022 4:17 pm

Output from my where is the OpenVPN server
/routing/ospf/lsa/print
Flags: S - self-originated, F - flushing, W - wraparound; D - dynamic 
 0  D instance=default-v2 type="external" originator=192.168.3.1 id=192.168.2.0 sequence=0x8000006A age=1198 checksum=0xA768 body=
        options=E
        netmask=255.255.255.0
        forwarding-address=0.0.0.0
        metric=1 type-1
        route-tag=0

 1  D instance=default-v2 type="external" originator=192.168.2.1 id=192.168.3.0 sequence=0x80000083 age=6 checksum=0x7185 body=
        options=E
        netmask=255.255.255.0
        forwarding-address=0.0.0.0
        metric=1 type-1
        route-tag=0

 2  D instance=default-v2 type="external" originator=192.168.2.1 id=192.168.7.0 sequence=0x80000069 age=1380 checksum=0x7993 body=
        options=E
        netmask=255.255.255.0
        forwarding-address=0.0.0.0
        metric=1 type-1
        route-tag=0

 3  D instance=default-v2 type="external" originator=192.168.3.1 id=192.168.7.0 sequence=0x8000006D age=993 checksum=0x6A9D body=
        options=E
        netmask=255.255.255.0
        forwarding-address=0.0.0.0
        metric=1 type-1
        route-tag=0

 4  D instance=default-v2 area=backbone type="router" originator=192.168.2.1 id=192.168.2.1 sequence=0x800000C7 age=815 checksum=0xD4F3 body=
        bits=E
            type=network id=192.168.77.1 data=192.168.77.253 metric=1
            type=stub id=192.168.2.0 data=255.255.255.0 metric=1

 5  D instance=default-v2 area=backbone type="router" originator=192.168.3.1 id=192.168.3.1 sequence=0x8000009F age=979 checksum=0x36B6 body=
        bits=E
            type=network id=192.168.77.1 data=192.168.77.254 metric=1
            type=stub id=192.168.3.0 data=255.255.255.0 metric=1

 6 SD instance=default-v2 area=backbone type="router" originator=192.168.7.1 id=192.168.7.1 sequence=0x80000071 age=1585 checksum=0xBA52 body=
        bits=E
            type=network id=192.168.77.1 data=192.168.77.1 metric=1
            type=stub id=192.168.7.0 data=255.255.255.0 metric=1

 7 SD instance=default-v2 area=backbone type="network" originator=192.168.7.1 id=192.168.77.1 sequence=0x8000005C age=1643 checksum=0xC234 
      body=
        netmask=255.255.255.255
            router-id=192.168.3.1
            router-id=192.168.7.1
Here is the router marked as Prague 192.168.3.1
/routing/ospf/lsa/print
Flags: S - self-originated, F - flushing, W - wraparound; D - dynamic 
 0 SD instance=default-v2 type="external" originator=192.168.3.1 id=192.168.2.0 sequence=0x8000006A age=1291 checksum=0xA768 body=
        options=E
        netmask=255.255.255.0
        forwarding-address=0.0.0.0
        metric=1 type-1
        route-tag=0

 1  D instance=default-v2 type="external" originator=192.168.2.1 id=192.168.3.0 sequence=0x80000083 age=108 checksum=0x7185 body=
        options=E
        netmask=255.255.255.0
        forwarding-address=0.0.0.0
        metric=1 type-1
        route-tag=0

 2  D instance=default-v2 type="external" originator=192.168.2.1 id=192.168.7.0 sequence=0x80000069 age=1482 checksum=0x7993 body=
        options=E
        netmask=255.255.255.0
        forwarding-address=0.0.0.0
        metric=1 type-1
        route-tag=0

 3 SD instance=default-v2 type="external" originator=192.168.3.1 id=192.168.7.0 sequence=0x8000006D age=1086 checksum=0x6A9D body=
        options=E
        netmask=255.255.255.0
        forwarding-address=0.0.0.0
        metric=1 type-1
        route-tag=0

 4  D instance=default-v2 area=backbone type="router" originator=192.168.2.1 id=192.168.2.1 sequence=0x800000C7 age=917 checksum=0xD4F3 body=
        bits=E
            type=network id=192.168.77.1 data=192.168.77.253 metric=1
            type=stub id=192.168.2.0 data=255.255.255.0 metric=1

 5 SD instance=default-v2 area=backbone type="router" originator=192.168.3.1 id=192.168.3.1 sequence=0x8000009F age=1072 checksum=0x36B6 body=
        bits=E
            type=network id=192.168.77.1 data=192.168.77.254 metric=1
            type=stub id=192.168.3.0 data=255.255.255.0 metric=1

 6  D instance=default-v2 area=backbone type="router" originator=192.168.7.1 id=192.168.7.1 sequence=0x80000071 age=1693 checksum=0xBA52 body=
        bits=E
            type=network id=192.168.77.1 data=192.168.77.1 metric=1
            type=stub id=192.168.7.0 data=255.255.255.0 metric=1

 7  D instance=default-v2 area=backbone type="network" originator=192.168.7.1 id=192.168.77.1 sequence=0x8000005C age=1751 checksum=0xC234 
      body=
        netmask=255.255.255.255
            router-id=192.168.3.1
            router-id=192.168.7.1
Here is the router marked as Pisecne 192.168.2.1
/routing/ospf/lsa/print
Flags: S - self-originated, F - flushing, W - wraparound; D - dynamic 
 0  D instance=default-v2 type="external" originator=192.168.3.1 id=192.168.2.0 sequence=0x8000006A age=1701 checksum=0xA768 body=
        options=E
        netmask=255.255.255.0
        forwarding-address=0.0.0.0
        metric=1 type-1
        route-tag=0

 1 SD instance=default-v2 type="external" originator=192.168.2.1 id=192.168.3.0 sequence=0x80000083 age=501 checksum=0x7185 body=
        options=E
        netmask=255.255.255.0
        forwarding-address=0.0.0.0
        metric=1 type-1
        route-tag=0

 2 SD instance=default-v2 type="external" originator=192.168.2.1 id=192.168.7.0 sequence=0x8000006A age=128 checksum=0x7794 body=
        options=E
        netmask=255.255.255.0
        forwarding-address=0.0.0.0
        metric=1 type-1
        route-tag=0

 3  D instance=default-v2 type="external" originator=192.168.3.1 id=192.168.7.0 sequence=0x8000006D age=1496 checksum=0x6A9D body=
        options=E
        netmask=255.255.255.0
        forwarding-address=0.0.0.0
        metric=1 type-1
        route-tag=0

 4 SD instance=default-v2 area=backbone type="router" originator=192.168.2.1 id=192.168.2.1 sequence=0x800000C7 age=1310 checksum=0xD4F3 body=
        bits=E
            type=network id=192.168.77.1 data=192.168.77.253 metric=1
            type=stub id=192.168.2.0 data=255.255.255.0 metric=1

 5  D instance=default-v2 area=backbone type="router" originator=192.168.3.1 id=192.168.3.1 sequence=0x8000009F age=1482 checksum=0x36B6 body=
        bits=E
            type=network id=192.168.77.1 data=192.168.77.254 metric=1
            type=stub id=192.168.3.0 data=255.255.255.0 metric=1

 6  D instance=default-v2 area=backbone type="router" originator=192.168.7.1 id=192.168.7.1 sequence=0x80000072 age=330 checksum=0xB853 body=
        bits=E
            type=network id=192.168.77.1 data=192.168.77.1 metric=1
            type=stub id=192.168.7.0 data=255.255.255.0 metric=1

 7  D instance=default-v2 area=backbone type="network" originator=192.168.7.1 id=192.168.77.1 sequence=0x8000005D age=302 checksum=0xC035 
      body=
        netmask=255.255.255.255
            router-id=192.168.3.1
            router-id=192.168.7.1
Between the Prague and Pisecne router there is a Wireguard, which I failed to add to OSPF and so it is not there.
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1676
Joined: Fri Aug 10, 2012 6:46 am
Location: iparchitechs.com
Contact:

Re: OSPF is setting up the wrong interfaces

Sun Sep 11, 2022 4:33 pm

Gotcha...now what's the output of

routing/route/print
routing/ospf/export

For all three routers?
 
hufhendr
just joined
Topic Author
Posts: 11
Joined: Wed Sep 07, 2022 10:27 pm

Re: OSPF is setting up the wrong interfaces

Sun Sep 11, 2022 6:18 pm

OpenVPN server to which two neighbouring routers connect
/routing/route/print
Flags: A - ACTIVE; c, s, o, v, y - COPY; H - HW-OFFLOADED; +, B - BLACKHOLE
Columns: DST-ADDRESS, GATEWAY, AFI, DISTANCE, SCOPE, TARGET-SCOPE, IMMEDIATE-GW
     DST-ADDRESS        GATEWAY                    AFI   DISTANCE  SCOPE  TARGET-SCOPE  IMMEDIATE-GW             
Av   0.0.0.0/0          Cetin PPPoE                ip4          1     30            10  Cetin PPPoE              
Ac   89.24.145.107/32   Cetin PPPoE                ip4          0     10                Cetin PPPoE              
Ao   192.168.2.0/24     192.168.77.254%<ovpn-pha>  ip4        110     20            10  192.168.77.254%<ovpn-pha>
Ao   192.168.3.0/24     192.168.77.254%<ovpn-pha>  ip4        110     20            10  192.168.77.254%<ovpn-pha>
Ac   192.168.7.0/24     bridge                     ip4          0     10                bridge                   
Ac   192.168.10.0/24    vlan2                      ip4          0     10                vlan2                    
Ac   192.168.11.0/24    vlan3                      ip4          0     10                vlan3                    
Ac   192.168.77.253/32  <ovpn-ps>                  ip4          0     10                <ovpn-ps>                
Ac   192.168.77.254/32  <ovpn-pha>                 ip4          0     10                <ovpn-pha>               
Av + ::/0               Cetin PPPoE                ip6          1     30            10  Cetin PPPoE              
As + ::/0               Cetin PPPoE                ip6          1     30            10  Cetin PPPoE              
A H  <ovpn-pha>                                    link         0                                                
A H  eth1                                          link         0                                                
A H  <ovpn-ps>                                     link         0                                                
A H  eth3                                          link         0                                                
A H  eth5                                          link         0                                                
A H  bridge                                        link         0                                                
A H  vlan2                                         link         0                                                
A H  vlan3                                         link         0                                                
A H  Cetin VLAN                                    link         0                                                
A H  Cetin PPPoE                                   link         0 
/routing/ospf/export
# sep/11/2022 17:07:07 by RouterOS 7.5
# software id = WLZZ-1KWZ
#
# model = RB760iGS
# serial number = D4500F1062F9
/routing ospf instance
add disabled=no name=default-v2 redistribute=static router-id=192.168.7.1
/routing ospf area
add disabled=no instance=default-v2 name=backbone
/routing ospf interface-template
add area=backbone disabled=no networks=192.168.7.0/24
add area=backbone disabled=no networks=192.168.77.0/24
Router marked as Prague
/routing/route/print
Flags: A - ACTIVE; c, s, o, d, y - COPY; H - HW-OFFLOADED
Columns: DST-ADDRESS, GATEWAY, AFI, DISTANCE, SCOPE, TARGET-SCOPE, IMMEDIATE-GW
    DST-ADDRESS           GATEWAY               AFI   DISTANCE  SCOPE  TARGET-SCOPE  IMMEDIATE-GW        
Ad  0.0.0.0/0             89.103.48.1           ip4          1     30            10  89.103.48.1%ether1  
Ac  10.200.0.0/32         wireguard1            ip4          0     10                wireguard1          
Ac  89.103.48.0/24        ether1                ip4          0     10                ether1              
Ac  192.168.1.0/24        vlan4                 ip4          0     10                vlan4               
As  192.168.2.0/24        wireguard1            ip4          1     30            10  wireguard1          
Ac  192.168.3.0/24        bridge                ip4          0     10                bridge              
 o  192.168.7.0/24        192.168.77.1%ovpn-kn  ip4        110     20            10  192.168.77.1%ovpn-kn
As  192.168.7.0/24        ovpn-kn               ip4          1     30            10  ovpn-kn             
Ac  192.168.10.0/24       vlan2                 ip4          0     10                vlan2               
Ac  192.168.11.0/24       vlan3                 ip4          0     10                vlan3               
Ac  192.168.77.1/32       ovpn-kn               ip4          0     10                ovpn-kn             
Ac  fe80::%ether1/64      ether1                ip6          0     10                ether1              
Ac  fe80::%bridge/64      bridge                ip6          0     10                bridge              
Ac  fe80::%vlan2/64       vlan2                 ip6          0     10                vlan2               
Ac  fe80::%vlan3/64       vlan3                 ip6          0     10                vlan3               
Ac  fe80::%wireguard1/64  wireguard1            ip6          0     10                wireguard1          
Ac  fe80::%vlan4/64       vlan4                 ip6          0     10                vlan4               
Ac  fe80::%ovpn-kn/64     ovpn-kn               ip6          0     10                ovpn-kn             
A H ether1                                      link         0                                           
A H ether4                                      link         0                                           
A H bridge                                      link         0                                           
A H vlan2                                       link         0                                           
A H vlan3                                       link         0                                           
A H wireguard1                                  link         0                                           
A H vlan4                                       link         0                                           
A H ovpn-kn                                     link         0
/routing/ospf/export
# sep/11/2022 17:14:43 by RouterOS 7.5
# software id = CI1K-69EK
#
# model = RB760iGS
# serial number = D4500D7C5163
/routing ospf instance
add disabled=no name=default-v2 redistribute=static router-id=192.168.3.1
/routing ospf area
add disabled=no instance=default-v2 name=backbone
/routing ospf interface-template
add area=backbone disabled=no networks=192.168.3.0/24
add area=backbone disabled=no networks=192.168.77.0/24
add area=backbone disabled=yes networks=10.200.0.0/24 type=ptp
/routing ospf static-neighbor
add address=10.200.0.2%wireguard1 area=backbone disabled=yes
Router marked as Pisecne
/routing/route/print
Flags: A - ACTIVE; c, s, v, y - COPY; H - HW-OFFLOADED
Columns: DST-ADDRESS, GATEWAY, AFI, DISTANCE, SCOPE, TARGET-SCOPE, IMMEDIATE-GW
    DST-ADDRESS       GATEWAY      AFI   DISTANCE  SCOPE  TARGET-SCOPE  IMMEDIATE-GW
Av  0.0.0.0/0         Cetin PPPoE  ip4          1     30            10  Cetin PPPoE 
Ac  10.200.0.0/24     wireguard1   ip4          0     10                wireguard1  
Ac  89.24.145.107/32  Cetin PPPoE  ip4          0     10                Cetin PPPoE 
Ac  192.168.2.0/24    bridge       ip4          0     10                bridge      
As  192.168.3.0/24    wireguard1   ip4          1     30            10  wireguard1  
As  192.168.7.0/24    ovpn-kn      ip4          1     30            10  ovpn-kn     
Ac  192.168.10.0/24   vlan2        ip4          0     10                vlan2       
Ac  192.168.20.0/24   vlan3        ip4          0     10                vlan3       
Ac  192.168.77.1/32   ovpn-kn      ip4          0     10                ovpn-kn     
Av  ::/0              Cetin PPPoE  ip6          1     30            10  Cetin PPPoE 
A H ether1                         link         0                                   
A H ether2                         link         0                                   
A H ether3                         link         0                                   
A H bridge                         link         0                                   
A H vlan2                          link         0                                   
A H vlan3                          link         0                                   
A H Cetin VLAN                     link         0                                   
A H Cetin PPPoE                    link         0                                   
A H wireguard1                     link         0                                   
A H ovpn-kn                        link         0
/routing/ospf/export
# sep/11/2022 17:17:21 by RouterOS 7.5
# software id = 0GFR-Q6BS
#
# model = RB760iGS
# serial number = D4500E165BBC
/routing ospf instance
add disabled=no name=default-v2 redistribute=static router-id=192.168.2.1
/routing ospf area
add disabled=no instance=default-v2 name=backbone
/routing ospf interface-template
add area=backbone disabled=no networks=192.168.2.0/24
add area=backbone disabled=no networks=192.168.77.0/24
add area=backbone disabled=yes interfaces=wireguard1 type=ptmp
add area=backbone disabled=yes networks=10.200.0.0/24 type=ptp
/routing ospf static-neighbor
add address=10.200.0.1%wireguard1 area=backbone disabled=yes poll-interval=5s
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1676
Joined: Fri Aug 10, 2012 6:46 am
Location: iparchitechs.com
Contact:

Re: OSPF is setting up the wrong interfaces

Sun Sep 11, 2022 8:12 pm

I did a quick drawing because it made it easier to read the OSPF LSAs. It seems like there is a problem between the OVPN Server and Pisecne because it's not learning any OSPF routes from the server but Prague is.

A few things that would be helpful

1. You're using a broadcast network type on a non-broadcast network - try using ptmp network type on the server and for each location.
2. Show the output of this command on each router:

routing/ospf/neighbor/print detail


Image
 
hufhendr
just joined
Topic Author
Posts: 11
Joined: Wed Sep 07, 2022 10:27 pm

Re: OSPF is setting up the wrong interfaces

Sun Sep 11, 2022 11:06 pm

OpenVPN server
/routing/ospf/neighbor/print detail
Flags: V - virtual; D - dynamic 
 0  D instance=default-v2 area=backbone address=192.168.77.254 priority=128 router-id=192.168.3.1 dr=192.168.77.1 bdr=192.168.77.254 state="Full" state-changes=6 
      adjacency=2d1h18m4s timeout=33s 

 1  D instance=default-v2 area=backbone address=192.168.77.253 priority=128 router-id=192.168.2.1 dr=192.168.77.1 bdr=192.168.77.253 state="Full" state-changes=6 
      adjacency=2d1h17m53s timeout=33s
Praha
/routing/ospf/neighbor/print detail
Flags: V - virtual; D - dynamic 
 0  D instance=default-v2 area=backbone address=192.168.77.1 priority=128 router-id=192.168.7.1 dr=192.168.77.1 bdr=192.168.77.254 state="Full" state-changes=6 
      adjacency=2d1h18m21s timeout=35s
Pisecne
/routing/ospf/neighbor/print detail
Flags: V - virtual; D - dynamic 
 0  D instance=default-v2 area=backbone address=192.168.77.1 priority=128 router-id=192.168.7.1 dr=192.168.77.1 bdr=192.168.77.253 state="Full" state-changes=6 
      adjacency=2d1h18m4s timeout=32s
The strange thing is that I normally got to Pisecna both via http 80 and ssh 22, even pinged through, but it was quite slow. I have no idea which way it went, traceroute had the last response from the first router. And up until now, I thought I could only go through Wireguard directly from one to the other.
 
hufhendr
just joined
Topic Author
Posts: 11
Joined: Wed Sep 07, 2022 10:27 pm

Re: OSPF is setting up the wrong interfaces

Sun Sep 11, 2022 11:19 pm

Interesting thing, I tried putting ptmp on all and on all all the neighbors disappeared. Even the routs uploaded via OSPF disappeared, suddenly they are not visible at all.
I'll wait till tomorrow to see if they don't sniff and then I'll revert.
 
hufhendr
just joined
Topic Author
Posts: 11
Joined: Wed Sep 07, 2022 10:27 pm

Re: OSPF is setting up the wrong interfaces

Mon Sep 12, 2022 12:15 am

Still nothing happened, so I tried switching to PTMP broadcast and added Wireguard network 10.200.0.0/24 to the backbone, the situation changed significantly.
/ip/route> print 
Flags: D - DYNAMIC; A - ACTIVE; c, o, v, y - COPY
Columns: DST-ADDRESS, GATEWAY, DISTANCE
    DST-ADDRESS        GATEWAY                    DISTANCE
DAv 0.0.0.0/0          Cetin PPPoE                       1
DAo 10.200.0.1/32      192.168.77.254%<ovpn-pha>       110
DAo 10.200.0.2/32      192.168.77.253%<ovpn-ps>        110
DAc 89.24.145.107/32   Cetin PPPoE                       0
DAo 192.168.2.0/24     192.168.77.254%<ovpn-pha>       110
DAo 192.168.2.1/32     192.168.77.253%<ovpn-ps>        110
DAo 192.168.3.0/24     192.168.77.253%<ovpn-ps>        110
DAo 192.168.3.1/32     192.168.77.254%<ovpn-pha>       110
D o 192.168.7.0/24     192.168.77.254%<ovpn-pha>       110
D o 192.168.7.0/24     192.168.77.253%<ovpn-ps>        110
DAc 192.168.7.0/24     bridge                            0
DAc 192.168.10.0/24    vlan2                             0
DAc 192.168.11.0/24    vlan3                             0
D o 192.168.77.253/32  192.168.77.253%<ovpn-ps>        110
DAc 192.168.77.253/32  <ovpn-ps>                         0
D o 192.168.77.254/32  192.168.77.254%<ovpn-pha>       110
DAc 192.168.77.254/32  <ovpn-pha>                        0
Still not quite right though, the neighbors around Wireguard are not directly visible.

Who is online

Users browsing this forum: No registered users and 3 guests