Community discussions

MikroTik App
 
jlopez
just joined
Topic Author
Posts: 9
Joined: Mon Mar 04, 2019 4:07 pm

[OSPF] MikroTik and Huawei neighbor establishment issues

Wed Aug 31, 2022 5:30 pm

Dear MikroTik community.

I have a MikrotTik CCR and Huawei router trying to deploy an ospf scenario:

This is MikroTik ospf configuration:

/interface vlan
add interface=combo1 name=OSPF_HUAWEI vlan-id=30

/ip address
add address=192.168.30.2/30 interface=OSPF_HUAWEI network=192.168.30.0

/routing ospf instance
set [ find default=yes ] name=OSPF redistribute-connected=as-type-1 router-id=192.168.30.2

/routing ospf interface
add instance-id=1 interface=OSPF_HUAWEI

/routing ospf network
add area=backbone network=192.168.30.0/30

This is Huawei configuration (ospf between two Huawei routers is successful):

ospf 1 router-id 192.168.30.1
import-route direct
opaque-capability enable
area 0.0.0.0
network 192.168.30.0 0.0.0.3
#
interface GigabitEthernet0/2/5.30
vlan-type dot1q 30
description OSPF_MIKROTIK
ip address 192.168.30.1 255.255.255.252
ospf cost 100
ospf enable 1 area 0.0.0.0

Both equipments have direct connectivity and ping is successful.

Thanks for your attention andl help.

Best regards.
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1676
Joined: Fri Aug 10, 2012 6:46 am
Location: iparchitechs.com
Contact:

Re: [OSPF] MikroTik and Huawei neighbor establishment issues

Wed Sep 07, 2022 4:43 pm

Verify MTU, timers and network type all match

I would also disable opaque LSA capability on the Huawei router until you have the neighbor working.
 
jlopez
just joined
Topic Author
Posts: 9
Joined: Mon Mar 04, 2019 4:07 pm

Re: [OSPF] MikroTik and Huawei neighbor establishment issues

Tue Sep 20, 2022 1:32 am

Thanks for your answer.

All parameters are the same in both routers, but issue remains.

Best regards.

Who is online

Users browsing this forum: No registered users and 1 guest