Community discussions

MikroTik App
 
davidon
just joined
Topic Author
Posts: 13
Joined: Wed Sep 28, 2022 10:03 pm

MikroTik suddenly stopped communicating

Wed Sep 28, 2022 10:05 pm

About 21 hours ago I noticed that I had the last communication which went through my MTik device.
That communication was SMTP.
Since then, I failed to perform the following two types of communication:
* SMTP from LAN ports to WAN/Internet port.
* HTTP, i.e. accessing the web interface of MTik via Internet port.

Until about 21 hours ago, those communication types worked well for a long time (about two years if not more).

I tried to connect the MTik device directly to my computer (via MTik Internet or LAN ports), but it didn't acquire IP Address.
I tried setting a manual IP Address, but still communication didn't work.

During the attempt to connect to the MTik device via HTTP, using Wireshark I noticed that the device didn't reply at all (as if it disappeared from the network).

My MTik device is hEX RB750Gr3.

Note that I didn't upgrade the RouterOS version of the MTik device for a long time as well.

I performed Reset to the MTik device and uploaded a backup configuration (which obviously worked in the past),
but then I couldn't connect to the web interface of the MTik device.
I was connected to the LAN port of the Router and MTik was connected to the LAN port of the Router via a different port, yet Wireshark showed that the MTik device constantly uses ARP to ask who is the gateway/router.

I wonder what could be the reason of it?
Such a weird behavior, happened out of the blue.
 
davidon
just joined
Topic Author
Posts: 13
Joined: Wed Sep 28, 2022 10:03 pm

Re: MikroTik suddenly stopped communicating

Thu Sep 29, 2022 1:51 am

UPDATE:

I successfully managed to connect to the web interface of the device by directly connecting Ethernet cable between my computer to the MTik Internet port.
Also I configured a manual IP address which was in the same network as the internet port.

The firewall rules allow me to connect to MTik via Internet port, so no issue here.

But if I connect the MTik device directly to the LAN port of the (other) router that I have, then:
* I'm unable to connect to MTik device (either HTTP or ping).
* I constantly see the MTik device sending Broadcast ARP ("who is 192.168.0.1 ? ..."), so it is awake and manages to communicate via the other router (no physical issue).
* I tried to configure manual MAC address in the ARP web page of MTik, but still I cannot access the MTik device (this time without the Broadcast ARP).
 
davidon
just joined
Topic Author
Posts: 13
Joined: Wed Sep 28, 2022 10:03 pm

Re: MikroTik suddenly stopped communicating  [SOLVED]

Thu Sep 29, 2022 10:19 pm

The problem seems to be with a bad RJ45 / Ethernet connections.

I plugged my MikroTik device directly to my main router and it was recognized quickly.

I checked the physical connection in the wall and it has issues with some of the wires.
 
User avatar
k6ccc
Forum Guru
Forum Guru
Posts: 1089
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: MikroTik suddenly stopped communicating

Thu Sep 29, 2022 11:03 pm

Layer 1 will get you every time!

Who is online

Users browsing this forum: Ca6ko, Google [Bot] and 25 guests