Community discussions

MikroTik App
 
futureping
just joined
Topic Author
Posts: 1
Joined: Tue Sep 21, 2021 6:44 pm

No link when connecting CCR2216-1G-12XS-2XQ QSPF28 interfaces

Wed Aug 17, 2022 3:13 am

Hi All

We recently purchased a new CCR2216-1G-12XS-2XQ and I am having trouble bring up the link between the device and two of our existing Cisco Nexus 3064-X devices. On the CCR side I am using both the QSFP28 interfaces to connect to the QSFP+ interfaces on the Nexus. I am also using 40G DAC cables from FS.com and I specified the encoding for each end of the cable. Before returning the cables I would like to rule out any misconfiguration on my end, which I assume is most likely the case. I am still new to Mikrotik and I was told that to bring the connection up I should only enable one of the interfaces and manually set the speed to 40Gbps but still no luck. Please see some of my configuration below
/interface export
# aug/16/2022 17:06:43 by RouterOS 7.4.1
# software id = I2YE-4LIK
#
# model = CCR2216-1G-12XS-2XQ
/interface bridge
add name=bridge1
/interface ethernet
set [ find default-name=qsfp28-1-1 ] auto-negotiation=no comment=\
    "To nexus-1 Eth1/49" speed=40Gbps
set [ find default-name=qsfp28-1-2 ] disabled=yes
set [ find default-name=qsfp28-1-3 ] disabled=yes
set [ find default-name=qsfp28-1-4 ] disabled=yes
set [ find default-name=qsfp28-2-1 ] auto-negotiation=no comment=\
    "To nexus-2 Eth1/49" speed=40Gbps
set [ find default-name=qsfp28-2-2 ] disabled=yes
set [ find default-name=qsfp28-2-3 ] disabled=yes
set [ find default-name=qsfp28-2-4 ] disabled=yes
set [ find default-name=sfp28-1 ] comment="To nexus-1 Eth1/17"
set [ find default-name=sfp28-2 ] comment="To nexus-1 Eth1/18"
set [ find default-name=sfp28-11 ] comment="To ccr-2 on sfp28-11"
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=qsfp28-1-1
add bridge=bridge1 interface=qsfp28-1-2
add bridge=bridge1 interface=qsfp28-1-3
add bridge=bridge1 interface=qsfp28-1-4
add bridge=bridge1 interface=qsfp28-2-1
add bridge=bridge1 interface=qsfp28-2-2
add bridge=bridge1 interface=qsfp28-2-3
add bridge=bridge1 interface=qsfp28-2-4
add bridge=bridge1 interface=sfp28-1
add bridge=bridge1 interface=sfp28-2
add bridge=bridge1 interface=sfp28-3
add bridge=bridge1 interface=sfp28-4
add bridge=bridge1 interface=sfp28-5
add bridge=bridge1 interface=sfp28-6
add bridge=bridge1 interface=sfp28-7
add bridge=bridge1 interface=sfp28-8
add bridge=bridge1 interface=sfp28-9
add bridge=bridge1 interface=sfp28-10
add bridge=bridge1 interface=sfp28-11
add bridge=bridge1 interface=sfp28-12
/interface list member
add interface=ether1 list=WAN
add interface=qsfp28-1-1 list=LAN
add interface=qsfp28-1-2 list=LAN
add interface=qsfp28-1-3 list=LAN
add interface=qsfp28-1-4 list=LAN
add interface=qsfp28-2-1 list=LAN
add interface=qsfp28-2-2 list=LAN
add interface=qsfp28-2-3 list=LAN
add interface=qsfp28-2-4 list=LAN
add interface=sfp28-1 list=LAN
add interface=sfp28-2 list=LAN
add interface=sfp28-3 list=LAN
add interface=sfp28-4 list=LAN
add interface=sfp28-5 list=LAN
add interface=sfp28-6 list=LAN
add interface=sfp28-7 list=LAN
add interface=sfp28-8 list=LAN
add interface=sfp28-9 list=LAN
add interface=sfp28-10 list=LAN
add interface=sfp28-11 list=LAN
add interface=sfp28-12 list=LAN

 
JimBouse
just joined
Posts: 7
Joined: Fri Apr 22, 2011 7:47 pm

Re: No link when connecting CCR2216-1G-12XS-2XQ QSPF28 interfaces

Tue Oct 04, 2022 9:29 pm

Good afternoon.

I recently got our 2216 setup and am struggling to get our 100G interfaces to come up as well.
Did you ever get this working?

Thanks,
Jim
 
User avatar
etdijarwanto
just joined
Posts: 7
Joined: Fri Jan 26, 2018 3:34 am
Location: Indonesia

Re: No link when connecting CCR2216-1G-12XS-2XQ QSPF28 interfaces

Fri Jan 06, 2023 8:50 am

Successfully connecting 40Gbps link on CCR2216-1G-12XS-2XQ to Nexus N6K using DAC 40G cable.
/interface/export 
# jan/06/2023 14:40:51 by RouterOS 7.6
# software id =
#
# model = CCR2216-1G-12XS-2XQ
# serial number = 
/interface ethernet
set [ find default-name=qsfp28-1-1 ] auto-negotiation=no comment="SW-N6K-CORE #Port Eth2/1" l2mtu=9570 mtu=9570 speed=40Gbps
set [ find default-name=qsfp28-1-2 ] l2mtu=9570 mtu=9570 speed=40Gbps
set [ find default-name=qsfp28-1-3 ] l2mtu=9570 mtu=9570 speed=40Gbps
set [ find default-name=qsfp28-1-4 ] l2mtu=9570 mtu=9570 speed=40Gbps

!Command: show running-config interface Ethernet2/1
!Time: Fri Jan  6 14:44:03 2023

interface Ethernet2/1
  description CCR2216-1G-12XS-2XQ#qsfp28-1
  switchport mode trunk
  duplex full
  no negotiate auto
Thank you,
Etdi J.

Who is online

Users browsing this forum: Ahrefs [Bot], Semrush [Bot] and 17 guests