Community discussions

MikroTik App
 
Grolus
just joined
Topic Author
Posts: 14
Joined: Thu Sep 29, 2022 8:33 pm

Routerboard hEX S - No Internet with fibre modem

Thu Sep 29, 2022 8:53 pm

Hey guys,
I got my MikroTik Router hEX S today and I want to provide internet access with each separated networks to three households over one fibre modem (Genexis FibreTwist G2110).

The Modem is connected with Ether1 and my client computer is connected with Ether2.

Also I added a DHCP client to Ether1 according to the following documentation: https://help.mikrotik.com/docs/display/ ... Connection

But the DHCP client remains in status "Status: searching..." forever.

The connection works perfectly fine with my "FritzBox! 7590". Does anyone have an idea what the problem is? I attached a few screenshots of the current configuration.

Thank you in advance!
You do not have the required permissions to view the files attached to this post.
 
Grolus
just joined
Topic Author
Posts: 14
Joined: Thu Sep 29, 2022 8:33 pm

Re: Routerboard hEX S - No Internet with fibre modem

Sat Oct 01, 2022 12:37 pm

Addition:
1. Yesterday I talked to a technician of our internet provider. He told me that this approach is correct in general and there should not be any problem with a MikroTik Routerboard
2. No I attached the Routerboard to the FritzBox to check, if the DHCP client works if the FritzBox is the Main Router and a DHCP server: it worked immediately. The Routerboard got an IP within the FritzBox's IP range. But no Internet so far.
 
User avatar
Znevna
Forum Guru
Forum Guru
Posts: 1198
Joined: Mon Sep 23, 2019 1:04 pm

Re: Routerboard hEX S - No Internet with fibre modem

Sat Oct 01, 2022 2:05 pm

From the screenshot provided, you're getting an IP from the same range as your LAN subnet (192.168.88.100) this is a non-working configuration.
Why are you getting 192.168.88.100 ?
 
erlinden
Forum Guru
Forum Guru
Posts: 1283
Joined: Wed Jun 12, 2013 1:59 pm

Re: Routerboard hEX S - No Internet with fibre modem

Sat Oct 01, 2022 2:28 pm

Instead of a couple of screenshots, it would be best to share your config (except for the private part):
/export hide-sensitive file=anynameyoulike
 
Grolus
just joined
Topic Author
Posts: 14
Joined: Thu Sep 29, 2022 8:33 pm

Re: Routerboard hEX S - No Internet with fibre modem

Sat Oct 01, 2022 4:47 pm

Why are you getting 192.168.88.100 ?
This was my last try (manual configuration) after automatic connection with a DHCP client did not work. Also it was not the port for the modem, but for the client PC.

But considering the recent insights I think I have to wait after I had another phone call with the providers technicians.
Because: I have two identical FritzBox Routers. One has been delivered by the provider. The other one I ordered myself. And for some reason the provider Fritzbox works perfectly, while the other one is also not able to connect with the Modem.
 
Grolus
just joined
Topic Author
Posts: 14
Joined: Thu Sep 29, 2022 8:33 pm

Re: Routerboard hEX S - No Internet with fibre modem

Tue Oct 04, 2022 10:44 am

Ok, after another call with a support guy right now I have learned that the delivered FritzBox Router was preconfigured. So lets forget about my initial DHCP problem for now.

I actually have so called "login data" for the internet connection that look as shown in the attached screenshot. I've already noticed that before but I did not find any field within the Mikrotik Configuration to use those data for a connection.

Is it possible to configure the internet connection only with those given information ("SIP-Domain / Realm", "Proxy Server" and "Registrar")

Thank you again!
You do not have the required permissions to view the files attached to this post.
 
User avatar
Znevna
Forum Guru
Forum Guru
Posts: 1198
Joined: Mon Sep 23, 2019 1:04 pm

Re: Routerboard hEX S - No Internet with fibre modem

Tue Oct 04, 2022 11:10 am

That information is only for SIP, nothing to do with your internet connection.
 
Grolus
just joined
Topic Author
Posts: 14
Joined: Thu Sep 29, 2022 8:33 pm

Re: Routerboard hEX S - No Internet with fibre modem

Tue Oct 04, 2022 6:02 pm

*sigh*

Ok, another approach: I figured out that the FritzBox requires a "VLAN ID" (provided by my provider) to make the internet running. This is three digit number. I never heard about VLAN's in that context.

Unfortunately I cannot find a documentation or forum thread that describes how to configure then internet access with having the providers VLAN ID only. Is there a way to do so?
What I have tried: I added a VLAN with the given VLAN ID to Ether1 (WAN Port, attached to the ONT). But that does not change anything. Here is the current configuration:
[admin@RouterOS] >> export hide-sensitive
# jan/05/1970 04:39:28 by RouterOS 6.48.6
# software id = QXQC-WMAZ
#
# model = RB760iGS
# serial number = HD2086154BV
/interface bridge
add admin-mac=18:FD:74:8B:4F:B0 auto-mac=no comment=defconf name=bridge
/interface vlan
add interface=ether1 name=vlan1 vlan-id=132
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=sfp1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=192.168.88.0
/ip dhcp-client
add comment=defconf disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
/system identity
set name=RouterOS
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

Out of curiosity: How to access the exported data if I saved it to a file? I had to omit the file name in the end of the export command to print the output. Since there are no linux tools like "ls" or "cat", I dont know how to find the file.
 
User avatar
Emil66
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Tue Aug 28, 2018 2:09 am

Re: Routerboard hEX S - No Internet with fibre modem

Tue Oct 04, 2022 6:05 pm

Make the Vlan interface the WAN interface, not the untagged ether1. Put the DHCP client on the Vlan, not the untagged ether1.
 
Grolus
just joined
Topic Author
Posts: 14
Joined: Thu Sep 29, 2022 8:33 pm

Re: Routerboard hEX S - No Internet with fibre modem

Wed Oct 05, 2022 10:43 am

Thank you, now I got a WAN IP. The router itself has internet access, as well as my windows network adaptor, according to it's status.
But: I'm still offline on the windows machine (cannot open any website and no other application is connecting).
 
User avatar
Emil66
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Tue Aug 28, 2018 2:09 am

Re: Routerboard hEX S - No Internet with fibre modem  [SOLVED]

Wed Oct 05, 2022 1:19 pm

Did you update the WAN interface list to include the VLAN interface but not ether1? That interface list is what configures the firewall for NAT to the internet, etc..
 
Grolus
just joined
Topic Author
Posts: 14
Joined: Thu Sep 29, 2022 8:33 pm

Re: Routerboard hEX S - No Internet with fibre modem

Wed Oct 05, 2022 6:53 pm

Thank you, with your tip I figured it out:
I had to add a NAT rule with action "maquerade" and Out. Interface "vlan1".

I'm happy now :)
 
User avatar
Emil66
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Tue Aug 28, 2018 2:09 am

Re: Routerboard hEX S - No Internet with fibre modem

Wed Oct 05, 2022 7:48 pm

You had that already, because it's part of the default firewall configuration:
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
You just need to edit the "WAN" interface list to include your vlan interface (which is your WAN) and remove the ether1 interface (which is not). There are other firewall rules which depend on the WAN interface list correctly listing your WAN interface(s), so this is a better solution than manually adding a NAT rule for a specific interface. Specifically, you want this one to take effect:
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
 
Grolus
just joined
Topic Author
Posts: 14
Joined: Thu Sep 29, 2022 8:33 pm

Re: Routerboard hEX S - No Internet with fibre modem

Thu Oct 06, 2022 9:52 am

Ok, I will check that out. Thanks!

Who is online

Users browsing this forum: Sela69 and 23 guests