Community discussions

MikroTik App
 
IBREDSOPORTE
just joined
Topic Author
Posts: 3
Joined: Fri Jul 22, 2022 3:43 pm

OSPFv3 - NSSA does not work between v6 & v7

Thu Oct 20, 2022 10:57 am

Hi Community,

We are configurating OSPFv3 with NSSA type area between RB2011UiAS routeros v6.48.6 and RB2011UiAS routeros v7.3 and it does not work. Instead of OSPFv2 that works perfectly.


v6.48.6 config:
/interface bridge
add name=Lo_BR protocol-mode=none
/routing ospf-v3 area
set [ find default=yes ] disabled=yes
/routing ospf-v3 instance
set [ find default=yes ] disabled=yes
add name=ospf-v3 router-id=10.0.0.2
/routing ospf-v3 area
add area-id=0.0.0.1 default-cost=1 inject-summary-lsas=no instance=ospf-v3 \
    name=area1 translator-role=translate-never type=nssa
/ip address
add address=10.0.0.2 interface=Lo_BR network=10.0.0.2
/ipv6 address
add address=f305:2f75:1f0::1/127 advertise=no interface=ether3
/routing ospf-v3 interface
add area=area1 interface=ether3 network-type=point-to-point priority=128
/system identity
set name=RouterOS

v7.3 config:
/interface bridge
add name=Lo_BR protocol-mode=none
/routing ospf instance
add disabled=no in-filter-chain=ospf-in name=ospf-v3 out-filter-chain=ospf-out \
    redistribute=connected router-id=10.0.0.1 version=3
/routing ospf area
add area-id=0.0.0.1 disabled=no instance=ospf-v3 name=area1 nssa-translator=\
    candidate type=nssa
/ip address
add address=10.0.0.1 comment=loopback interface=Lo_BR network=10.0.0.1
/ipv6 address
add address=f305:2f75:1f0::/127 advertise=no interface=ether3
/ipv6 firewall address-list
add address=f305:2f75:1f0::/127 list=OSPFv3
/routing filter rule
add chain=ospf-in disabled=no rule="accept;"
add chain=ospf-out disabled=no rule="accept;"
/routing ospf interface-template
add area=area1 cost=10 disabled=no interfaces=ether3 prefix-list=OSPFv3 type=\
    ptp


When "default" or "stub" area type is configurated OSPFv3 state is FULL and works but when we "NSSA" type area is configurated OSPF state is "EXSTART" and doesnt works.

¿Could you help me?

Who is online

Users browsing this forum: Semrush [Bot] and 4 guests