Community discussions

MikroTik App
 
lurch
just joined
Topic Author
Posts: 22
Joined: Mon Jan 24, 2022 5:45 pm

traffic slower in one direction

Thu Oct 20, 2022 3:30 pm

I have an iperf client connected to sfp-sfpplus3 the machine has 2.5gpbs link. On sfp-sfpplus4 I have an iperf server with a 10gbps link

when doing an upload iperf i see

[SUM] 0.00-10.00 sec 2.69 GBytes 2.31 Gbits/sec 995 sender
[SUM] 0.00-10.01 sec 2.69 GBytes 2.31 Gbits/sec receiver

but when doing a download i get

[SUM] 0.00-10.00 sec 555 MBytes 465 Mbits/sec 16063 sender
[SUM] 0.00-10.00 sec 553 MBytes 463 Mbits/sec receiver

slower with a lot of retransmissions.

I've tried hardware offloading etc but nothing seems to make a difference has anyone else experienced this issue?
# oct/20/2022 13:22:31 by RouterOS 7.2.3
# software id = 
# model = CRS354-48G-4S+2Q+
/interface bridge
add admin-mac= auto-mac=no comment=defconf \
    ingress-filtering=no name=bridge vlan-filtering=yes
/interface ethernet
set [ find default-name=sfp-sfpplus2 ] auto-negotiation=no full-duplex=no \
    speed=10Gbps
set [ find default-name=sfp-sfpplus4 ] speed=10Gbps
/interface vlan
/interface ethernet switch
set 0 l3-hw-offloading=yes
/interface ethernet switch port
set 0 l3-hw-offloading=no
set 1 l3-hw-offloading=no
set 2 l3-hw-offloading=no
set 3 l3-hw-offloading=no
set 4 l3-hw-offloading=no
set 5 l3-hw-offloading=no
set 6 l3-hw-offloading=no
set 7 l3-hw-offloading=no
set 10 limit-broadcasts=no
set 12 egress-rate=10.0Mbps ingress-rate=10.0Mbps l3-hw-offloading=no
set 13 egress-rate=20.0Mbps ingress-rate=20.0Mbps
set 14 l3-hw-offloading=no
set 15 l3-hw-offloading=no
set 16 l3-hw-offloading=no
set 17 egress-rate=526.0Mbps ingress-rate=570.0Mbps l3-hw-offloading=no
set 18 egress-rate=526.0Mbps ingress-rate=570.0Mbps l3-hw-offloading=no
set 19 l3-hw-offloading=no
set 20 l3-hw-offloading=no
set 24 l3-hw-offloading=no
set 25 l3-hw-offloading=no
set 26 l3-hw-offloading=no
set 27 l3-hw-offloading=no
set 28 l3-hw-offloading=no
set 29 l3-hw-offloading=no
set 30 l3-hw-offloading=no
set 31 l3-hw-offloading=no
set 32 l3-hw-offloading=no
set 33 l3-hw-offloading=no
set 34 l3-hw-offloading=no
set 35 l3-hw-offloading=no
set 36 l3-hw-offloading=no
set 37 l3-hw-offloading=no
set 38 l3-hw-offloading=no
set 39 l3-hw-offloading=no
set 40 l3-hw-offloading=no
set 41 l3-hw-offloading=no
set 42 l3-hw-offloading=no
set 43 l3-hw-offloading=no
set 44 l3-hw-offloading=no
set 45 l3-hw-offloading=no
set 46 l3-hw-offloading=no
set 47 l3-hw-offloading=no
set 48 l3-hw-offloading=no
set 49 l3-hw-offloading=no
set 50 l3-hw-offloading=no
set 51 l3-hw-offloading=no
set 52 l3-hw-offloading=no
set 53 l3-hw-offloading=no
set 54 l3-hw-offloading=no
set 55 l3-hw-offloading=no
set 56 l3-hw-offloading=no
set 57 l3-hw-offloading=no
set 58 l3-hw-offloading=no
set 59 l3-hw-offloading=no
/interface list
add name=WAN
add name=LAN
/interface lte apn
set [ find default=yes ] ip-type=ipv4 use-network-apn=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=vlan208_pool ranges=10.10.0.209-10.10.0.222
/ip dhcp-server
add address-pool=vlan71_pool bootp-support=none interface=vlan71 lease-time=\
    1d name=vlan71_dhcp
add address-pool=vlan200_pool bootp-support=none interface=vlan200 \
    lease-time=1d name=vlan200_dhcp
add address-pool=vlan4010_pool interface=vlan4010 lease-time=1h name=\
    vlan4010_dhcp
add address-pool=vlan208_pool bootp-support=none interface=vlan208 name=\
    vlan208_dhcp
/port
set 0 name=serial0
/ppp profile
add local-address=vlan4010_pool name=profile1 remote-address=vlan4010_pool \
    use-ipv6=no
/queue type
add kind=red name=default_red red-avg-packet=1300
/routing bgp template
set default disabled=no output.network=bgp-networks
/routing ospf instance
add disabled=no name=default-v2
/routing ospf area
add disabled=yes instance=default-v2 name=backbone-v2
/interface bridge port
add bridge=bridge comment=defconf ingress-filtering=no interface=ether1 pvid=\
    801
add bridge=bridge comment=defconf ingress-filtering=no interface=ether2 pvid=\
    802
add bridge=bridge comment=defconf ingress-filtering=no interface=ether3 pvid=\
    803
add bridge=bridge comment=defconf ingress-filtering=no interface=ether4 pvid=\
    804
add bridge=bridge comment=defconf ingress-filtering=no interface=ether5 pvid=\
    71
add bridge=bridge comment=defconf ingress-filtering=no interface=ether6 pvid=\
    71
add bridge=bridge comment=defconf ingress-filtering=no interface=ether7 pvid=\
    71
add bridge=bridge comment=defconf ingress-filtering=no interface=ether8 pvid=\
    71
add bridge=bridge comment=defconf ingress-filtering=no interface=ether9 pvid=\
    801
add bridge=bridge comment=defconf ingress-filtering=no interface=ether10
add bridge=bridge comment=defconf ingress-filtering=no interface=ether11
add bridge=bridge comment=defconf ingress-filtering=no interface=ether12 \
    pvid=200
add bridge=bridge comment=defconf ingress-filtering=no interface=ether13 \
    pvid=200
add bridge=bridge comment=defconf ingress-filtering=no interface=ether14
add bridge=bridge comment=defconf ingress-filtering=no interface=ether15
add bridge=bridge comment=defconf ingress-filtering=no interface=ether16
add bridge=bridge comment=defconf ingress-filtering=no interface=ether17
add bridge=bridge comment=defconf ingress-filtering=no interface=ether18
add bridge=bridge comment=defconf ingress-filtering=no interface=ether19
add bridge=bridge comment=defconf ingress-filtering=no interface=ether21
add bridge=bridge comment=defconf ingress-filtering=no interface=ether22
add bridge=bridge comment=defconf ingress-filtering=no interface=ether23 \
    pvid=200
add bridge=bridge comment=defconf ingress-filtering=no interface=ether24 \
    pvid=208
add bridge=bridge comment=defconf ingress-filtering=no interface=ether25
add bridge=bridge comment=defconf ingress-filtering=no interface=ether26
add bridge=bridge comment=defconf ingress-filtering=no interface=ether27
add bridge=bridge comment=defconf ingress-filtering=no interface=ether28
add bridge=bridge comment=defconf ingress-filtering=no interface=ether29
add bridge=bridge comment=defconf ingress-filtering=no interface=ether30
add bridge=bridge comment=defconf ingress-filtering=no interface=ether31
add bridge=bridge comment=defconf ingress-filtering=no interface=ether32
add bridge=bridge comment=defconf ingress-filtering=no interface=ether33
add bridge=bridge comment=defconf ingress-filtering=no interface=ether34
add bridge=bridge comment=defconf ingress-filtering=no interface=ether35
add bridge=bridge comment=defconf ingress-filtering=no interface=ether36
add bridge=bridge comment=defconf ingress-filtering=no interface=ether37
add bridge=bridge comment=defconf ingress-filtering=no interface=ether38
add bridge=bridge comment=defconf ingress-filtering=no interface=ether39
add bridge=bridge comment=defconf ingress-filtering=no interface=ether40
add bridge=bridge comment=defconf ingress-filtering=no interface=ether41
add bridge=bridge comment=defconf ingress-filtering=no interface=ether42 \
    pvid=71
add bridge=bridge comment=defconf ingress-filtering=no interface=ether43
add bridge=bridge comment=defconf ingress-filtering=no interface=ether44
add bridge=bridge comment=defconf ingress-filtering=no interface=ether45 \
    pvid=200
add bridge=bridge comment=defconf ingress-filtering=no interface=ether46
add bridge=bridge comment=defconf ingress-filtering=no interface=ether47
add bridge=bridge comment=defconf ingress-filtering=no interface=ether48 \
    pvid=71
add bridge=bridge comment=defconf ingress-filtering=no interface=ether49
add bridge=bridge comment=defconf ingress-filtering=no interface=qsfpplus1-1
add bridge=bridge comment=defconf ingress-filtering=no interface=qsfpplus1-2
add bridge=bridge comment=defconf ingress-filtering=no interface=qsfpplus1-3
add bridge=bridge comment=defconf ingress-filtering=no interface=qsfpplus1-4
add bridge=bridge comment=defconf ingress-filtering=no interface=qsfpplus2-1
add bridge=bridge comment=defconf ingress-filtering=no interface=qsfpplus2-2
add bridge=bridge comment=defconf ingress-filtering=no interface=qsfpplus2-3
add bridge=bridge comment=defconf ingress-filtering=no interface=qsfpplus2-4
add bridge=bridge comment=defconf ingress-filtering=no interface=sfp-sfpplus1
add bridge=bridge comment=defconf ingress-filtering=no interface=sfp-sfpplus3
add bridge=bridge comment=defconf ingress-filtering=no interface=sfp-sfpplus4
add bridge=bridge interface=ether20
add bridge=bridge interface=sfp-sfpplus2
/ip settings
set max-neighbor-entries=8192
/ipv6 settings
set disable-ipv6=yes max-neighbor-entries=8192
/interface bridge vlan
add bridge=bridge vlan-ids=1
add bridge=bridge tagged=sfp-sfpplus1,bridge vlan-ids=200
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=400
add bridge=bridge tagged=sfp-sfpplus2,sfp-sfpplus1,bridge vlan-ids=4010
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=401
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=402
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=403
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=404
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=405
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=406
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=407
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=409
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=418
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=419
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=420
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=421
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=422
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=450
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=451
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=452
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=501
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=502
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=503
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=601
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=603
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=604
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=700
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=801
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=802
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=803
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=804
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=999
add bridge=bridge tagged=sfp-sfpplus1,bridge vlan-ids=71
add bridge=bridge tagged=sfp-sfpplus1,bridge vlan-ids=208
add bridge=bridge tagged=sfp-sfpplus1 vlan-ids=805
/interface list member
add interface=ether1 list=LAN
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
add interface=ether5 list=LAN
add interface=ether6 list=LAN
add interface=ether7 list=LAN
add interface=ether8 list=LAN
add interface=ether9 list=LAN
add interface=ether10 list=LAN
add interface=ether11 list=LAN
add interface=ether12 list=LAN
add interface=ether13 list=LAN
add interface=ether14 list=LAN
add interface=ether15 list=LAN
add interface=ether16 list=LAN
add interface=ether17 list=LAN
add interface=ether18 list=LAN
add interface=ether19 list=LAN
add interface=ether20 list=LAN
add interface=ether21 list=LAN
add interface=ether22 list=LAN
add interface=ether23 list=LAN
add interface=ether24 list=LAN
add interface=ether25 list=LAN
add interface=ether26 list=LAN
add interface=ether27 list=LAN
add interface=ether28 list=LAN
add interface=ether29 list=LAN
add interface=ether30 list=LAN
add interface=ether31 list=LAN
add interface=ether32 list=LAN
add interface=ether33 list=LAN
add interface=ether34 list=LAN
add interface=ether35 list=LAN
add interface=ether36 list=LAN
add interface=ether37 list=LAN
add interface=ether38 list=LAN
add interface=ether39 list=LAN
add interface=ether40 list=LAN
add interface=ether41 list=LAN
add interface=ether42 list=LAN
add interface=ether43 list=LAN
add interface=ether44 list=LAN
add interface=ether45 list=LAN
add interface=ether46 list=LAN
add interface=ether47 list=LAN
add interface=ether48 list=LAN
add interface=ether49 list=LAN
add interface=qsfpplus1-1 list=LAN
add interface=qsfpplus1-2 list=LAN
add interface=qsfpplus1-3 list=LAN
add interface=qsfpplus1-4 list=LAN
add interface=qsfpplus2-1 list=LAN
add interface=qsfpplus2-2 list=LAN
add interface=qsfpplus2-3 list=LAN
add interface=qsfpplus2-4 list=LAN
add interface=sfp-sfpplus1 list=LAN
add interface=sfp-sfpplus2 list=LAN
add interface=sfp-sfpplus3 list=LAN
add interface=sfp-sfpplus4 list=LAN
/interface ovpn-server server
set auth=sha1,md5
/ip address
add address=10.10.0.9/24 interface=bridge network=10.10.0.0
/ip dhcp-server lease
/ip dhcp-server network
add address=10.10.0.208/28 dns-server=1.1.1.1,8.8.8.8 gateway=10.10.0.210 \
    netmask=28
/ip dns
set servers=1.1.1.1
/ip firewall filter
add action=fasttrack-connection chain=forward connection-state=\
    established,related hw-offload=yes protocol=tcp
add action=fasttrack-connection chain=forward connection-state=\
    established,related hw-offload=no
add action=accept chain=forward connection-state=established,related
/ip firewall nat
add action=masquerade chain=srcnat log=yes out-interface=bridge src-address=\
    10.10.0.208/28
add action=accept chain=dstnat in-interface=bridge
/ip route
add disabled=no dst-address=0.0.0.0/0 gateway=10.10.0.2
/system clock
set time-zone-name=Europe/London
/system identity
set name=RouterOS
/system routerboard settings
set boot-os=router-os
 
FurthestCastle
just joined
Posts: 4
Joined: Sun Oct 23, 2022 2:10 am

Re: traffic slower in one direction

Sun Oct 23, 2022 2:27 am

Yes! Did you find a resolution?

My configuration also includes three 10 Gbe hosts (pfsense, proxmox, and truenas). They also experience the asymmetric speed issue. At best they get 4 Gbps throughput.

Who is online

Users browsing this forum: No registered users and 15 guests