Community discussions

MikroTik App
 
kraal
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 83
Joined: Tue Jan 19, 2021 10:24 pm

Netinstall hAP ac2

Fri Oct 21, 2022 4:43 pm

Hello,

I am trying to use netinstall for the first time and I'm really struggling with the procedure indicated on https://help.mikrotik.com/docs/display/ROS/Netinstall.
Maybe you could help me.

The target device is a hAP ac2 curently running RouterOS 6.49.7 Stabe (multi packages), the host from which I need to run netinstall is under linux.

What I want to achieve: downgrade this hAP ac2 to 6.48.6 (single package npk)

What I'm doing:
  • remove all cables from the hAP ac2
  • plug a cable directly from the host computer to the hAP ac2
  • turn off the hAP ac2
  • configure the host computer network device (ip 192.168.88.2, gw and dns 192.168.88.1, mask 255.255.255.0)
  • retrieved the netinstall tool on the host (`wget https://download.mikrotik.com/routeros/ ... 9.7.tar.gz`)
  • extract netinstall
  • run it `netinstall-cli -a 192.168.88.3 <my target npk>
  • plug the hAP ac2 and try to put it in etherboot state (by pressing the reset button before plugin back the power cable and keeping it pressed)
On the host computer, the last message which is displayed is "Waiting for RouterBOARD..."
My guess is that I do not succeed in putting the hAP ac2 in etherboot state...

So the stupiud question is : on what button should I press and when should I release pressing on it (tried various duraations up to 20 secs...) ? I must be really dumb not to be able to do it.

Thanks a lot in advance,

Michel.
 
erlinden
Forum Guru
Forum Guru
Posts: 1281
Joined: Wed Jun 12, 2013 1:59 pm

Re: Netinstall hAP ac2

Fri Oct 21, 2022 4:48 pm

Instead of using 192.168.88.3 you should use 192.168.88.1
 
holvoetn
Forum Guru
Forum Guru
Posts: 1822
Joined: Tue Apr 13, 2021 2:14 am
Location: Belgium

Re: Netinstall hAP ac2

Fri Oct 21, 2022 11:47 pm

I use 88.3 as well.
I even colored that bold red in my notes to make no mistake.

Keep pressing the button until you see it starts.
 
Njumaen
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Feb 24, 2016 8:41 pm

Re: Netinstall hAP ac2

Sat Oct 22, 2022 8:52 am

Are you shure that you plugged the PC into the ETH1/WAN port???

The etherboot loader just looks there!
 
kraal
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 83
Joined: Tue Jan 19, 2021 10:24 pm

Re: Netinstall hAP ac2

Sun Oct 23, 2022 10:48 pm

Well... Once I turned off UFW everything (obviously) started working as expected...

Thanks for your help though :-)

Who is online

Users browsing this forum: seriquiti and 21 guests