Community discussions

MikroTik App
 
jeroenR90S
just joined
Topic Author
Posts: 9
Joined: Tue Dec 08, 2020 10:30 pm

RB960 BGP Proxmox SDN "unsupported capability"

Thu Jul 01, 2021 1:08 pm

First of all, this is a home(lab) setup combining proxmox SDN (which runs FRR onderneath) in which BGP is overkill, but I want to see how it works and learn from that.
One of the things is always that you learn the most if things are not working, hence my question.
I don't have a real design per-se, but a quick text drawing:

Mikrotik RB960 BGP peer <-> Proxmox EVPN/BGP controller as peer -> vrf -> (vx)lans
192.168.88.1 AS=65530 192.168.88.249 AS=65530 (so iBGP)

I'm not certain if pasting in my entire Mikrotik config in here is useful, but this is the log entry I keep seeing repeated on the RB960:
9:47:48 route,bgp,info TCP connection established 
09:47:48 route,bgp,info     RemoteAddress=192.168.88.249 
09:47:48 route,bgp,error Received notification 
09:47:48 route,bgp,error     OPEN error: unsupported capability 
The proxmox syslog shows this, for some reason this will not paste properly as code:
Jul 01 09:45:55 <hostname> bgpd[924]: [EC 33554451] 192.168.88.1 [Error] Configured AFI/SAFIs do not overlap with received MP capabilities
Jul 01 09:45:55 <hostname> bgpd[924]: %NOTIFICATION: sent to neighbor 192.168.88.1 2/7 (OPEN Message Error/Unsupported Capability) 12 bytes 01 04 00 01
Jul 01 09:45:55 <hostname> bgpd[924]: [EC 33554451] bgp_process_packet: BGP OPEN receipt failed for peer: 192.168.88.1

This is how the RB960 is set up:
/routing bgp peer
add address-families=ip,l2vpn disabled=no name=proxmox-epvpnctl1 \
    remote-address=192.168.88.249 remote-as=65530 use-bfd=yes

/routing bgp instance
set default router-id=192.168.88.1
 
notes:
Bear with me regarding the bfd and address families
I changed the router ID from it's original 0.0.0.0. but reading the documentation this would normally not be needed.
I'm not advertising any networks from my RB960 to the proxmox (yet).

Editing the config in Proxmox is mainly GUI work, but as I wrote underneath is FRR which is stored here:
root@<host>:~# cat /etc/frr/frr.conf 
log syslog informational
ip forwarding
ipv6 forwarding
frr defaults datacenter
service integrated-vtysh-config
hostname <hostname>
!
!
vrf vrf_evpnz1
 vni 10000
exit-vrf
!
router bgp 65530
 bgp router-id 192.168.88.249
 no bgp default ipv4-unicast
 coalesce-time 1000
 neighbor VTEP peer-group
 neighbor VTEP remote-as 65530
 neighbor VTEP bfd
 neighbor 192.168.88.1 peer-group VTEP
 !
 address-family ipv4 unicast
  import vrf vrf_evpnz1
 exit-address-family
 !
 address-family ipv6 unicast
  import vrf vrf_evpnz1
 exit-address-family
 !
 address-family l2vpn evpn
  neighbor VTEP activate
  advertise-all-vni
 exit-address-family
!
router bgp 65530 vrf vrf_evpnz1
 !
 address-family ipv4 unicast
  redistribute connected
 exit-address-family
 !
 address-family ipv6 unicast
  redistribute connected
 exit-address-family
 !
 address-family l2vpn evpn
  default-originate ipv4
  default-originate ipv6
 exit-address-family
!
line vty
This config is why I specified the bfd and specific ip and l2vpn in the mikrotik, but that does not make a difference if I set that or leave default on the RB960.
Some settings can only be done in this file and are not yet available in the Proxmox gui.
Kind of puzzled by this line:
 no bgp default ipv4-unicast
 
Is there anything fundamentally wrong in this config? Or is the next step to start capturing packets and see what's actually inside there?

Best regards, and thanks in advance for any pointers,

Jeroen
 
jeroenR90S
just joined
Topic Author
Posts: 9
Joined: Tue Dec 08, 2020 10:30 pm

Re: RB960 BGP Proxmox SDN "unsupported capability"

Thu Jul 01, 2021 2:33 pm

Apparently I'm being a dumbass again -does ROS 6.47.10 actually support evpn/vxlan....?
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 9596
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: RB960 BGP Proxmox SDN "unsupported capability"

Thu Jul 01, 2021 2:54 pm

no... only the 7 beta
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 2029
Joined: Mon Jan 14, 2008 1:53 pm
Location: Over the Rainbow
Contact:

Re: RB960 BGP Proxmox SDN "unsupported capability"

Thu Jul 01, 2021 2:56 pm

Apparently I'm being a dumbass again -does ROS 6.47.10 actually support evpn/vxlan....?
Definately not.

The best path is to email support@mikrotik.com to request eVPN support
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 9596
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: RB960 BGP Proxmox SDN "unsupported capability"

Thu Jul 01, 2021 2:59 pm

For example eVPN/VxLAN are supported starting from 7.0beta5, but are not stable version, just for play...
On production I only use 6.47.10.
 
jeroenR90S
just joined
Topic Author
Posts: 9
Joined: Tue Dec 08, 2020 10:30 pm

Re: RB960 BGP Proxmox SDN "unsupported capability"

Fri Jul 02, 2021 9:23 am

Thanks for the confirmation, guess this really shows you should start with a plan and some basic research, even for home! (I probably make too much plans at work already...)
The best path is to email support@mikrotik.com to request eVPN support
Just done that! Would be awesome if it could be included in 6.x as well...
I have my birthday coming up, maybe I could ask a new RB960 and try the latest 7.x on that...

Jeroen
 
User avatar
eset
Member Candidate
Member Candidate
Posts: 104
Joined: Tue Dec 15, 2015 5:15 pm
Contact:

Re: RB960 BGP Proxmox SDN "unsupported capability"

Thu Jul 07, 2022 2:38 am

So it's clear that R7.0 must be set on MT ? I manage to connect to BGP on MT from promos using BGP Controller. But using also BGP-EVPN I still can't ping. I receive routes on MT from Subnets but I don't see any routes deployed to VMs

Who is online

Users browsing this forum: Ahrefs [Bot] and 4 guests