Community discussions

MikroTik App
 
woodych
just joined
Topic Author
Posts: 12
Joined: Fri Nov 12, 2021 7:09 pm

RouterOS 7.1: Multicast PIM SM configuration - HowTo?

Sun Jan 16, 2022 9:43 am

Dear Community

It looks as my previous post was lost then MikroTik had a server outage a couple of weeks ago.

After upgrading from RouterOS 6 to RouterOS 7.1 my multicast PIM Routing config was gone. That part is all now, NP!

But whatever I do when I try to add a BSR or PR candidate. I get presented the Error: Couldn't add New PIM Candidate - address interface must be specified (6)

Whatever I specify as address, is not being accepted. Not via WebGUI nor via CLI.

Wiki is outdated and only covers RouterOs 6 PIM. Has anyone managed to get PIM SM to work on RouterOS 7?

Edit: I think there is a serious bug in PIM SM.
After adding an instance and then adding an interface template, the instance disappears and the WebGUI behave strangely.

So I went to the CLI and tried:

/routing/pimsm/instance/add name=pimsm1 vrf=main
/routing/pimsm/instance/print

=> Mikrotik hangs!
=> Mikrotik looses default route!

=> Manual Reboot. Operation restored, but pimsm1 instance disappeard again.

-Benoît-
 
Liv
just joined
Posts: 1
Joined: Thu Dec 02, 2021 1:18 pm

Re: RouterOS 7.1: Multicast PIM SM configuration - HowTo?

Thu Feb 17, 2022 7:18 pm

my Pim routing config is gone as well when upgraded to 7.1.1,
did you find a fix?
Thanks
 
woodych
just joined
Topic Author
Posts: 12
Joined: Fri Nov 12, 2021 7:09 pm

Re: RouterOS 7.1: Multicast PIM SM configuration - HowTo?

Sun Jun 12, 2022 8:51 am

Unfortunately not yet. But if you search the forum form "pimsm" you will find many issue mentioned with V7 and nobody confirming it works :-)
Release Notes for 7.4rc seem to indicate a fix coming. A user wrote pimsm started to work on this version. But I an not going to test 7.4rc on my main router. I'll wait for the propper release.

Who is online

Users browsing this forum: No registered users and 12 guests