Community discussions

MikroTik App
 
GMordal
just joined
Topic Author
Posts: 1
Joined: Fri Jan 28, 2022 4:57 pm

ROS 7.x problem - vpls mtu only 1500B

Fri Jan 28, 2022 6:02 pm

Hello all.
I am testing RB5009 for data transmission via mpls / vpls. I need to carry an ethernet frame of 1540B size.
So far I have used ROS 6.4x.x on HEX-S, on MTU = 2000B interfaces.
I verified v7.1.1 and v7.2.rc2 on RB5009.

My problem is that despite starting vpls, where PW L2MTU = 2000B, MTU = 2000B, Actual MTU automaticly is set to 1500B.
It is the same on the bridge to which this vpls is added.

Packets larger than 1500B are not transported through this vpls.

Where did I go wrong?


#    NAME           MTU  MAC-ADDRESS        ARP      SWITCH 
0 R  ether1        2200  DC:2C:6E:3B:F0:3B  enabled  switch1        << uplink
1 RS ether2        2000  DC:2C:6E:3B:F0:3C  enabled  switch1     << to client


/interface vlan
add interface=ether1 loop-protect=off mtu=2000 name=vlan100-mpls vlan-id=100

/mpls interface
add disabled=no input=yes interface=vlan100-mpls mpls-mtu=2000

/interface vpls
add arp=disabled bridge=bridge-vpls-td cisco-static-id=20991 disabled=no mac-address=02:70:35:2D:1D:44 mtu=2000 name=vpls-td peer=10.20.100.1 pw-l2mtu=2000 pw-type=raw-ethernet

 > /interface/vpls/print detail 
Flags: X - disabled, R - running; D - dynamic; B - bgp-signaled, C - cisco-bgp-signaled 
 0 R   name="vpls-td" mtu=2000 mac-address=02:70:35:2D:1D:44 arp=disabled arp-timeout=auto peer=10.20.100.1 cisco-static-id=20991 pw-type=raw-ethernet pw-l2mtu=2000 bridge=bridge-vpls-td 



> /interface/bridge/port print 
Flags: D - DYNAMIC; H - HW-OFFLOAD
Columns: INTERFACE, BRIDGE, HW, PVID, PRIORITY, PATH-COST, INTERNAL-PATH-COST, HORIZON
#    INTERFACE  BRIDGE          HW   PVID  PRIORITY  PATH-COST  INTERNAL-PATH-COST  HORIZON
0  H ether2     bridge-vpls-td  yes     1  0x80             10                  10  none   
1 D  vpls-td    bridge-vpls-td          1  0x80             10                  10  none  

 /interface/bridge/print 
Flags: X - disabled, R - running 
 0 R name="bridge-loopback1" mtu=2200 actual-mtu=2200 l2mtu=65535 arp=enabled arp-timeout=auto mac-address=F2:44:89:2C:32:47 protocol-mode=none fast-forward=yes igmp-snooping=no auto-mac=yes 
     ageing-time=5m vlan-filtering=no dhcp-snooping=no 

 1 R name="bridge-vpls-td" mtu=2000 actual-mtu=1500 l2mtu=2000 arp=disabled arp-timeout=auto mac-address=DC:2C:6E:3B:F0:3C protocol-mode=none fast-forward=yes igmp-snooping=no auto-mac=yes 
     ageing-time=5m vlan-filtering=no dhcp-snooping=no 


Zrzut ekranu 2022-01-28 o 16.47.41.png
You do not have the required permissions to view the files attached to this post.
 
fluppir
just joined
Posts: 1
Joined: Fri Mar 11, 2022 12:25 am

Re: ROS 7.x problem - vpls mtu only 1500B

Fri Mar 11, 2022 1:10 pm

Hi

Have the same symptoms. I first tried it on a CHR, and had the problem. Then I tried on a 2004. On both devices, using latest stable v6.49.4 , I can ping 1500 without fragmentation, no problems. Just upgrading ( and this is even before I bring up the vpls) to v7 gets it to fail. If I disable MPLS, it works. There is a 4 byte shortage somewhere in the mix. Who knows how to fix that ?!?!
 
eliuzhc
just joined
Posts: 1
Joined: Tue Apr 26, 2022 11:12 am

Re: ROS 7.x problem - vpls mtu only 1500B

Tue Apr 26, 2022 11:22 am

After days spent messing around with it I've found that this problem can be resolved by setting manually the mtu at 1508 under mpls/mpls interface menu. In my case this setting solved the problem.
Before fix:
/mpls ldp
add disabled=no lsr-id=10.250.250.80 transport-addresses=10.250.250.80
/mpls ldp interface
add accept-dynamic-neighbors=yes afi=ip disabled=no interface=E002_ transport-addresses=""
After fix:
/mpls interface
add disabled=no interface=E002_ mpls-mtu=1508
/mpls ldp
add disabled=no lsr-id=10.250.250.80 transport-addresses=10.250.250.80
/mpls ldp interface
add accept-dynamic-neighbors=yes afi=ip disabled=no interface=E002_ transport-addresses=""
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6815
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: ROS 7.x problem - vpls mtu only 1500B

Tue Apr 26, 2022 2:04 pm

Try with 7.3beta37, MPLS MTUs and PW MTUS should be fixed.

Who is online

Users browsing this forum: No registered users and 3 guests