Community discussions

MikroTik App
 
User avatar
Maggiore81
Trainer
Trainer
Topic Author
Posts: 477
Joined: Sun Apr 15, 2012 12:10 pm
Location: Italy
Contact:

Routing filter problem

Tue May 03, 2022 4:36 pm

Hello
Upgraded latest longterm v6 to v7
I have a problem with a filter:
drop any except the default route

/routing filter rule
add chain=bgp-cliente disabled=no rule="if (not dst == 0.0.0.0/0) { reject; }"


it was created after upgrade from v6.
doesnt work, dont export anything.

can someone help me?
 
pe1chl
Forum Guru
Forum Guru
Posts: 9000
Joined: Mon Jun 08, 2015 12:09 pm

Re: Routing filter problem  [SOLVED]

Tue May 03, 2022 5:25 pm

Your issue probably is that the default action for filter rules has been changed from accept to reject.
So when you have only this in your rules, it does not work. You need to add an extra rule with "accept".
Or better you change your rule to:

add chain=bgp-cliente disabled=no rule="if (dst == 0.0.0.0/0) { accept; }"
 
User avatar
Maggiore81
Trainer
Trainer
Topic Author
Posts: 477
Joined: Sun Apr 15, 2012 12:10 pm
Location: Italy
Contact:

Re: Routing filter problem

Wed May 04, 2022 8:55 am

thanks
it works!
 
pe1chl
Forum Guru
Forum Guru
Posts: 9000
Joined: Mon Jun 08, 2015 12:09 pm

Re: Routing filter problem

Wed May 04, 2022 11:30 am

Ok good to hear that!
In actuality, it is of course a bug in the v6->v7 upgrade conversion, which should have added an "accept" rule.
 
xparanoik
just joined
Posts: 3
Joined: Thu Jul 23, 2020 8:21 am

Re: Routing filter problem

Wed May 04, 2022 2:54 pm

I suppose the easiest way to translate ROS6 filter rules to ROS7 format is to upgrade in place? Is there any other way?
 
pe1chl
Forum Guru
Forum Guru
Posts: 9000
Joined: Mon Jun 08, 2015 12:09 pm

Re: Routing filter problem

Wed May 04, 2022 3:36 pm

No. I have suggested that MikroTik make some offline tool or website to convert filters (and maybe the entire config).
Sort of an offline version of crossfig.
But I don't think that was implemented already.

Who is online

Users browsing this forum: No registered users and 5 guests