OSPF - Null auth failure when setting non-default instance
Posted: Wed May 04, 2022 6:15 pm
I'm completely new to OSPF, so it's very likely I've misunderstood something here. But it does seem like RouterOS is messing up the OSPF authentication type, so I figured I'd try asking about it.
Using BIRD (https://bird.network.cz/) on a Linux host, I created the simplest OSPF configuration possible, with "authentication none".
On RouterOS 7.2.2, following the "Basic configuration example" from here: https://help.mikrotik.com/docs/display/ ... alculation, I execute the following commands:
This works. BIRD and RouterOS say hello, exchange routes, everyone is happy. When I run I see . Assuming the instance here is referring to the same type of instance from , then it should actually be = 1. So I run:
.
And now BIRD and RouterOS are not happy; they will only say "Hello." Looking at the Hello packets in Wireshark I see the difference between when things worked, and when the didn't: When things were working RouterOS's Hello packet has and . Changing the instance-id, RouterOS is now sending Hello packets with and .
I run, and BIRD and RouterOS are exchanging routes again.
Is this a bug, or have I misunderstood interface-template's "instance-id" so badly that OSPF Hellos now don't have the correct auth types?
Thank you!
Using BIRD (https://bird.network.cz/) on a Linux host, I created the simplest OSPF configuration possible, with "authentication none".
On RouterOS 7.2.2, following the "Basic configuration example" from here: https://help.mikrotik.com/docs/display/ ... alculation, I execute the following commands:
Code: Select all
/routing ospf instance
add name=comp123 version=2 router-id=172.18.0.1
/routing ospf area
add name=area0 area-id=0.0.0.0 instance=comp123
/routing ospf interface-template
add networks=172.18.0.0/24 area=area0
This works. BIRD and RouterOS say hello, exchange routes, everyone is happy. When I run
Code: Select all
/routing/ospf/interface-template/print
Code: Select all
instance-id=0
Code: Select all
/routing/ospf/instance
Code: Select all
/routing/ospf/interface-template/set instance-id=1 numbers=0
And now BIRD and RouterOS are not happy; they will only say "Hello." Looking at the Hello packets in Wireshark I see the difference between when things worked, and when the didn't: When things were working RouterOS's Hello packet has
Code: Select all
Auth Type: Null
Code: Select all
Auth Data (none)
Code: Select all
Auth Type: Unknown (256)
Code: Select all
Auth Unknown: 000....
I run
Code: Select all
/routing/ospf/interface-template/set instance-id=0 numbers=0
Is this a bug, or have I misunderstood interface-template's "instance-id" so badly that OSPF Hellos now don't have the correct auth types?
Thank you!