Community discussions

MikroTik App
 
User avatar
jprietove
Trainer
Trainer
Topic Author
Posts: 204
Joined: Fri Jun 03, 2016 3:00 pm
Location: Cádiz, Spain
Contact:

v.7.3beta40 OSPF possible BUG. Default route not created in STUB Intra-Area Router

Thu May 19, 2022 12:33 pm

I am testing OSPF with new RouterOS v7.3beta40 and I have found that in a STUB Intra-Area Router, the default route is not created.

I am not sure if I it is my mistake or it is a bug. I have create a very simple scenario to test it: one router as ASBR with default-originate in backbone area. One ABR that belongs to areas backbone and areaA. And finally one IR in areaA.
# ASBR
/routing ospf instance
add disabled=no name=ospf-instance-1 originate-default=always redistribute=\
    connected
/routing ospf area
add disabled=no instance=ospf-instance-1 name=backbone
/ip address
add address=10.0.0.1/24 interface=ether2 network=10.0.0.0
/routing ospf interface-template
add area=backbone disabled=no networks=10.0.0.0/8
/system identity
set name=ASBR
Export for ABR:
/routing ospf instance
add disabled=no name=ospf-instance-1
/routing ospf area
add area-id=0.0.0.1 disabled=no instance=ospf-instance-1 name=a type=stub
add disabled=no instance=ospf-instance-1 name=backbone
/ip address
add address=10.0.0.101/24 interface=ether1 network=10.0.0.0
add address=172.16.1.101/24 interface=ether2 network=172.16.1.0
/routing ospf interface-template
add area=a disabled=no interfaces=ether2 networks=172.16.1.0/24 type=ptp
add area=backbone disabled=no networks=10.0.0.0/8
/system identity
set name=ABR
Export for IR:
/routing ospf instance
add disabled=no name=ospf-instance-1
/routing ospf area
add area-id=0.0.0.1 disabled=no instance=ospf-instance-1 name=a type=stub
/ip address
add address=172.16.1.201/24 interface=ether2 network=172.16.1.0
/routing ospf interface-template
add area=a disabled=no interfaces=ether2 networks=172.16.1.0/24 type=ptp
/system identity
set name=IR
After adjacency is established, routing table in IR is:
[admin@IR] > ip/route/print 
Flags: D - DYNAMIC; A - ACTIVE; c, o, y - COPY
Columns: DST-ADDRESS, GATEWAY, DISTANCE
    DST-ADDRESS    GATEWAY              DISTANCE
DAo 10.0.0.0/24    172.16.1.101%ether2       110
DAc 172.16.1.0/24  ether2                      0

As it can be seen, default route is not installed, but it should be.
 
aleksis
newbie
Posts: 25
Joined: Wed Apr 30, 2014 12:13 pm

Re: v.7.3beta40 OSPF possible BUG. Default route not created in STUB Intra-Area Router  [SOLVED]

Thu May 19, 2022 2:41 pm

In v7 "default-cost" must be configured for the stub area to get the default route originated.
 
User avatar
jprietove
Trainer
Trainer
Topic Author
Posts: 204
Joined: Fri Jun 03, 2016 3:00 pm
Location: Cádiz, Spain
Contact:

Re: v.7.3beta40 OSPF possible BUG. Default route not created in STUB Intra-Area Router

Thu May 19, 2022 3:25 pm

In v7 "default-cost" must be configured for the stub area to get the default route originated.
Thank you very much! That was! I wan't aware of this change.
 
User avatar
jprietove
Trainer
Trainer
Topic Author
Posts: 204
Joined: Fri Jun 03, 2016 3:00 pm
Location: Cádiz, Spain
Contact:

Re: v.7.3beta40 OSPF possible BUG. Default route not created in STUB Intra-Area Router

Thu May 19, 2022 4:10 pm

I've been testing more and I've found a detail... that shocks me.

If in IR a new Area is created, the default route doesn't appear!. It doesn't matter if there is no network in the new area.
So maybe in this case this is a Bug. I think IR role should be determined by only having networks in one area, and ABR role if several areas are active.

Any opinion?
[admin@IR] > routing/ospf/area/print 
Flags: X - disabled, I - inactive, D - dynamic; T - transit-capable 
 0    name="a" instance=ospf-instance-1 area-id=0.0.0.1 type=stub 
[admin@IR] > ip/route/print 
Flags: D - DYNAMIC; A - ACTIVE; c, o, y - COPY
Columns: DST-ADDRESS, GATEWAY, DISTANCE
    DST-ADDRESS    GATEWAY              DISTANCE
DAo 0.0.0.0/0      172.16.1.101%ether2       110
DAo 10.0.0.0/24    172.16.1.101%ether2       110
DAo 10.1.0.0/16    172.16.1.101%ether2       110
DAc 172.16.1.0/24  ether2                      0
[admin@IR] > routing/ospf/area/add name=backbone instance=ospf-instance-1 
[admin@IR] > routing/ospf/area/print 
Flags: X - disabled, I - inactive, D - dynamic; T - transit-capable 
 0    name="a" instance=ospf-instance-1 area-id=0.0.0.1 type=stub 

 1    name="backbone" instance=ospf-instance-1 area-id=0.0.0.0 type=default 
[admin@IR] > ip/route/print 
Flags: D - DYNAMIC; A - ACTIVE; c, y - COPY
Columns: DST-ADDRESS, GATEWAY, DISTANCE
    DST-ADDRESS    GATEWAY  DISTANCE
DAc 172.16.1.0/24  ether2          0
[admin@IR] > routing/ospf/interface/print 
Flags: D - dynamic 
 0 D address=172.16.1.201%ether2 area=a state=ptp network-type=ptp cost=1 
     retransmit-interval=5s transmit-delay=1s hello-interval=10s 
     dead-interval=40s 
[admin@IR] > 

Who is online

Users browsing this forum: No registered users and 2 guests