Community discussions

MikroTik App
 
Dude2048
Member Candidate
Member Candidate
Topic Author
Posts: 207
Joined: Thu Sep 01, 2016 4:04 pm

Re: DUDE v7 server "needed packages are not available"

Tue Jun 07, 2022 8:56 pm

Hello, in MikroTik v7 DUDE still can't upgrade Devices - Dude server still shows "needed packages are not available", though packages are uploaded on DUDE server in dude path.
Somebody any solution please?
 
marianob85
just joined
Posts: 18
Joined: Wed Feb 08, 2017 9:47 pm

Re: DUDE v7 server "needed packages are not available"

Tue Jun 07, 2022 9:24 pm

Still the same in 7.3!!
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 9532
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: DUDE v7 server "needed packages are not available"

Wed Jun 08, 2022 12:27 am

No one has described on what exactly path have put the files, and what files...
 
Dude2048
Member Candidate
Member Candidate
Topic Author
Posts: 207
Joined: Thu Sep 01, 2016 4:04 pm

Re: DUDE v7 server "needed packages are not available"

Wed Jun 08, 2022 9:17 am

When the files are in the old location with V6 it works fine. With V7 you will get the option to upgrade but it triggers "needed packages are not available" and doesn't do anything.

To be a bit more precise; For me it is the CHR package which triggers this.
 
sulicz
just joined
Posts: 2
Joined: Wed Apr 13, 2022 8:21 pm

Re: DUDE v7 server "needed packages are not available"

Thu Jun 09, 2022 12:56 pm

I have the same problem.
I uploaded to dude server file routeros-7.3-arm.npk but in packages is visible as system. All connected routers in v7 have in packages routeros not system. So that is impossible to make upgrade. (in version 7.2.3 and 7.3 for me now)
 
andacb
just joined
Posts: 2
Joined: Thu Apr 15, 2021 1:03 pm

Re: DUDE v7 server "needed packages are not available"

Fri Jun 10, 2022 7:57 pm

Let me join you all. I have the very same problem since upgrade to v7. :)

Andaç
 
Dude2048
Member Candidate
Member Candidate
Topic Author
Posts: 207
Joined: Thu Sep 01, 2016 4:04 pm

Re: DUDE v7 server "needed packages are not available"

Fri Jun 10, 2022 9:43 pm

Created sup-84404
 
AUsquirrel
newbie
Posts: 28
Joined: Fri Feb 21, 2014 10:28 pm

Re: DUDE v7 server "needed packages are not available"

Sat Jun 11, 2022 6:22 am

Same here.

I have placed the packages on my dude server in the /dude/files directory on my router that is the dude server.
They are visible in the dude via the client in the Content - Files under files All and in the packages tab.
Still get the error "needed packages are not available
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 9532
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: DUDE v7 server "needed packages are not available"

Sat Jun 11, 2022 11:30 am

The problem is now known (and known why it does so) and reported.
Hope MikroTik does something about it.
viewtopic.php?t=186567#p938935
 
Dude2048
Member Candidate
Member Candidate
Topic Author
Posts: 207
Joined: Thu Sep 01, 2016 4:04 pm

Re: DUDE v7 server "needed packages are not available"

Mon Jun 13, 2022 11:01 am

Answer from MT:

Hello

Yes, unfortunately, currently in the Dude it is not possible to upgrade devices by using v7 packages.

Best regards

——
I asked them if it will be fixed in future releases.
 
Dude2048
Member Candidate
Member Candidate
Topic Author
Posts: 207
Joined: Thu Sep 01, 2016 4:04 pm

Re: DUDE v7 server "needed packages are not available"

Mon Jun 13, 2022 11:02 am

And another answer:

Hello

We will try to resolve this problem as soon as possible in the future Dude releases when we will be working on fixes and improvements regarding this service.

Best regards
 
pe1chl
Forum Guru
Forum Guru
Posts: 9010
Joined: Mon Jun 08, 2015 12:09 pm

Re: DUDE v7 server "needed packages are not available"

Mon Jun 13, 2022 11:25 am

I thought there was no more Dude development and thus no future Dude releases?
Well, of course the answer is still correct then...
 
Dude2048
Member Candidate
Member Candidate
Topic Author
Posts: 207
Joined: Thu Sep 01, 2016 4:04 pm

Re: DUDE v7 server "needed packages are not available"

Mon Jun 13, 2022 11:27 am

I know. I have seen the statement from Normis, but it never hurts to try.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 9532
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: DUDE v7 server "needed packages are not available"

Mon Jun 13, 2022 12:14 pm

The problem IS NOT DUDE:
viewtopic.php?t=186567#p938935
 
AUsquirrel
newbie
Posts: 28
Joined: Fri Feb 21, 2014 10:28 pm

Re: DUDE v7 server "needed packages are not available"

Mon Jun 13, 2022 12:55 pm

The problem IS NOT DUDE:
viewtopic.php?t=186567#p938935
Hi rexended,
I had a browse through the .npk package to locate the file you mentioned, where in the package should it exist? I didn't find an internal system description file.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 9532
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: DUDE v7 server "needed packages are not available"

Mon Jun 13, 2022 2:54 pm

read twice the post: if "internal description of .npk file"
Starting offset 0x20 (114)
for example on v6 mibsbe is
>routeros-mipsbe<
and each platform have it's own string


instead on v7 REGARDLESS THE PLATFORM
>system·········<
· is padding 0x00

you can not do any, the .npk files are digitally signed, and if you alter something, routeros do not install it (if the dude recognize it or not, not mind)
 
pe1chl
Forum Guru
Forum Guru
Posts: 9010
Joined: Mon Jun 08, 2015 12:09 pm

Re: DUDE v7 server "needed packages are not available"

Mon Jun 13, 2022 5:41 pm

I don't know if they now properly sign the entire file instead of just the content. In the past it was possible to hack .npk files by changing header fields and RouterOS would not notice it.
 
sulicz
just joined
Posts: 2
Joined: Wed Apr 13, 2022 8:21 pm

Re: DUDE v7 server "needed packages are not available"

Wed Jul 20, 2022 2:17 pm

It comes version 7.4 ... problem remains.. :(
 
User avatar
inteq
Member
Member
Posts: 359
Joined: Wed Feb 25, 2015 8:15 pm
Location: Romania

Re: DUDE v7 server "needed packages are not available"

Fri Aug 26, 2022 12:49 am

7.4.1 same story
And I have a lot of devices to update...
 
nkm
just joined
Posts: 4
Joined: Sun Dec 25, 2011 9:57 am

Re: DUDE v7 server "needed packages are not available"

Fri Sep 02, 2022 4:43 pm

7.5 same bug
 
golimh
just joined
Posts: 3
Joined: Mon Jan 02, 2017 5:10 pm
Location: Iran
Contact:

Re: DUDE v7 server "needed packages are not available"

Tue Sep 06, 2022 6:26 am

I have same bug in ROS 7.5 with several devices.
 
Rohan1997
just joined
Posts: 2
Joined: Sun Nov 21, 2021 6:54 am

Re: DUDE v7 server "needed packages are not available"

Sun Oct 30, 2022 6:45 am

7.6 same bug
What's other way to upgrade ROS in group?
 
User avatar
bloon
just joined
Posts: 5
Joined: Mon Apr 21, 2014 10:40 am

Re: DUDE v7 server "needed packages are not available"

Wed Dec 21, 2022 2:54 pm

I have some bash script that can be used for mass upgrade.
It still need to input credential and hostname by hand, but at least it make more fast than manual upgrade.

https://github.com/vodafschuler/ros-upgrade

hope it help.
 
skullzaflare
newbie
Posts: 40
Joined: Tue Apr 12, 2016 12:01 am

Re: DUDE v7 server "needed packages are not available"

Wed Jan 04, 2023 4:32 pm

I noticed as of v7 the DNS override self hosting "check for updates" server breaks too. They just hang at "calculating download size..." and never continue
If i change it back to v6 it still works fine

Really wish the DUDE was fixed for this, the DNS override was just a backup for missed routers


(reference to what I am talking about https://jms1.net/mikrotik/Mikrotik%20Update%20Server.md)
 
kramegroeg2021
just joined
Posts: 2
Joined: Fri Jun 25, 2021 9:48 pm

Re: DUDE v7 server "needed packages are not available"

Mon Jan 30, 2023 7:40 pm

Is there any update on this? Can I install the Dude server on a Linux server and then point it to the Mikrotik router interfaces?

Who is online

Users browsing this forum: No registered users and 48 guests