Community discussions

MikroTik App
 
captainhachiman
just joined
Topic Author
Posts: 7
Joined: Thu Jun 16, 2022 7:09 am

CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Thu Jun 16, 2022 7:28 am

Hi, I just got my card after waiting 2 months. However after plugging it into my motherboard I find that it is not detected by the OS. Nothing at all about it shows up in lspci (not even an unknown device). I've upgraded the kernel to 5.18.4 and the motherboard is A88XM-PLUS with the latest BIOS firmware. Would be grateful if anyone can help me :)
 
antonsb
MikroTik Support
MikroTik Support
Posts: 323
Joined: Sun Jul 24, 2016 3:12 pm
Location: Riga, Latvia

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Thu Jun 16, 2022 11:13 am

CCR2004-1G-2XS-PCIe is istalled in first PCIe3.0 slot?
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 9595
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Thu Jun 16, 2022 11:29 am

Not only must be on the 1st PCIe slot (PCIEX16_1), that is it the unique slot that support the PCIe 3.0, if is supported from the processor,
but also the processor must be a FM2+ that support the PCIe 3.0,
or the motherboard do not support at all the PICe 3.0....
 
psannz
Member Candidate
Member Candidate
Posts: 111
Joined: Mon Nov 09, 2015 3:52 pm
Location: Renningen, Germany

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Thu Jun 16, 2022 12:33 pm

What CPU are you using?

Did you try to rescan the PCIe devices after Linux booted? The card needs some time to boot ROS on itself.

Regarding BIOS settings:
  • is Fastboot disabled?
  • Is Option ROM Messages set to "Force BIOS"?
  • You may alse have better success by setting the POST Delay Time to 30s just to give the card enough time to boot up itself, so that Linux will actually be able to see and interact with it.
 
captainhachiman
just joined
Topic Author
Posts: 7
Joined: Thu Jun 16, 2022 7:09 am

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Thu Jun 16, 2022 2:18 pm

The CPU is A10-7850K (FM2+, said to support PCI-e 3.0). I've made sure that:
- fastboot is disabled
- all other PCI-e cards are removed and CCR2004 is installed on the slot that is nearest to the CPU (There's a large "PCI-e 3.0" printed there on the motherboard)
- Option ROM Messages is set to "Force BIOS"
- set the POST Delay to 10s (the largest I can set on this motherboard)
- "echo "1" > /sys/bus/pci/rescan" is tried

However when running lspci I still get nothing about my Mikrotik card. Any ideas?
Last edited by captainhachiman on Fri Jun 17, 2022 11:57 am, edited 1 time in total.
 
psannz
Member Candidate
Member Candidate
Posts: 111
Joined: Mon Nov 09, 2015 3:52 pm
Location: Renningen, Germany

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Thu Jun 16, 2022 7:20 pm

- "echo "1" > /sys/bus/pci/rescan" is tried
but did you run it with root rights? Try again, with a "sudo" in front of it ;)
 
captainhachiman
just joined
Topic Author
Posts: 7
Joined: Thu Jun 16, 2022 7:09 am

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Thu Jun 16, 2022 7:25 pm

- "echo "1" > /sys/bus/pci/rescan" is tried
but did you run it with root rights? Try again, with a "sudo" in front of it ;)
Yes I did try that, and I also tried running that after sudo su, but it is still not detected.
 
User avatar
herger
newbie
Posts: 41
Joined: Tue Aug 18, 2020 2:48 pm

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Thu Jun 16, 2022 8:07 pm

Did you try connecting to the CCR (via ethernet)? What does ROS say about the state of the pcie interfaces? had some bad luck with recent ROSv7 on mine, try latest 7.3.1.
 
captainhachiman
just joined
Topic Author
Posts: 7
Joined: Thu Jun 16, 2022 7:09 am

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Thu Jun 16, 2022 8:24 pm

Did you try connecting to the CCR (via ethernet)? What does ROS say about the state of the pcie interfaces? had some bad luck with recent ROSv7 on mine, try latest 7.3.1.
Image
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 9595
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Fri Jun 17, 2022 10:49 am

please paste this on terminal and post the results:
/sys routerboard print
/sys routerboard settings print
/sys resource print
/sys package print
/export show-sensitive
(remember to remove serial number and private info, CENSORING that, and not removing that line/settings from export)
 
captainhachiman
just joined
Topic Author
Posts: 7
Joined: Thu Jun 16, 2022 7:09 am

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Fri Jun 17, 2022 12:10 pm

terminal code

[admin@MikroTik] > /sys routerboard print 
       routerboard: yes
             model: CCR2004-1G-2XS-PCIe
     serial-number: [CENSORED]
     firmware-type: al64
  factory-firmware: 7.1.4
  current-firmware: 7.1.4
  upgrade-firmware: 7.3.1
[admin@MikroTik] > /sys routerboard settings print 
              auto-upgrade: no
               boot-device: nand-if-fail-then-ethernet
             boot-protocol: bootp
       force-backup-booter: no
               silent-boot: no
      protected-routerboot: disabled
      reformat-hold-button: 20s
  reformat-hold-button-max: 10m
[admin@MikroTik] > /sys resource/ print 
                   uptime: 6h2m49s
                  version: 7.3.1 (stable)
               build-time: Jun/09/2022 08:58:15
         factory-software: 7.1.4
              free-memory: 3847.1MiB
             total-memory: 4032.0MiB
                      cpu: ARM64
                cpu-count: 4
                 cpu-load: 0%
           free-hdd-space: 105.8MiB
          total-hdd-space: 129.0MiB
  write-sect-since-reboot: 88
         write-sect-total: 262
               bad-blocks: 0.2%
        architecture-name: arm64
               board-name: CCR2004-1G-2XS-PCIe
                 platform: MikroTik
[admin@MikroTik] > /sys package print
Columns: NAME, VERSION
# NAME      VERSION
0 routeros  7.3.1  

# jan/02/1970 06:03:19 by RouterOS 7.3.1
# software id = [CENSORED]
#
# model = CCR2004-1G-2XS-PCIe
# serial number = [CENSORED]
/interface bridge
add name=bridge1
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.1.3-192.168.1.254
add name=dhcp_pool1 ranges=192.168.1.100-192.168.1.254
/ip dhcp-server
add address-pool=dhcp_pool1 interface=bridge1 name=dhcp1
/port
set 0 name=serial0
set 1 name=serial1
/interface bridge port
add bridge=bridge1 interface=ether-pcie2
add bridge=bridge1 interface=ether-pcie3
add bridge=bridge1 interface=ether-pcie4
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=sfp28-2
add bridge=bridge1 interface=sfp28-1
/interface detect-internet
set detect-interface-list=all
/interface list member
add interface=ether-pcie1 list=WAN
add interface=bridge1 list=LAN
/ip address
add address=192.168.1.1/24 interface=bridge1 network=192.168.1.0
add address=192.168.0.99/24 interface=ether1 network=192.168.0.0
/ip arp
add address=192.168.0.99 interface=ether1
/ip dhcp-client
add interface=ether-pcie1
/ip dhcp-server network
add address=0.0.0.0/24 gateway=0.0.0.0 netmask=24
add address=192.168.1.0/24 dns-server=9.9.9.9 gateway=192.168.1.1 netmask=24
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=WAN
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 9595
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Fri Jun 17, 2022 1:15 pm

Ok, first try to update RouteBOARD "BIOS" (RouterBOOT) on System / Routerboard...
After update, completely power off the mainboard, wait 10/20 sec and power it up again...

On the remaining parts, I do not see anything strange...
 
captainhachiman
just joined
Topic Author
Posts: 7
Joined: Thu Jun 16, 2022 7:09 am

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Fri Jun 17, 2022 2:14 pm

Upgraded but it's still not showing up in lspci after rescanning. It's really strange.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 9595
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Fri Jun 17, 2022 3:59 pm

You can try on another PCIe 3.0 motherboard?
 
captainhachiman
just joined
Topic Author
Posts: 7
Joined: Thu Jun 16, 2022 7:09 am

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Fri Jun 17, 2022 4:41 pm

You can try on another PCIe 3.0 motherboard?
Seems to be the time for me to upgrade my machine lol :lol:
Thanks for your help, I'll do that but probably after some time.
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 2552
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Fri Jun 17, 2022 5:51 pm

is nice to see that ccr2004-pcie works well independently from PC recognize it or not

i think even in that condition it can be useful in some scenarios
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 9595
Joined: Tue Feb 25, 2014 12:49 pm
Location: 🇮🇹, my 💔 is in 🇺🇦

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Fri Jun 17, 2022 7:11 pm

Yes, you can just power it the board with some PCIe bus adapter already used for data mining on GPU cards, and, regardless if connected or not to one motherboard, works.
 
technick
newbie
Posts: 29
Joined: Fri Jun 10, 2022 5:03 am
Location: Canada
Contact:

Re: CCR2004-1G-2XS-PCIe Not Showing Up in lspci

Mon Jun 27, 2022 1:35 am

OP, if it makes you feel better, I have a nearly full server rack with no servers supporting POST delay, or seeing the passthrough devices of the CCR PCIe device!

Linux, BSD, Windows, they all show non-configurable errored devices. Even 3 last gen (DDR4/i7/AM3) desktop/workstation systems that have no support for the PCIe passthrough.

In my experience so far, the ports also need a physical+configured+enabled connection before they appear in winbox (or on the web config) as enabled for passthrough.

Who is online

Users browsing this forum: No registered users and 2 guests