Community discussions

MikroTik App
 
dylan
just joined
Topic Author
Posts: 1
Joined: Wed Aug 10, 2022 9:50 am

BGP Basics for v7.4

Wed Aug 10, 2022 9:59 am

Hi All,

Have been blindsided by a client deploying newer MikroTIks running v7 software that I'm not familiar with & under some time pressure to bring on a peering.

After some help with a very basic BGP peering config:

The issue is that I am receiving a full table and not advertising our network.

Full table is expected but it would be ideal to see in action being able to filter down to default only if needed
# aug/10/2022 16:49:27 by RouterOS 7.4.1
# software id = L3M5-E3ZZ
#
# model = CCR2004-16G-2S+
# serial number = <CENSORED>
/routing bgp template
set default as=xxx27 input.filter=BGP_IN output.filter-chain=BGP_OUT .keep-sent-attributes=yes .network=x.x.x.0/23 .redistribute=connected \
    router-id=x.x.x.0
/routing bgp connection
add as=zzz27 disabled=no input.filter=BGP_IN local.address=a.a.a.82 .role=ebgp name=Peer1 output.keep-sent-attributes=yes .network=\
    bgp-networks remote.address=a.a.a.81 .as=zzz11
routing/filter/export 
/routing filter rule
add chain=BGP_IN rule="if (dst==0.0.0.0/0 && protocol bgp) {accept}"
add chain=BGP_OUT rule="if (dst-len==23 && dst in x.x.x.0/23) {set bgp-med 20; set bgp-path-prepend 1; accept }"
/ip firewall address-list
add address=x.x.x.0/23 list=bgp-networks
/ip route
add disabled=no dst-address=0.0.0.0/0 gateway=45.113.198.81
add blackhole dst-address=x.x.x.0/23
Last edited by rextended on Wed Aug 10, 2022 1:06 pm, edited 1 time in total.
Reason: <CENSORED>
 
metrotyranno
just joined
Posts: 12
Joined: Fri Mar 24, 2017 12:21 pm

Re: BGP Basics for v7.4

Fri Aug 12, 2022 10:38 am

As far as I can tell comparing your setup to our testing setup, the network attribute on the BGP template should be your firewall list name.
set default as=xxx27 input.filter=BGP_IN output.filter-chain=BGP_OUT .keep-sent-attributes=yes .network=bgp-networks .redistribute=connected router-id=x.x.x.0

Who is online

Users browsing this forum: No registered users and 2 guests