Community discussions

MikroTik App
 
OlofL
Member Candidate
Member Candidate
Topic Author
Posts: 113
Joined: Mon Oct 12, 2015 2:37 pm

Trying to learn ospf-mpls-bgp ipvpn - what am I missing? (no vpnv4 routes in mpls forwarding-table)

Thu Aug 11, 2022 5:19 pm

Im trying to learn mpls/ospf/bgp "ipvpn" setup.
traffic between PE1 loopback and PE2 loopback is switched through mpls.
traffic between ce1 and ce2 doesn't get switched by mpls, so an ip packet reaches P1 and its dropped because it doesnt have route to CE2.

What am I missing here?
Config:
/interface bridge
add name=loopback protocol-mode=none

/ip vrf
add interfaces=ether6 name=cust123

/routing ospf instance
add disabled=no name=bb router-id=10.10.10.5
/routing ospf area
add disabled=no instance=bb name=bb-area

/ip address
add address=192.168.4.2/24 interface=ether1 network=192.168.4.0
add address=10.10.10.5 interface=loopback network=10.10.10.5
add address=172.16.2.1/24 interface=ether6 network=172.16.2.0

/mpls ldp
add afi=ip lsr-id=10.10.10.5 transport-addresses=10.10.10.5
/mpls ldp interface
add interface=ether1

/routing bgp connection
add address-families=vpnv4 as=65000 disabled=no local.address=10.10.10.5 \
    .role=ibgp name=pe1 remote.address=10.10.10.1 .as=65000 router-id=\
    10.10.10.5
/routing bgp vpn
add disabled=no export-route-targets=65000:123 import-route-targets=65000:123 \
    label-allocation-policy=per-vrf redistribute=connected \
    route-distinguisher=10.10.10.5:123 vrf=cust123

/routing ospf interface-template
add area=bb-area disabled=no interfaces=ether1
add area=bb-area disabled=no interfaces=loopback passive

/system identity
set name=PE2


Both local and remote prefix has been installed in the correct routing table.
[admin@PE2] /ip/route> print detail where routing-table=cust123 
Flags: D - dynamic; X - disabled, I - inactive, A - active; 
c - connect, s - static, r - rip, b - bgp, o - ospf, d - dhcp, v - vpn, m - modem, y - copy; 
H - hw-offloaded; + - ecmp 
   DAy   dst-address=172.16.1.0/24 routing-table=cust123 gateway=10.10.10.1 
         immediate-gw=192.168.4.1%ether1 distance=0 scope=40 target-scope=30 
         suppress-hw-offload=no 

   DAc   dst-address=172.16.2.0/24 routing-table=cust123 gateway=ether6@cust123 
         immediate-gw=ether6 distance=0 scope=10 suppress-hw-offload=no 
         local-address=172.16.2.1%ether6@cust123 


However, there is no mpls label to the remote vrf-cust123 prefix (172.16.1.0/24)
Only the local 172.16.2.0/24 is in the mpls forwarding table.
[admin@PE2] /mpls> forwarding-table/print detail 
Flags: L - ldp, P - vpn, T - traffic-eng, V - vpls 
 0 L label=16 type=ldp vrf=main prefix=10.10.10.2 
     nexthops={ label=17; nh=192.168.4.1; interface=ether1 } 
...
 7 P label=23 type=vpn vrf=cust123 prefix=172.16.2.0/24 

Image

Who is online

Users browsing this forum: alidamji, IPANetEngineer and 9 guests