Community discussions

MikroTik App
 
szwajkiewicz
just joined
Topic Author
Posts: 2
Joined: Tue Aug 23, 2022 11:18 am

1000M autonegotiation fails between Mikrotik router and Cicso switch

Tue Aug 23, 2022 11:22 am

Hi everyone, that is my first post here.

There seems to be an issue with autonegotiation between Cisco 220 Series Switch and Mikrotik router with RouterOS 6.48. Current configuration is as follows:

MIkrotik port setup:

https://drive.google.com/file/d/1gy1SZQ ... sp=sharing

Difference between setup and status seems to be in Advertising. It is set up to advertise 100M and 1000M
but when you look at Status only 100M is ticked, 1000M boxes are not ticked.

MIkrotik port status:

https://drive.google.com/file/d/1h8S6Nu ... sp=sharing

When you look at Link Partner Advertising there is a similar problem: although Cisco 220 series switch is set
up to advertise all 10M, 100M and 1000M, only 10M and 100M are ticked, 1000M boxes are not ticked.

Cisco port status and setup:

https://drive.google.com/file/d/18slyED ... sp=sharing

https://drive.google.com/file/d/1vWmk12 ... sp=sharing

Both devices work absolutely fine at 1000M full duplex when connected to other routers, switches or computers. Cat 5E patchcords are 1 meter long and they are brand new.

How to set up autonegotiation parameters so as to link Cisco Switch and Mikrotik router at 1000M full duplex speed?

I am not able to find the mismatch in both devices configuration that prevents autonegotiating the link at 1000Mbps.
 
mkx
Forum Guru
Forum Guru
Posts: 8953
Joined: Thu Mar 03, 2016 10:23 pm

Re: 1000M autonegotiation fails between Mikrotik router and Cicso switch

Tue Aug 23, 2022 7:33 pm

Which MT device are you using?

Are cables 1000% OK? Port status not showing 1000Tx being advertised might mean that one of "optional" pairs (4-5 and 7-8 are only used for Gbps and higher speeds) on cable might be faulty and if switch detects fault on any of these pairs, auto-negotiation process omits rates that need those pairs from being advertised.

Also check if contacts in ports you want to use are all physically fine (i.e. not bent or damaged in any otehr way).
 
szwajkiewicz
just joined
Topic Author
Posts: 2
Joined: Tue Aug 23, 2022 11:18 am

Re: 1000M autonegotiation fails between Mikrotik router and Cicso switch

Sat Nov 19, 2022 11:26 am

Thank you for the reply.

The issue was with patchcords. Cat.6 patchcords fixed the problem.

Who is online

Users browsing this forum: Amazon [Bot], Bing [Bot] and 21 guests