Community discussions

MikroTik App
 
mfedotov
just joined
Topic Author
Posts: 14
Joined: Mon Oct 25, 2021 3:32 am

OSPF with unnumbered IPs results in inactive routes on Mikrotik side

Tue Sep 06, 2022 7:30 pm

Hello

I am playing in a lab creating an OSPF adjacency between a Miktrotik router and a Cisco 9000v router using unnumbered IP interfaces. The adjacency establishes OK, LSAs sent and received, routing tables looks good on Cisco side, but on Mikrotik side all the routes are marked as inactive and the route to the Cisco neighbor is missing. I even tried to add a manual route to the Cisco neighbor, and I can ping that neighbor after that, but none of the other routers on the Cisco side.

In the output below I established adjacency with Cisco neighbor 10.0.1.1. The addresses 10.0.0.1, 10.0.0.254 and 10.0.1.2 are the other 9000v routers on the Cisco side of the network. The route to 10.0.1.1/32 I added manually, but it did not help, the nexthop 10.0.1.1%ether2 is shown as unreachable...
[admin@MikroTik] > /routing/ospf/neighbor/print
Flags: V - virtual; D - dynamic
 0  D instance=ospf-main area=ospf-area-0 address=10.0.1.1 router-id=10.0.1.1
      state="Full" state-changes=4 adjacency=3d18h8m11s timeout=39s
[admin@MikroTik] > /ip/route/print
Flags: D - DYNAMIC; I, A - ACTIVE; c, s, o, d, y - COPY; H - HW-OFFLOADED
Columns: DST-ADDRESS, GATEWAY, DISTANCE
#      DST-ADDRESS    GATEWAY          DISTANCE
  DIoH 10.0.0.1/32    10.0.1.1%ether2       110
  DIoH 10.0.0.254/32  10.0.1.1%ether2       110
0  As  10.0.1.1/32    ether2                  1
  DIoH 10.0.1.2/32    10.0.1.1%ether2       110
  DAc  10.0.2.1/32    ether2                  0
  DAc  10.0.2.2/32    lo0                     0
  DAd  0.0.0.0/0      10.255.2.1@mgmt         1
  DAc  10.255.2.0/24  ether1@mgmt             0

This is using routerOS 7.5, but on the other version (I believe I tried 7.3.1) it was the same.
Any ideas/suggestions?

Regards
Mike

Who is online

Users browsing this forum: No registered users and 8 guests