Community discussions

MikroTik App
 
connectthedots
just joined
Topic Author
Posts: 2
Joined: Wed Sep 14, 2022 5:53 pm

RB5009UPr+S+ - Hang on reboot when connected via SSH and Winbox

Wed Sep 14, 2022 6:08 pm

board-name: RB5009UPr+S+
version: 7.5 (stable)
ether1 connected to ISP modem (XB6) advertising 10/100/1000M (not advertising 2.5G)
sfp-sfpplus1 connected to CRS326 sfp-sfpplus2 via XS+DA0001
USB connected to APC UPS (UPS package installed)

I am able to get my RB5009 to hang on reboot when connected both via SSH and Winbox.
If I issue a /system/reboot command from the CLI via SSH while also connected via Winbox, the router does not reboot and hangs with ether 2 dimly lit.
I have to pull the power plug and reconnect power in order for the device to boot.
When I reboot via CLI while not also connected via winbox, the router reboots without issue.
When I reboot via Winbox without being connected via SSH, the router reboots without issue.
I have experienced no other problems with this device.

I am wondering if anyone else is able to replicate my findings.
 
holvoetn
Forum Guru
Forum Guru
Posts: 1824
Joined: Tue Apr 13, 2021 2:14 am
Location: Belgium

Re: RB5009UPr+S+ - Hang on reboot when connected via SSH and Winbox

Wed Sep 14, 2022 10:10 pm

I don't have an rb5009 (yet) but how clean is this device ?
Since upgrading to 7 (or did it come with 7 ?), how often did it get a clean netinstall ?

Can you do a netinstall (after making sure your config has been properly backed up) and then reproduce the steps to see if it still behaves the same ?
 
connectthedots
just joined
Topic Author
Posts: 2
Joined: Wed Sep 14, 2022 5:53 pm

Re: RB5009UPr+S+ - Hang on reboot when connected via SSH and Winbox

Wed Sep 14, 2022 11:57 pm

Device was pulled out of the box and upgraded from 7.2 to 7.5 before being manually configured to what it is now.
It is currently "in production" and I'd like to keep my family from screaming at me so I would prefer to get feedback from other RB5009 owners before I take that step.
Thanks for replying!

EDIT: Just to be clear this isn't impacting daily use and is mitigated by not being connected via winbox and ssh simultaneously while rebooting the device. I'm interested in knowing if this is common across all RB5009 devices on 7.5. Thanks!
 
jpd
just joined
Posts: 3
Joined: Fri Oct 22, 2021 3:19 pm

Re: RB5009UPr+S+ - Hang on reboot when connected via SSH and Winbox

Sun Sep 18, 2022 6:20 pm

I am no longer able to replicate the hang. It appears this was a red herring.
After a lot of reboots during testing it now reboots reliably although I am still at a loss to explain why it was intermittently hanging with a dim ether2 in the first place.
 
Troy137
just joined
Posts: 1
Joined: Sun Oct 23, 2022 7:04 pm

Re: RB5009UPr+S+ - Hang on reboot when connected via SSH and Winbox

Sun Oct 23, 2022 7:13 pm

I have the same problem. RB5009UG+S+ with firmware 7.6 (Stable). Reboots have always seemed to be hit or miss through Winbox. I have never tried with SSH. I know it will hang when the second LED for ETHER2 remains dimly lit for more than about 45 seconds. Then the only solution is to remove the power cord and plug it back in. I have ETHER2 set up with a static route to an Edgeswitch ER-4 Router and my networks are working and stable otherwise.
Last edited by Troy137 on Sun Oct 23, 2022 7:32 pm, edited 1 time in total.

Who is online

Users browsing this forum: tomklu76 and 7 guests