Community discussions

MikroTik App
 
troy
Member
Member
Topic Author
Posts: 314
Joined: Thu Jun 30, 2005 6:47 pm

ROS7 - Set BGP Communities in /ip/route ?

Tue Sep 20, 2022 5:20 pm

In ROS6, one could set bgp-communities in /ip route. How does one do this in ROS7? My config gets clobbered when upgrading in the lab and makes me quite fearful to do it in production.

ROS6:
/ip route
add bgp-communities=555:400 distance=250 dst-address=10.20.30.0/24 type=blackhole

After upgrade to ROS7, no more communities and not finding anything else in the new config that replaces it.

/ip route
add blackhole disabled=no distance=250 dst-address=10.20.30.0/24
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6815
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: ROS7 - Set BGP Communities in /ip/route ?

Tue Sep 20, 2022 5:29 pm

BGP attributes must be set in the routing filters. Setting BGP attributes for non-BGP routes did not make much sense. It was only good for testing, aka an easy and fast method to generate fake BGP routes.
 
troy
Member
Member
Topic Author
Posts: 314
Joined: Thu Jun 30, 2005 6:47 pm

Re: ROS7 - Set BGP Communities in /ip/route ?

Tue Sep 20, 2022 6:28 pm

MRZ,

I would agree that setting bgp attributes for non-bgp route doesn't make sense, but if a filter is using the community to decide whether or not to advertise a route, then being able to set the community in the local routing table makes perfect sense.

In ROS6, if I want to create a local route and have it advertised to the rest of my network, peers, or transit providers, all we need to do is create the blackhole route for the prefix and set the community.

In ROS7, we not only have to create the blackhole route, but now we also have to create a filter to assign a community to it, effectively doubling the work (and chances to make a mistake).

IMO, MT should bring back the ability to set some BGP attributes while creating anchor routes.
 
NeuST
just joined
Posts: 2
Joined: Mon Nov 19, 2012 2:01 am

Re: ROS7 - Set BGP Communities in /ip/route ?

Wed Nov 02, 2022 10:47 pm

BGP attributes must be set in the routing filters. Setting BGP attributes for non-BGP routes did not make much sense. It was only good for testing, aka an easy and fast method to generate fake BGP routes.
Please, could you give us an example of how the output filter would be configured to send a community?

Thanks
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6815
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: ROS7 - Set BGP Communities in /ip/route ?

Thu Nov 03, 2022 8:59 am

Who is online

Users browsing this forum: No registered users and 6 guests