Community discussions

MikroTik App
 
Darkside
just joined
Topic Author
Posts: 3
Joined: Mon Oct 24, 2022 4:05 am

hEX on ROS 7.6

Mon Oct 24, 2022 4:16 am

Hi,

I am by no means an expert here but have configured and have running a number of Mikrotik routers, including 2 x hEX units.

However; I have a hEX unit running 7.5 that will not route to the internet, even on a very basic config. My last test was a pure default setup, even with that setup I cannot ping or route to the internet at all. I can ping the local router address 192.168.88.1, I can ping my external facing address but nothing further, not even my ISP gateway from the router or LAN PC's

I am using a CRS125-24G-1S on ROS 6.49.6 which is working fine on the same internet connection.

I have compared all internet settings that I can think of and all are correct between the 2 units.

1 x difference I have noticed though is on the route list for the CRS (6.49) it shows WAN reachable comments in the gateway section for the 0.0.0.0/0 entry, but not on the hex (7.6).

I am not sure if there is a setting that needs changing on 7.6 to allow internet access or that 7.6 is not compatible with my service provider, I am at a loss.

Please help this is driving me nuts.
Last edited by Darkside on Tue Oct 25, 2022 8:01 am, edited 1 time in total.
 
Darkside
just joined
Topic Author
Posts: 3
Joined: Mon Oct 24, 2022 4:05 am

Re: hEX on ROS 7.6

Mon Oct 24, 2022 4:39 am

# jan/02/1970 00:01:23 by RouterOS 7.6
# software id = BZ61-FREN
#
# model = RB750Gr3
# serial number = CC210FD614A8
/interface bridge
add admin-mac=DC:2C:6E:EC:F5:B2 auto-mac=no comment=defconf name=bridge
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp interface=bridge name=defconf
/port
set 0 name=serial0
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=\
192.168.88.0
/ip dhcp-client
add comment=defconf interface=ether1
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf dns-server=192.168.88.1 gateway=\
192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid disabled=yes
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
/ipv6 firewall address-list
add address=::/128 comment="defconf: unspecified address" list=bad_ipv6
add address=::1/128 comment="defconf: lo" list=bad_ipv6
add address=fec0::/10 comment="defconf: site-local" list=bad_ipv6
add address=::ffff:0.0.0.0/96 comment="defconf: ipv4-mapped" list=bad_ipv6
add address=::/96 comment="defconf: ipv4 compat" list=bad_ipv6
add address=100::/64 comment="defconf: discard only " list=bad_ipv6
add address=2001:db8::/32 comment="defconf: documentation" list=bad_ipv6
add address=2001:10::/28 comment="defconf: ORCHID" list=bad_ipv6
add address=3ffe::/16 comment="defconf: 6bone" list=bad_ipv6
/ipv6 firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMPv6" protocol=\
icmpv6
add action=accept chain=input comment="defconf: accept UDP traceroute" port=\
33434-33534 protocol=udp
add action=accept chain=input comment=\
"defconf: accept DHCPv6-Client prefix delegation." dst-port=546 protocol=\
udp src-address=fe80::/10
add action=accept chain=input comment="defconf: accept IKE" dst-port=500,4500 \
protocol=udp
add action=accept chain=input comment="defconf: accept ipsec AH" protocol=\
ipsec-ah
add action=accept chain=input comment="defconf: accept ipsec ESP" protocol=\
ipsec-esp
add action=accept chain=input comment=\
"defconf: accept all that matches ipsec policy" ipsec-policy=in,ipsec
add action=drop chain=input comment=\
"defconf: drop everything else not coming from LAN" in-interface-list=\
!LAN
add action=accept chain=forward comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop packets with bad src ipv6" src-address-list=bad_ipv6
add action=drop chain=forward comment=\
"defconf: drop packets with bad dst ipv6" dst-address-list=bad_ipv6
add action=drop chain=forward comment="defconf: rfc4890 drop hop-limit=1" \
hop-limit=equal:1 protocol=icmpv6
add action=accept chain=forward comment="defconf: accept ICMPv6" protocol=\
icmpv6
add action=accept chain=forward comment="defconf: accept HIP" protocol=139
add action=accept chain=forward comment="defconf: accept IKE" dst-port=\
500,4500 protocol=udp
add action=accept chain=forward comment="defconf: accept ipsec AH" protocol=\
ipsec-ah
add action=accept chain=forward comment="defconf: accept ipsec ESP" protocol=\
ipsec-esp
add action=accept chain=forward comment=\
"defconf: accept all that matches ipsec policy" ipsec-policy=in,ipsec
add action=drop chain=forward comment=\
"defconf: drop everything else not coming from LAN" in-interface-list=\
!LAN
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
 
holvoetn
Forum Guru
Forum Guru
Posts: 1813
Joined: Tue Apr 13, 2021 2:14 am
Location: Belgium

Re: hEX on ROS 7.6

Mon Oct 24, 2022 8:43 am

I have Hex running since (I think) march 2021 using first 6.<whateverithadoutofthebox>, going over various 7-betas, stable, ... , skipping a few beta-versions (not much) all the way up to 7.6.
Rarely (never ?) had an issue connecting to my ISP.

What device is used to connect to your ISP, the one between Hex and The Big Bad Web :lol: and how is that supposed to happen ? (PPPoE, ethernet, ...)
 
Darkside
just joined
Topic Author
Posts: 3
Joined: Mon Oct 24, 2022 4:05 am

Re: hEX on ROS 7.6

Mon Oct 24, 2022 8:54 am

Being in Australia it is complicated ; ). We have FTTC, so copper to the premise from the street, which connects to a NetCommWireless NDD-0300, then an Ethernet connection to the Mikrotik, using VDSL2.

it all works fine on 6.49 with my CRS, but everything i try on the hEX unit with 7.5 or7.6 results in no internet.

Who is online

Users browsing this forum: Ahrefs [Bot], Amazon [Bot], Bing [Bot] and 55 guests