Community discussions

MikroTik App
 
Skjeggape
just joined
Topic Author
Posts: 2
Joined: Wed Oct 26, 2022 6:45 pm

Help getting IPTV-Multicast working on Audience

Wed Oct 26, 2022 7:05 pm

Hello, as i keept experiencing power issues with my RB-750GL i've decided to replace it with a Audience. So far the Audience works exelente. However with the RB-750GL IPTV worked, but im at a loss with the Audience. I'm pretty sure i've managed to replicate/copy the working settings over to audience.
I have Wan ISP on "ether1" upstream, Alt.Subnets 0.0.0.0/0. Downstream is "ether2"
Also added neccesary and maybe a few uneccesary IP adresses to firewall rules and added rules for IGMP and UDP identical as on the 750GL. But no go, i just cant seem to get iptv working.
Also ISP dosnt use VLAN's for IPTV unless the changed something last two weeks.

Will be very happy if someone can help me getting this working XD

EXPORT config
# oct/26/2022 17:11:31 by RouterOS 6.49.7
# software id = 16WW-5DAP
#
# model = RBD25G-5HPacQD2HPnD
# serial number = HCX084DS60Y
/interface bridge
add admin-mac=18:FD:74:6A:B1:B6 auto-mac=no comment=defconf igmp-snooping=yes \
    igmp-version=3 multicast-querier=yes multicast-router=permanent name=\
    bridge
/interface wireless
# managed by CAPsMAN
# channel: 2412/20-Ce/gn(16dBm), SSID: Hovvarpne2,4N, local forwarding
set [ find default-name=wlan1 ] disabled=no ssid=MikroTik
# managed by CAPsMAN
# channel: 5180/20-Ceee/ac/P(18dBm), SSID: Hovvarpne5AC, local forwarding
set [ find default-name=wlan2 ] disabled=no ssid=MikroTik
/caps-man security
add authentication-types=wpa2-psk comment=defconf name=capSec passphrase=\
    ⋅⋅⋅⋅⋅⋅⋅⋅⋅
/caps-man configuration
add channel.band=2ghz-b/g/n channel.control-channel-width=20mhz \
    channel.extension-channel=XX comment=defconf country=norway \
    datapath.client-to-client-forwarding=yes datapath.local-forwarding=yes \
    distance=indoors installation=indoor name=cfg-2ghz security=capSec ssid=\
    Hovvarpne2,4N
add channel.band=5ghz-a/n/ac channel.control-channel-width=20mhz \
    channel.extension-channel=XXXX comment=defconf country=norway \
    datapath.client-to-client-forwarding=yes datapath.local-forwarding=yes \
    distance=indoors installation=indoor name=cfg-5ghz-ac security=capSec \
    ssid=Hovvarpne5AC
add channel.band=5ghz-a/n channel.control-channel-width=20mhz \
    channel.extension-channel=XX comment=defconf country=norway \
    datapath.client-to-client-forwarding=yes datapath.local-forwarding=yes \
    distance=indoors installation=indoor name=cfg-5ghz-an security=capSec \
    ssid=Hovvarpne5AC
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk comment=defconf disable-pmkid=yes mode=\
    dynamic-keys name=wpsSync supplicant-identity=MikroTik \
    wpa2-pre-shared-key=SorgalArt
/interface wireless
set [ find default-name=wlan3 ] band=5ghz-a/n/ac channel-width=20/40mhz-XX \
    disabled=no mode=ap-bridge security-profile=wpsSync ssid=SYNC-6AB1B9
/ip pool
add name=dhcp ranges=192.168.88.100-192.168.88.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/caps-man manager
set enabled=yes
/caps-man manager interface
set [ find default=yes ] forbid=yes
add comment=defconf disabled=no interface=bridge
/caps-man provisioning
add action=create-dynamic-enabled comment=defconf hw-supported-modes=gn \
    master-configuration=cfg-2ghz name-format=prefix-identity name-prefix=\
    2ghz
add action=create-dynamic-enabled comment=defconf hw-supported-modes=ac \
    master-configuration=cfg-5ghz-ac name-format=prefix-identity name-prefix=\
    5ghz-ac
add action=create-dynamic-enabled comment=defconf hw-supported-modes=an \
    master-configuration=cfg-5ghz-an name-format=prefix-identity name-prefix=\
    5ghz-an
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/interface wireless cap
# 
set bridge=bridge caps-man-addresses=127.0.0.1 enabled=yes interfaces=\
    wlan1,wlan2
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=\
    192.168.88.0
/ip dhcp-client
add comment=defconf disabled=no interface=ether1
/ip dhcp-server lease
add address=192.168.88.238 mac-address=68:63:59:9A:6F:3C server=defconf
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf dns-server=\
    130.67.15.198,193.213.112.4 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall address-list
add address=93.91.111.2 list="Telenor T-We"
add address=93.93.111.26 list="Telenor T-We"
add address=233.184.48.49 list="Telenor T-We"
add address=233.184.48.94 list="Telenor T-We"
add address=233.184.49.39 list="Telenor T-We"
add address=239.255.255.250 list="Telenor T-We"
add address=148.122.7.125 list="Telenor T-We"
add address=244.0.0.1 list="Telenor T-We"
add address=224.0.2.3 list="Telenor T-We"
add address=233.184.48.212 list="Telenor T-We"
add address=93.91.111.6 list="Telenor T-We"
add address=192.168.88.238 list="Telenor T-We"
/ip firewall filter
add action=accept chain=input comment=::IPTV protocol=igmp src-address-list=\
    "Telenor T-We"
add action=accept chain=forward protocol=igmp src-address-list="Telenor T-We"
add action=accept chain=input protocol=udp src-address-list="Telenor T-We"
add action=accept chain=forward protocol=udp src-address-list="Telenor T-We"
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid src-address-list="!Telenor T-We"
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec src-address-list="!Telenor T-We"
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec src-address-list="!Telenor T-We"
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN src-address-list=\
    "!Telenor T-We"
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid src-address-list="!Telenor T-We"
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN src-address-list="!Telenor T-We"
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
/ip service
set telnet disabled=yes
set ftp address=192.168.88.0/24
set www address=192.168.88.0/24
set ssh address=192.168.88.0/24
set api address=192.168.88.0/24
set winbox address=192.168.88.0/24
set api-ssl address=192.168.88.0/24
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=bridge type=internal
add interface=ether1 type=external
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 comment=::LAN interface=bridge threshold=3
add alternative-subnets=0.0.0.0/0 comment=::WAN interface=ether1 threshold=3 \
    upstream=yes
/system clock
set time-zone-name=Europe/Oslo
/system logging
add topics=igmp-proxy
add disabled=yes topics=debug
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
 
Skjeggape
just joined
Topic Author
Posts: 2
Joined: Wed Oct 26, 2022 6:45 pm

Re: Help getting IPTV-Multicast working on Audience  [SOLVED]

Mon Oct 31, 2022 1:07 pm

SOLVED

After upgrading to RouterOS 7.6 and setting Downstream interface to 'bridge' instead of 'ether1' Multicast traffic started working.

Who is online

Users browsing this forum: Hominidae and 25 guests