Community discussions

MikroTik App
 
Jeroen3
just joined
Topic Author
Posts: 5
Joined: Wed Jun 28, 2017 9:20 pm

ax2 ros7.6 pppoe mtu question (ipv6)

Wed Oct 26, 2022 10:16 pm

Hi

I'm playing with the new hap ax2 and trying to set it up right.

It looks like I'm having some mtu problems with the pppoe connection on fiber for ipv6. As discussed on this forum here and here.
I can add the mangle rules, that seems to alleviate the problem. (and the 100/100 fiber won't challenge the processor much anyway).
But why didn't I need those in router os 6.48.6?
What changed?

But I don't really understand what's going on, my ipv6 is skills are not that great yet. Learning a lot this week :) .
When I sniff the ethernet without the mangle rules I see some respons that target unreachable needs fragmentation, indicating the mikrotik passes packets too big?
My provider explicitely states (mtu) 1500 bytes (rfc4638) and now with most on default tcp-mss on and mangle rules the pppoe sets to 1492 mtu.

The mangle rules, for reference:
/ipv6 firewall mangle
add action=change-mss chain=forward comment="'fix' mtu problem pppoe" new-mss=clamp-to-pmtu passthrough=\
    yes protocol=tcp tcp-flags=syn
add action=change-mss chain=forward comment="'fix' mtu problem pppoe" in-interface=kpn-pppoe new-mss=\
    clamp-to-pmtu passthrough=yes protocol=tcp tcp-flags=sy
---
Wifi is great though, less power and smaller than the hap ac!

Who is online

Users browsing this forum: bibos, Google [Bot] and 34 guests