Community discussions

MikroTik App
 
AlvinTLC
just joined
Topic Author
Posts: 1
Joined: Tue Nov 08, 2022 4:01 pm

MPLS Network 40+ Routers

Tue Nov 08, 2022 4:14 pm

Hi we have a network with more than 40+ Routers, Mikrotik and Juniper

Juniper QFX5100 around 10
Mikrotik CCR2216 1
Mikrotik CCR2004 the rest

What happen when we try to do the MPLS connection we got duplicate routes, for example

Image

From this router where i took the picture i can ping and tracert to anywhere

Image
Image

This router has the next config

OSPF
/routing ospf instance
add disabled=no mpls-te-address=10.253.253.65 mpls-te-area=0.0.0.0 name=\
    TeleryV4 out-filter-chain=OSPF-OUT redistribute=connected,static router-id=\
    10.253.253.65
add disabled=no name=TeleryV6 redistribute=connected,static router-id=\
    10.253.253.65 version=3
/routing ospf area
add disabled=no instance=TeleryV4 name=TeleryV4-Area
add disabled=no instance=TeleryV6 name=TeleryV6-Area
/routing ospf interface-template
add area=TeleryV4-Area disabled=no interfaces=sfp-sfpplus12 type=ptp
add area=TeleryV4-Area auth=simple auth-id=1 auth-key="0zY@0\$pF" disabled=no \
    interfaces=sfp-sfpplus2 type=ptp
add area=TeleryV4-Area disabled=no interfaces=sfp-sfpplus11 type=ptp
add area=TeleryV4-Area disabled=no interfaces=Loopback networks=\
    10.253.253.65/32 passive
MPLS
/mpls interface
add disabled=no input=yes interface=sfp-sfpplus11 mpls-mtu=1550
add disabled=no input=yes interface=sfp-sfpplus12 mpls-mtu=1550
/mpls ldp
add afi=ip disabled=no distribute-for-default=no loop-detect=no lsr-id=\
    10.253.253.65 transport-addresses=10.253.253.65 use-explicit-null=no vrf=\
    main
/mpls ldp accept-filter
add accept=yes disabled=no prefix=10.254.254.0/24
add accept=yes disabled=no prefix=10.253.253.0/24
add accept=no disabled=no prefix=0.0.0.0/0
/mpls ldp advertise-filter
add advertise=yes disabled=no prefix=10.254.254.0/0
add advertise=yes disabled=no prefix=10.253.253.0/0
add advertise=yes disabled=no prefix=172.16.64.0/20
add advertise=no disabled=no prefix=0.0.0.0/0
/mpls ldp interface
add disabled=no interface=all
/mpls traffic-eng interface
add bandwidth=10Gbps disabled=no interface=sfp-sfpplus11
add bandwidth=10Gbps disabled=no interface=sfp-sfpplus12

From this router we can do everything VPLS tunnels and other things working as is.

But for the next router in the sfp-sfpplus11 from this router

Image
i could ping the 10.253.253.43 directly because 10.253.253.64 this router is directly connected to
Image
but the 10.253.253.66 is connected to 10.253.253.43 and to 10.253.253.102 when the ring is closed

from this router i cant ping or open a vpls connection

Config for this router
/routing ospf instance
add disabled=no mpls-te-address=10.253.253.64 mpls-te-area=0.0.0.0 name=\
    OZYTELv4-v2 out-filter-chain=OSPF-OUT redistribute=connected,static \
    router-id=10.253.253.64 routing-table=main
/routing ospf area
add disabled=no instance=OZYTELv4-v2 name=backbone-v2
/routing ospf interface-template
add area=backbone-v2 cost=10 disabled=no interfaces=sfp-sfpplus1 networks=\
    172.16.68.12/30 priority=1 type=ptp
add area=backbone-v2 auth-id=1 auth-key="" cost=10 disabled=no interfaces=\
    Loopback networks=10.253.253.64 passive priority=1
add area=backbone-v2 cost=100 disabled=no interfaces=sfp-sfpplus2 networks=\
    172.16.68.16/30 priority=2 type=ptp
add area=backbone-v2 cost=10 disabled=no interfaces=sfp-sfpplus4 networks=\
    172.16.68.28/30 priority=1 type=ptp
MPLS
/mpls interface
add disabled=no input=yes interface=sfp-sfpplus1 mpls-mtu=1548
add disabled=no input=yes interface=sfp-sfpplus2 mpls-mtu=1548
/mpls ldp
add afi=ip disabled=no distribute-for-default=no loop-detect=no lsr-id=\
    10.253.253.64 transport-addresses=10.253.253.64 use-explicit-null=no vrf=\
    main
/mpls ldp accept-filter
add accept=yes disabled=no prefix=10.253.253.0/24
add accept=yes disabled=no prefix=10.254.254.0/24
add accept=yes disabled=no prefix=172.16.64.0/20
add accept=no disabled=no prefix=0.0.0.0/0
/mpls ldp advertise-filter
add advertise=yes disabled=no prefix=10.253.253.0/24
add advertise=yes disabled=no prefix=10.254.254.0/24
add advertise=yes disabled=no prefix=172.16.64.0/20
add advertise=no disabled=no prefix=0.0.0.0/0
/mpls ldp interface
add disabled=no interface=all
Thanks in advance if you have any option for me

10.253.253.65 and 10.253.253.64 are mikrotik ccr2004
10.253.253.102, 10.253.253.92, 10.253.253.74, 10.253.253.43 10.253.253.66 are junipers.

Thanks.

Who is online

Users browsing this forum: No registered users and 7 guests