How do I enable IGMP Snooping when using bridge+VLANs?
Posted: Tue Nov 15, 2022 3:46 pm
Crosspost Reddit thread
So I have a single CCR1036 on ROS 7.6 whereby I used this config guide to configure bridge and bridged based VLAN:
viewtopic.php?t=143620#p706998
Also, because MikroTik recommends that type of config for this model:
https://help.mikrotik.com/docs/display/ ... switchchip
Now the good news is, this is working correctly for IPv4/IPv6 traffic unicast. However, the moment I enable multicast carrier on the bridge itself, IPv6 SLAAC/RA/NA/NS traffic all begins to break and no longer works.
So am I doing something wrong with the IGMP Snooping config when using bridge/VLAN? How do I get IGMP snooping to work in the simplest way possible for my VLAN based config?
Below is my config sample export that is working but without multicast carrier enabled.
So I have a single CCR1036 on ROS 7.6 whereby I used this config guide to configure bridge and bridged based VLAN:
viewtopic.php?t=143620#p706998
Also, because MikroTik recommends that type of config for this model:
https://help.mikrotik.com/docs/display/ ... switchchip
Now the good news is, this is working correctly for IPv4/IPv6 traffic unicast. However, the moment I enable multicast carrier on the bridge itself, IPv6 SLAAC/RA/NA/NS traffic all begins to break and no longer works.
So am I doing something wrong with the IGMP Snooping config when using bridge/VLAN? How do I get IGMP snooping to work in the simplest way possible for my VLAN based config?
Below is my config sample export that is working but without multicast carrier enabled.
Code: Select all
/interface bridge
add frame-types=admit-only-vlan-tagged igmp-snooping=yes igmp-version=3 mld-version=2 name=bridge1 vlan-filtering=yes
/interface bridge port
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged interface=ether1 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged interface=ether2 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged interface=ether3 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged interface=ether4 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged interface=ether5 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged interface=ether6 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged interface=ether7 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged interface=ether8 pvid=10
/interface bridge vlan
add bridge=bridge1 comment="Main VLAN" tagged=bridge1 vlan-ids=20
add bridge=bridge1 comment="Management VLAN" tagged=bridge1 vlan-ids=10
/interface vlan
add interface=bridge1 name="Main VLAN" vlan-id=20
add interface=bridge1 name="Management VLAN" vlan-id=10