Community discussions

MikroTik App
 
tukusejssirs
just joined
Topic Author
Posts: 1
Joined: Wed Nov 16, 2022 1:42 pm

Add a additional dynamic CAP interface to existing CAPsMAN configuration

Wed Nov 16, 2022 2:23 pm

I have Mikrotik RB40111iGS (router) and cAP ac (AP). I have configured (with a friend’s help some time ago) CAPsMan (on the router) to include 2.4 GHz and 5 GHz wireless interfaces of the router and 2.4 GHz wireless interface of the AP, all of them as dynamic CAP interfaces.

Now, I’d like to add 5 GHz wireless interface of the AP to CAPsMAN. I have no idea how to do that.

Although OT to the main issue in this post, however, I can’t make clients (phones, computers) that are connected to the network wirelessly (or at least both of them are connected via router) ping each other. I’ve read that I need to enable local forwarding and/or client-to-client forwarding, however, I have them both enabled on both router and AP.

See the attached configs of both devices.

Note that I use RouterOS 6.49.7 (I haven’t upgraded yet to v7).

Anyway, if you’d like to suggest some improvements to the configs, I’ll be really grateful!
You do not have the required permissions to view the files attached to this post.
 
User avatar
BrateloSlava
Member Candidate
Member Candidate
Posts: 132
Joined: Mon Aug 09, 2021 10:33 am
Location: Ukraine, Kharkiv

Re: Add a additional dynamic CAP interface to existing CAPsMAN configuration

Thu Nov 17, 2022 11:03 am

Firstly. Make a backup before making changes. Stop CAPsMAN. Remove all wireless interface names from existing bridges. On the router itself and on the access point.

Further. The CAPsMAN configuration, that you have set up, does not have a description of the parameters for frequencies in the 2.4 and 5 GHz bands.

I would recommend that you use a Google search for a "normal" step by step guide to setting up CAPsMAN.

As an example, made with one of my configurations, I demonstrate a configuration option (for ROS 7)
### Describe the parameters of "channels". that will be used for wireless interfaces.
/caps-man channel add band=5ghz-onlyac control-channel-width=20mhz extension-channel=XX frequency=5180,5220,5745,5805 name=channel-AW-50 save-selected=no tx-power=14
/caps-man channel add band=2ghz-onlyn control-channel-width=20mhz extension-channel=disabled frequency=2412,2437,2462 name=channel-AW-24 save-selected=no tx-power=10

### Describe the parameters of "datapath"
/caps-man datapath add bridge=bridge1 client-to-client-forwarding=yes interface-list=LAN local-forwarding=yes name=datapath-local-forwarding
/caps-man datapath add bridge=bridge1 client-to-client-forwarding=yes interface-list=LAN name=datapath-capsman-forwarding

### Describe the "configuration" parameters that will be used for the 2.4 and 5 GHz bands.
/caps-man configuration add channel=channel-AW-24 country=ukraine datapath=datapath-capsman-forwarding disconnect-timeout=5s distance=indoors frame-lifetime=5s guard-interval=any hw-protection-mode=rts-cts hw-retries=5 installation=any max-sta-count=20 mode=ap name=AW-cfg-2.4GHz-capsman rates.vht-basic-mcs="" .vht-supported-mcs="" rx-chains=0,1,2 security.authentication-types=wpa2-psk .disable-pmkid=yes .encryption=aes-ccm .group-encryption=aes-ccm .group-key-update=1h .passphrase=SecreT-Passw0rd ssid=MainWiFi tx-chains=0,1,2
/caps-man configuration add channel=channel-AW-50 country="united states" datapath=datapath-capsman-forwarding disconnect-timeout=5s distance=indoors frame-lifetime=5s guard-interval=any hw-protection-mode=rts-cts hw-retries=5 installation=any max-sta-count=20 mode=ap name=AW-cfg-5.0GHz-capsman rates.vht-supported-mcs="" rx-chains=0,1,2,3 security.authentication-types=wpa2-psk .disable-pmkid=yes .encryption=aes-ccm .group-encryption=aes-ccm .group-key-update=1h .passphrase=SecreT-Passw0rd ssid=MainWiFi tx-chains=0,1,2,3

### Describe the parameters that will be used by access points when connecting to CAPsMAN.
/caps-man provisioning add action=create-dynamic-enabled comment=Other hw-supported-modes=g,gn master-configuration=AW-cfg-2.4GHz-capsman name-format=identity
/caps-man provisioning add action=create-dynamic-enabled hw-supported-modes=an,ac master-configuration=AW-cfg-5.0GHz-capsman name-format=identity

By the way. And I also recommend revising the firewall settings.

Who is online

Users browsing this forum: Bing [Bot] and 12 guests